aboutsummaryrefslogtreecommitdiff
path: root/games/xblast
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-05-02 14:16:49 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-05-02 14:16:49 +0000
commitdd6f9aecd223894fd0211f09b7a15f4a3a89bcfc (patch)
tree78e72938e9ae1fafd84cf8b4b69b5d7c261245bd /games/xblast
parent504cac19e8af2daa15b41035a8c601571db30990 (diff)
downloadports-dd6f9aecd223894fd0211f09b7a15f4a3a89bcfc.tar.gz
ports-dd6f9aecd223894fd0211f09b7a15f4a3a89bcfc.zip
Convert graphics/sdl_gfx to USES=libtool. Also set USE_AUTOTOOLS because
upstream forgot to regenerate the build scripts. This makes the build use the correct version information and causes a library version bump. Use this opportunity to use USES=libtool instead of USES=libtool:oldver. Bump PORTREVISION on all dependent ports and convert them to USES=libtool where needed. Also use USES=(gmake, pathfix, tar) and new LIB_DEPENDS syntax here and there. games/freedink-engine: - Option helpers. - Staging. - Use dirrmtry for locale directories. games/oolite: - Staging. - Replace ECHO with ECHO_CMD. - Don't use GNUSTEP_PREFIX to install files because it expands to LOCALBASE rather than PREFIX. games/openssn: - Remove USES=desktop-file-utils. No MimeType field in desktop file. - Staging. - Install files in standard DATADIR. games/xblast: - Use proper options. - Staging. - Patch configure so normal make install can be used instead of do-install. - Replace TAR | TAR with COPYTREE_SHARE.
Notes
Notes: svn path=/head/; revision=352815
Diffstat (limited to 'games/xblast')
-rw-r--r--games/xblast/Makefile129
-rw-r--r--games/xblast/pkg-plist3
2 files changed, 43 insertions, 89 deletions
diff --git a/games/xblast/Makefile b/games/xblast/Makefile
index b7c89782c4db..848ee6e22fea 100644
--- a/games/xblast/Makefile
+++ b/games/xblast/Makefile
@@ -3,26 +3,18 @@
PORTNAME= xblast
PORTVERSION= 2.10.4
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Sources/${PORTVERSION} \
SF/${PORTNAME}/Images/${IMAGES_DATE}:images \
SF/${PORTNAME}/Levels/${LEVELS_DATE}:levels \
- SF/${PORTNAME}/Models/${MODELS_DATE}:models
-.if !defined(WITHOUT_SOUND)
-MASTER_SITES+= SF/${PORTNAME}/Musics/${MUSICS_DATE}:musics \
+ SF/${PORTNAME}/Models/${MODELS_DATE}:models \
+ SF/${PORTNAME}/Musics/${MUSICS_DATE}:musics \
SF/${PORTNAME}/Sounds/${SOUNDS_DATE}:sounds
-.else
-PKGNAMESUFFIX= -nosound
-.endif
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
images-${IMAGES_DATE}${EXTRACT_SUFX}:images \
levels-${LEVELS_DATE}${EXTRACT_SUFX}:levels \
models-${MODELS_DATE}${EXTRACT_SUFX}:models
-.if !defined(WITHOUT_SOUND)
-DISTFILES+= musics-${MUSICS_DATE}${EXTRACT_SUFX}:musics \
- sounds${EXTRACT_SUFX}:sounds
-.endif
DIST_SUBDIR= xblast
MAINTAINER= ports@FreeBSD.org
@@ -31,21 +23,9 @@ COMMENT= Multi-player real-time strategy game for X11
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-.if defined(WITHOUT_SOUND)
-WITHOUT_SDL= yes
-.endif
-.if !defined(WITHOUT_SDL)
-WANT_SDL= yes
-.endif
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-admin
-MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOHEADER="${TRUE}" \
- AUTOMAKE="${TRUE}"
-
-MAN6= xblast.6
-
-DATADIR= ${PREFIX}/share/XBlast-TNT
+CONFIGURE_ARGS= --with-otherdatadir=${DATADIR}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -58,84 +38,57 @@ MODELS_DATE= 2005-01-06
MUSICS_DATE= 2005-01-06
SOUNDS_DATE= 2004-04-29
-NO_STAGE= yes
-
-OPTIONS_DEFINE= NLS
+OPTIONS_DEFINE= NLS SDL SMPF SOUND
+OPTIONS_DEFAULT=SDL SOUND
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+SDL_USE= SDL=gfx,image,mixer,net,ttf,sdl
+SDL_CONFIGURE_ENABLE= sdl
+SDL_RUN_DEPENDS= ${FONTSDIR}/Vera.ttf:${PORTSDIR}/x11-fonts/bitstream-vera
+SMPF_DESC= Support for 16 players
+SMPF_CONFIGURE_ENABLE= SMPF
+SOUND_CONFIGURE_ENABLE= sound
+SOUND_DISTFILES= musics-${MUSICS_DATE}${EXTRACT_SUFX}:musics \
+ sounds${EXTRACT_SUFX}:sounds
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-.if defined(WITHOUT_SDL)
+.if ! ${PORT_OPTIONS:MSDL}
USE_XORG= ice x11
-CONFIGURE_ARGS+= --disable-sdl
-PLIST_SUB+= NOSDL=""
-.else
-RUN_DEPENDS+= ${FONTSDIR}/Vera.ttf:${PORTSDIR}/x11-fonts/bitstream-vera
-USE_SDL+= gfx image mixer net ttf sdl
-CONFIGURE_ARGS+= --enable-sdl
-PLIST_SUB+= NOSDL="@comment "
.endif
-.if defined(WITHOUT_SOUND)
-CONFIGURE_ARGS+= --disable-sound
-PLIST_SUB+= SOUND="@comment "
-.else
-CONFIGURE_ARGS+= --enable-sound
-PLIST_SUB+= SOUND=""
-.endif
-
-.if defined(WITH_SMPF)
-CONFIGURE_ARGS+= --enable-SMPF
-.endif
+post-extract:
+ -@${MV} ${WRKDIR}/levels-${LEVELS_DATE}/reconstruct?on2.xal ${WRKDIR}/levels-${LEVELS_DATE}/reconstruction2.xal
post-patch:
- @${REINPLACE_CMD} -e 's|/games/|/|g ; \
- /-ggdb/d' ${WRKSRC}/configure
+ @${TOUCH} -r ${WRKSRC}/configure ${WRKSRC}/aclocal.m4
@${REINPLACE_CMD} -e \
's|$$(game_datadir)/locale|$$(prefix)/share/locale|g ; \
s|^xblast_LDADD =.*$$|xblast_LDADD = $$(LIBINTL)|g' \
${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} '/datadir=$$game_datadir/d' ${WRKSRC}/configure
@${REINPLACE_CMD} -e \
's|"Vera.ttf"|"${FONTSDIR}/Vera.ttf"|g' ${WRKSRC}/sdl_text.c
- -@${MV} ${WRKDIR}/levels-${LEVELS_DATE}/reconstruct?on2.xal ${WRKDIR}/levels-${LEVELS_DATE}/reconstruction2.xal
-do-install:
- cd ${WRKSRC} && ${INSTALL_PROGRAM} xblast ${PREFIX}/bin/xblast
-.if defined(WITHOUT_SDL) && !defined(WITHOUT_SOUND)
- cd ${WRKSRC} && ${INSTALL_PROGRAM} xbsndsrv ${PREFIX}/bin/xbsndsrv
-.endif
- cd ${WRKSRC} && ${INSTALL_MAN} xblast.man ${MAN6PREFIX}/man/man6/xblast.6
-.if ${PORT_OPTIONS:MNLS}
-.for lang in de fr
- @${MKDIR} ${PREFIX}/share/locale/${lang}/LC_MESSAGES
- cd ${WRKSRC}/po && ${INSTALL_DATA} ${lang}.gmo \
- ${PREFIX}/share/locale/${lang}/LC_MESSAGES/xblast.mo
-.endfor
-.endif
- @${MKDIR} ${DATADIR}/image
- @(${TAR} -C ${WRKDIR}/images-${IMAGES_DATE} --exclude "Imakefile" \
- -cf - . | ${TAR} -C ${DATADIR}/image --unlink -xf -)
- @${MKDIR} ${DATADIR}/level
- @(${TAR} -C ${WRKDIR}/levels-${LEVELS_DATE} --exclude "Imakefile" \
- -cf - . | ${TAR} -C ${DATADIR}/level --unlink -xf -)
- @${MKDIR} ${DATADIR}/image/sprite
- @(${TAR} -C ${WRKDIR}/models-${MODELS_DATE} --exclude "Imakefile" \
- -cf - . | ${TAR} -C ${DATADIR}/image/sprite --unlink -xf -)
-.if !defined(WITHOUT_SOUND)
- @${MKDIR} ${DATADIR}/sounds
- @(${TAR} -C ${WRKDIR}/musics-${MUSICS_DATE} --exclude "Imakefile" \
- -cf - . | ${TAR} -C ${DATADIR}/sounds --unlink -xf -)
- @(${TAR} -C ${WRKDIR}/sounds --exclude "Imakefile" \
- -cf - . | ${TAR} -C ${DATADIR}/sounds --unlink -xf -)
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/xblast.man ${STAGEDIR}${MAN6PREFIX}/man/man6/xblast.6
+ ${MKDIR} ${STAGEDIR}${DATADIR}/image
+ cd ${WRKDIR}/images-${IMAGES_DATE} && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/image "-not -name Imakefile"
+ ${MKDIR} ${STAGEDIR}${DATADIR}/level
+ cd ${WRKDIR}/levels-${LEVELS_DATE} && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/level "-not -name Imakefile"
+ ${MKDIR} ${STAGEDIR}${DATADIR}/image/sprite
+ cd ${WRKDIR}/models-${MODELS_DATE} && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/image/sprite "-not -name Imakefile"
+.if ${PORT_OPTIONS:MSOUND}
+ ${MKDIR} ${STAGEDIR}${DATADIR}/sounds
+ cd ${WRKDIR}/musics-${MUSICS_DATE} && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/sounds "-not -name Imakefile"
+ cd ${WRKDIR}/sounds && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/sounds "-not -name Imakefile"
.endif
- @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
- @${FIND} ${DATADIR} -type d -exec ${CHMOD} 755 {} \;
- @${FIND} ${DATADIR} -type f -exec ${CHMOD} ${SHAREMODE} {} \;
.include <bsd.port.mk>
diff --git a/games/xblast/pkg-plist b/games/xblast/pkg-plist
index 7f4d21bcfb5c..6ae1bf14ad60 100644
--- a/games/xblast/pkg-plist
+++ b/games/xblast/pkg-plist
@@ -1,5 +1,6 @@
bin/xblast
-%%NOSDL%%%%SOUND%%bin/xbsndsrv
+%%NO_SDL%%%%SOUND%%bin/xbsndsrv
+man/man6/xblast.6.gz
%%NLS%%share/locale/de/LC_MESSAGES/xblast.mo
%%NLS%%share/locale/fr/LC_MESSAGES/xblast.mo
%%DATADIR%%/image/block/EPFL_stop.ppm