aboutsummaryrefslogtreecommitdiff
path: root/games/xbomb
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1998-02-20 09:31:39 +0000
committerThomas Gellekum <tg@FreeBSD.org>1998-02-20 09:31:39 +0000
commitb5d40eb0b9d3adfb7707953196cd4b79c94642f7 (patch)
tree9663e91f6a8e4e3eeb61420c2064f669edfa669f /games/xbomb
parent0cfd42308a5f91aff945f804f2b32d6c1091794b (diff)
downloadports-b5d40eb0b9d3adfb7707953196cd4b79c94642f7.tar.gz
ports-b5d40eb0b9d3adfb7707953196cd4b79c94642f7.zip
Did I mention that we don't have enough minesweeper clones? Try the
triangle mode on this one.
Notes
Notes: svn path=/head/; revision=9856
Diffstat (limited to 'games/xbomb')
-rw-r--r--games/xbomb/Makefile25
-rw-r--r--games/xbomb/distinfo1
-rw-r--r--games/xbomb/files/patch-aa53
-rw-r--r--games/xbomb/files/patch-ab13
-rw-r--r--games/xbomb/pkg-comment1
-rw-r--r--games/xbomb/pkg-descr22
-rw-r--r--games/xbomb/pkg-plist7
7 files changed, 122 insertions, 0 deletions
diff --git a/games/xbomb/Makefile b/games/xbomb/Makefile
new file mode 100644
index 000000000000..afe41379a538
--- /dev/null
+++ b/games/xbomb/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: xbomb
+# Version required: 2.1
+# Date created: 20 Feb 1998
+# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= xbomb-2.1
+CATEGORIES= games
+MASTER_SITES= ftp://ftp.demon.co.uk/pub/unix/xwindows/games/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.ORG
+
+USE_X11= yes
+MAN6= xbomb.6
+
+post-install:
+ @${MKDIR} ${PREFIX}/lib/X11/xbomb
+ @touch ${PREFIX}/lib/X11/xbomb/xbomb3.hi
+ @touch ${PREFIX}/lib/X11/xbomb/xbomb4.hi
+ @touch ${PREFIX}/lib/X11/xbomb/xbomb6.hi
+
+.include <bsd.port.mk>
diff --git a/games/xbomb/distinfo b/games/xbomb/distinfo
new file mode 100644
index 000000000000..5fb4c3b05458
--- /dev/null
+++ b/games/xbomb/distinfo
@@ -0,0 +1 @@
+MD5 (xbomb-2.1.tgz) = 4c3284096bcfb00eee0fb3b096378b56
diff --git a/games/xbomb/files/patch-aa b/games/xbomb/files/patch-aa
new file mode 100644
index 000000000000..805b862dd68d
--- /dev/null
+++ b/games/xbomb/files/patch-aa
@@ -0,0 +1,53 @@
+--- Makefile.orig Sat Jan 20 22:02:46 1996
++++ Makefile Fri Feb 20 10:27:38 1998
+@@ -12,33 +12,27 @@
+ # for conditions under which this file may be redistributed.
+ #
+
+-CC=gcc
+-CFLAGS=-O2
+-
+-INCLUDES=
++#CC=gcc
++CFLAGS+= -I${X11BASE}/include -DX11BASE=\"${X11BASE}\"
+
+ LIB=
+
+-XLIB=-L/usr/X11R6/lib -lXaw -lXmu -lXt -lX11
+-
+-COMPILE=$(CC) -c $(CFLAGS)
++XLIB=-L${X11BASE}/lib -lXaw -lXmu -lXt -lX11 -lcompat
+
+ LINK=$(CC)
+
+ OBJ=xbomb.o xwindow.o hiscore.o
+
+-INSTDIR=/usr/local
++INSTDIR=${PREFIX}
+
+ ########
++all: xbomb
+
+ xbomb : $(OBJ)
+ $(LINK) $(OBJ) -o $@ $(LIB) $(XLIB)
+
+ ########
+
+-%.o : %.c
+- $(COMPILE) $< -o $@ $(INCLUDES)
+-
+ xbomb.o : xbomb.c xbomb.h
+ xwindow.o : xwindow.c xbomb.h icon.h
+ hiscore.o : hiscore.c xbomb.h
+@@ -54,7 +48,7 @@
+ strip xbomb
+ install -d $(INSTDIR)/bin
+ install -d $(INSTDIR)/man/man6
+- install -d $(INSTDIR)/lib/app-defaults
+- install -m 755 xbomb $(INSTDIR)/bin
+- install -m 644 xbomb.6 $(INSTDIR)/man/man6
+- install -m 644 xbomb.ad $(INSTDIR)/lib/app-defaults/XBomb
++ install -d $(INSTDIR)/lib/X11/app-defaults
++ ${BSD_INSTALL_PROGRAM} xbomb $(INSTDIR)/bin
++ ${BSD_INSTALL_MAN} xbomb.6 $(INSTDIR)/man/man6
++ ${BSD_INSTALL_SCRIPT} xbomb.ad $(INSTDIR)/lib/X11/app-defaults/XBomb
diff --git a/games/xbomb/files/patch-ab b/games/xbomb/files/patch-ab
new file mode 100644
index 000000000000..5ea85294a405
--- /dev/null
+++ b/games/xbomb/files/patch-ab
@@ -0,0 +1,13 @@
+--- hiscore.c.orig Fri Jan 16 20:50:39 1998
++++ hiscore.c Fri Feb 20 10:23:20 1998
+@@ -47,7 +47,9 @@
+ nbombs[NLEVELS]; /*+ number of bombs. +*/
+
+ /*+ The names of the high score tables. +*/
+-static char *filenames[NTYPES]={"/var/tmp/xbomb6.hi","/var/tmp/xbomb4.hi","/var/tmp/xbomb3.hi"};
++static char *filenames[NTYPES]={X11BASE"/lib/X11/xbomb/xbomb6.hi",
++ X11BASE"/lib/X11/xbomb/xbomb4.hi",
++ X11BASE"/lib/X11/xbomb/xbomb3.hi"};
+
+ /*+ The names of the positions in the high score tables. +*/
+ static char pos[11][5]={"Top","2nd","3rd","4th","5th","6th","7th","8th","9th","10th","Lost"};
diff --git a/games/xbomb/pkg-comment b/games/xbomb/pkg-comment
new file mode 100644
index 000000000000..c7c5b6ffd973
--- /dev/null
+++ b/games/xbomb/pkg-comment
@@ -0,0 +1 @@
+Minesweeper with a couple of grid types.
diff --git a/games/xbomb/pkg-descr b/games/xbomb/pkg-descr
new file mode 100644
index 000000000000..2578bad7af84
--- /dev/null
+++ b/games/xbomb/pkg-descr
@@ -0,0 +1,22 @@
+A program that looks superficially like the minesweeper program that
+comes supplied with MS Windows (and is also available in other
+versions). Runs under X Windows on the UNIX operating system.
+
+Features
+--------
+There are a number of features that make this version different from
+the others available (that I have seen).
+
+3 Grid Tile options
+ Hexagonal - Easy (the endgame can be difficult).
+ Square - Traditional.
+ Triangular - Difficult.
+
+3 Grid sizes
+ Small - 8x8 with 10 bombs
+ Medium - 16x16 with 40 bombs
+ Large - 30x16 with 99 bombs
+
+Highscore table
+ 10 entries for the fastest times for each of the 3 levels of
+ each of the 3 grid shapes.
diff --git a/games/xbomb/pkg-plist b/games/xbomb/pkg-plist
new file mode 100644
index 000000000000..44dff9a25111
--- /dev/null
+++ b/games/xbomb/pkg-plist
@@ -0,0 +1,7 @@
+bin/xbomb
+man/man6/xbomb.6.gz
+lib/X11/app-defaults/XBomb
+lib/X11/xbomb/xbomb3.hi
+lib/X11/xbomb/xbomb4.hi
+lib/X11/xbomb/xbomb6.hi
+@dirrm lib/X11/xbomb