aboutsummaryrefslogtreecommitdiff
path: root/games/xchadance
diff options
context:
space:
mode:
authorSeiichirou Hiraoka <flathill@FreeBSD.org>1999-02-20 00:48:21 +0000
committerSeiichirou Hiraoka <flathill@FreeBSD.org>1999-02-20 00:48:21 +0000
commit06216e20eabe920a85977c599ae7a27a1345b09f (patch)
treee985ba75fe7fadea10f01bdef60af035613aaed1 /games/xchadance
parent0b19c45675b23854f5bb6d24dfec8e3b5cce9d0e (diff)
downloadports-06216e20eabe920a85977c599ae7a27a1345b09f.tar.gz
ports-06216e20eabe920a85977c599ae7a27a1345b09f.zip
Submitted by: issei@jp.FreeBSD.ORG
Display a dancing girl "ChaCha." She dance, dance and dance forever on your desktop. Enjoy!
Notes
Notes: svn path=/head/; revision=16784
Diffstat (limited to 'games/xchadance')
-rw-r--r--games/xchadance/Makefile40
-rw-r--r--games/xchadance/distinfo1
-rw-r--r--games/xchadance/files/patch-aa26
-rw-r--r--games/xchadance/pkg-comment1
-rw-r--r--games/xchadance/pkg-descr3
-rw-r--r--games/xchadance/pkg-plist4
6 files changed, 75 insertions, 0 deletions
diff --git a/games/xchadance/Makefile b/games/xchadance/Makefile
new file mode 100644
index 000000000000..4431ce348a22
--- /dev/null
+++ b/games/xchadance/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: xchadance
+# Version required: 1.0
+# Date created: 21 August 1998
+# Whom: issei <issei@jp.FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= xchada01
+PKGNAME= xchadance-1.0
+CATEGORIES= games
+MASTER_SITES= http://www.jp.FreeBSD.ORG/~issei/LOCAL_PORTS/
+EXTRACT_SUFX= .lzh
+
+MAINTAINER= issei@jp.FreeBSD.ORG
+
+BUILD_DEPENDS= lha:${PORTSDIR}/archivers/lha
+
+MAKEFILE= makefile
+USE_X_PREFIX= yes
+NO_WRKSUBDIR= yes
+
+EXTRACT_CMD= lha
+EXTRACT_BEFORE_ARGS= e
+EXTRACT_AFTER_ARGS=
+
+RESTRICTED= 'contains commercial character data'
+
+post-patch:
+ @cd ${WRKSRC}; \
+ ${PATCH} < ${WRKSRC}/xchada01.bug
+
+post-install:
+.if !defined(NOPORTOCS)
+ @${MKDIR} ${PREFIX}/share/doc/xchadance
+ @${INSTALL_DATA} ${WRKSRC}/README.jp ${PREFIX}/share/doc/xchadance
+ @${INSTALL_DATA} ${WRKSRC}/README.eng ${PREFIX}/share/doc/xchadance
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/xchadance/distinfo b/games/xchadance/distinfo
new file mode 100644
index 000000000000..b7951359d169
--- /dev/null
+++ b/games/xchadance/distinfo
@@ -0,0 +1 @@
+MD5 (xchada01.lzh) = 7ca27f4f7f976798d2f2b02c0c340f8f
diff --git a/games/xchadance/files/patch-aa b/games/xchadance/files/patch-aa
new file mode 100644
index 000000000000..5412997e8624
--- /dev/null
+++ b/games/xchadance/files/patch-aa
@@ -0,0 +1,26 @@
+--- makefile.orig Mon Mar 7 22:10:46 1994
++++ makefile Fri Feb 19 08:58:24 1999
+@@ -1,6 +1,7 @@
+ CC = gcc
+-CFLAGS = -Wall -O
+-BINDIR = /usr/local/bin/
++CFLAGS+= -I${PREFIX}/include
++LDFLAGS+= -L${PREFIX}/lib -lX11
++BINDIR= ${PREFIX}/bin/
+
+
+ all : xchadance
+@@ -9,11 +10,11 @@
+ rm *.o *~ *.bak core.* a.out
+
+ install :
+- cp xchadance $(BINDIR)
++ install -s xchadance $(BINDIR)
+
+
+ xchadance : xchadance.o chadata.o
+- $(CC) xchadance.o chadata.o -o xchadance -lX11
++ $(CC) xchadance.o chadata.o -o xchadance ${LDFLAGS}
+
+
+ xchadance.o : xchadance.c xchadance.h
diff --git a/games/xchadance/pkg-comment b/games/xchadance/pkg-comment
new file mode 100644
index 000000000000..6f9f70162a32
--- /dev/null
+++ b/games/xchadance/pkg-comment
@@ -0,0 +1 @@
+Display a dancing girl "ChaCha."
diff --git a/games/xchadance/pkg-descr b/games/xchadance/pkg-descr
new file mode 100644
index 000000000000..29d58ccbacaf
--- /dev/null
+++ b/games/xchadance/pkg-descr
@@ -0,0 +1,3 @@
+Display a dancing girl "ChaCha."
+
+She dance, dance and dance forever on your desktop. Enjoy!
diff --git a/games/xchadance/pkg-plist b/games/xchadance/pkg-plist
new file mode 100644
index 000000000000..e28661063cf0
--- /dev/null
+++ b/games/xchadance/pkg-plist
@@ -0,0 +1,4 @@
+bin/xchadance
+share/doc/xchadance/README.eng
+share/doc/xchadance/README.jp
+@dirrm share/doc/xchadance