aboutsummaryrefslogtreecommitdiff
path: root/games/xdino
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1996-11-16 12:49:19 +0000
committerSatoshi Asami <asami@FreeBSD.org>1996-11-16 12:49:19 +0000
commit79e72437d817a3f56aee807fb6a47b8a1af86afe (patch)
tree2f76d6707a407a0f4736db40d1bdf887d31a320f /games/xdino
parent4803609bdda9045b6d1694feb95ed332c5e003c8 (diff)
downloadports-79e72437d817a3f56aee807fb6a47b8a1af86afe.tar.gz
ports-79e72437d817a3f56aee807fb6a47b8a1af86afe.zip
Dinosaur puzzle.
Closes PR 1796/2030. Submitted by: Yukihiro Nakai <Nakai@Mlab.t.u-tokyo.ac.jp>
Notes
Notes: svn path=/head/; revision=4518
Diffstat (limited to 'games/xdino')
-rw-r--r--games/xdino/Makefile24
-rw-r--r--games/xdino/distinfo1
-rw-r--r--games/xdino/pkg-comment1
-rw-r--r--games/xdino/pkg-descr96
-rw-r--r--games/xdino/pkg-plist3
5 files changed, 125 insertions, 0 deletions
diff --git a/games/xdino/Makefile b/games/xdino/Makefile
new file mode 100644
index 000000000000..43be5a8aea9d
--- /dev/null
+++ b/games/xdino/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: xdino
+# Version required: V5.3
+# Date created: 12 October 1996
+# Whom: Yukihiro Nakai <Nakai@Mlab.t.u-tokyo.ac.jp>
+#
+# $Id$
+#
+
+DISTNAME= xdino
+PKGNAME= xdino-5.3
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_XCONTRIB}
+MASTER_SITE_SUBDIR= games/puzzles
+
+MAINTAINER= Nakai@Mlab.t.u-tokyo.ac.jp
+
+USE_IMAKE= yes
+
+post-install:
+ @chmod 755 ${PREFIX}/bin/xdino
+ @chown bin.bin ${PREFIX}/bin/xdino
+ @${INSTALL_DATA} ${WRKSRC}/Dino.ad ${PREFIX}/lib/X11/app-defaults/Dino
+
+.include <bsd.port.mk>
diff --git a/games/xdino/distinfo b/games/xdino/distinfo
new file mode 100644
index 000000000000..ed99a826c070
--- /dev/null
+++ b/games/xdino/distinfo
@@ -0,0 +1 @@
+MD5 (xdino.tar.gz) = b2c9bcffabdc650104c1f0f65445f1bc
diff --git a/games/xdino/pkg-comment b/games/xdino/pkg-comment
new file mode 100644
index 000000000000..f953c7ceef0e
--- /dev/null
+++ b/games/xdino/pkg-comment
@@ -0,0 +1 @@
+dino puzzle game for X-Window
diff --git a/games/xdino/pkg-descr b/games/xdino/pkg-descr
new file mode 100644
index 000000000000..c2976c2b0eff
--- /dev/null
+++ b/games/xdino/pkg-descr
@@ -0,0 +1,96 @@
+XDino, dino puzzle game for X-Window.
+
+Usage:
+ xdino [-display <display>] [-geometry <geometry>]
+ [-{foreground | fg} <color>] [-{background | bg}
+ <color>] [-{border | bd} <color>] [-mono] [-[no]orient]
+ [-{mode <int> | both}] [-face{0|1|2|3|4|5} <color>]
+
+Description:
+
+ Use "mouse-left" to move ccw.
+
+ Use "mouse-center", "P", or "p" to toggle the practice
+ mode (in practice mode the record should be "practice").
+ One must double click on "mouse-center" if the puzzle is
+ being worked on.
+
+ "mouse-right", "R", or "r", to randomize (this must be
+ done first to set a new record). One must double click on
+ "mouse-right" if the puzzle is being worked on.
+
+ "O" or "o" keys toggle the orient mode.
+
+ "2", "3", "B", or "b" keys change modes to Period 2,
+ Period 3, or Both.
+
+ "S" or "s" keys reserved for the auto-solver (unimple-
+ mented).
+
+ "U" or "u" keys to undo move.
+
+ "G" or "g" keys to get a saved puzzle.
+
+ "W" or "w" keys to write or save a puzzle.
+
+ "Q", "q", or "CTRL-C" keys kill program.
+
+ Use the arrows, key pad or, "R" keys to move other than
+ CCW.
+
+ Use the control key and the keypad, or arrow keys to move
+ the whole cube.
+
+Options:
+
+ -display host:dpy
+ This option specifies the X server to contact.
+
+ -geometry {+|-}X{+|-}Y
+ This option sets the initial position of the dino
+ window (resource name "geometry").
+
+ -{foreground | fg} color
+ This option specifies the foreground of the dino
+ window (resource name "foreground").
+
+ -{background | bg} color
+ This option specifies the background of the dino
+ window (resource name "background").
+
+ -{border | bd} color
+ This option specifies the border color of the
+ cubelets in the dino window (resource name "bor-
+ derColor").
+
+ -mono This option allows you to access the mono mode on
+ a color monitor (resource name "mono").
+
+ -[no]orient
+ This option allows you to access the orient mode
+ (resource name "orient").
+
+ -mode <int>
+ This option allows you to set the turning mode
+ (resource name "mode").
+
+ -both This option allows you to set the turning mode to
+ both period 2 and period 3 (resource name "mode"
+ set at 4).
+
+ -face{0|1|2|3|4|5} <color>
+ This option allows you to change the color of a
+ face (resource name "faceColorN"). In mono-mode,
+ color is represented as the first letter of the
+ color name. On the 2-D version, the faces are
+ ordered top to bottom and left to right on the "t"
+ configuration. The "+-" configuration is physi-
+ cally consistent with the former, so it is ordered
+ "0, 1, 2, 3, 5, 4". If you has two colors that
+ begin with the same letter you should have one in
+ uppercase and one in lowercase to distinguish them
+ in mono-mode. You can change the colors of the
+ faces to make a stupid cube (i.e. all White or in
+ mono-mode all "W"). Unfortunately, it will not
+ normally say its solved when its randomized. This
+ would be cheating.
diff --git a/games/xdino/pkg-plist b/games/xdino/pkg-plist
new file mode 100644
index 000000000000..39fb3aa46acd
--- /dev/null
+++ b/games/xdino/pkg-plist
@@ -0,0 +1,3 @@
+bin/xdino
+man/man1/xdino.1.gz
+lib/X11/app-defaults/Dino