aboutsummaryrefslogtreecommitdiff
path: root/games/xemeraldia
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1995-03-24 05:27:13 +0000
committerSatoshi Asami <asami@FreeBSD.org>1995-03-24 05:27:13 +0000
commit318f9e3350e005a08e37e41858bd747634e1bfd3 (patch)
treee40c4768114f1cbf354be1b15be6e1a155319200 /games/xemeraldia
parentb1d8acd71f75815ba788e272ca192ea02f9ed692 (diff)
downloadports-318f9e3350e005a08e37e41858bd747634e1bfd3.tar.gz
ports-318f9e3350e005a08e37e41858bd747634e1bfd3.zip
Version 0.2 of xemeraldia. Drop blocks and break them.
Notes
Notes: svn path=/head/; revision=1190
Diffstat (limited to 'games/xemeraldia')
-rw-r--r--games/xemeraldia/Makefile33
-rw-r--r--games/xemeraldia/distinfo1
-rw-r--r--games/xemeraldia/files/patch-aa17
-rw-r--r--games/xemeraldia/pkg-comment1
-rw-r--r--games/xemeraldia/pkg-descr13
-rw-r--r--games/xemeraldia/pkg-plist8
6 files changed, 73 insertions, 0 deletions
diff --git a/games/xemeraldia/Makefile b/games/xemeraldia/Makefile
new file mode 100644
index 000000000000..e3ab99514293
--- /dev/null
+++ b/games/xemeraldia/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: xemeraldia
+# Version required: 0.2
+# Date created: 22 Mar 1995
+# Whom: swallace
+#
+# $Id: Makefile,v 1.1.1.1 1995/01/03 08:46:26 swallace Exp $
+#
+
+DISTNAME= xemeraldia-0.2
+DISTFILES= 250.gz
+MASTER_SITES= ftp://ftp.kuis.kyoto-u.ac.jp/News.Archives/fj.sources/1995/
+USE_IMAKE= yes
+NO_INSTALL_MANPAGES= yes
+EXTRACT_COOKIE?= ${.CURDIR}/work/.extract_done
+
+extract: fetch ${EXTRACT_COOKIE}
+
+${EXTRACT_COOKIE}:
+ @${MAKE} ${.MAKEFLAGS} checksum pre-extract
+ @echo "===> Extracting for ${DISTNAME}"
+ @(cd ${DISTDIR}; zcat ${DISTFILES} | uudecode)
+ @rm -rf ${WRKDIR}
+ @mkdir -p ${WRKDIR}
+ @(cd ${WRKDIR}; ${EXTRACT_CMD} ${EXTRACT_ARGS} \
+ ${DISTDIR}/${DISTNAME}.tar.gz)
+ @${TOUCH} ${TOUCH_FLAGS} ${EXTRACT_COOKIE}
+
+
+pre-install:
+ touch ${PREFIX}/lib/X11/.xemeraldia.scores
+ chmod 666 ${PREFIX}/lib/X11/.xemeraldia.scores
+
+.include <bsd.port.mk>
diff --git a/games/xemeraldia/distinfo b/games/xemeraldia/distinfo
new file mode 100644
index 000000000000..a7c2f23e634f
--- /dev/null
+++ b/games/xemeraldia/distinfo
@@ -0,0 +1 @@
+MD5 (250.gz) = 17dfc39179902b20b46fc926fae40cb5
diff --git a/games/xemeraldia/files/patch-aa b/games/xemeraldia/files/patch-aa
new file mode 100644
index 000000000000..757de53afbc0
--- /dev/null
+++ b/games/xemeraldia/files/patch-aa
@@ -0,0 +1,17 @@
+--- ./Imakefile.org Mon Mar 20 05:01:34 1995
++++ ./Imakefile Wed Mar 22 05:31:31 1995
+@@ -1,5 +1,4 @@
+-BIN_DIR= /usr/local/bin
+-HIGH_SCORE_DIR= /usr/local/lib
++HIGH_SCORE_DIR= ${LIBDIR}
+
+ /*---------------------------------------------------------------------*/
+
+@@ -7,7 +6,6 @@
+ # define GLLIB -lgl_s
+ #endif
+
+-BINDIR=$(BIN_DIR)
+ EXTRA_DEFINES = -DHIGH_SCORE_TABLE=\"$(HIGH_SCORE_DIR)/.xemeraldia.scores\"\
+ -D__USE_FIXED_PROTOTYPES__
+
diff --git a/games/xemeraldia/pkg-comment b/games/xemeraldia/pkg-comment
new file mode 100644
index 000000000000..ad128533e1c9
--- /dev/null
+++ b/games/xemeraldia/pkg-comment
@@ -0,0 +1 @@
+xemeraldia-0.2, a game of breaking blocks
diff --git a/games/xemeraldia/pkg-descr b/games/xemeraldia/pkg-descr
new file mode 100644
index 000000000000..dab0eebbebdd
--- /dev/null
+++ b/games/xemeraldia/pkg-descr
@@ -0,0 +1,13 @@
+This is version 0.2 of xemeraldia.
+
+Drop the blocks. If you drop a square on top of one of the same
+color, they (as well as any neighboring blocks of the same color) will
+both be shaken by an "impact". The first impact will cause fractures;
+the second will cause the block(s) to dissolve.
+
+You can either use the arrow keys or vi-style (hjkl) keys to move/
+rotate the blocks. `s' or `p' will pause the game, and if your boss
+comes along, `q' can be used to avoid an unpleasant confrontation.
+
+- Satoshi
+asami@cs.berkeley.edu
diff --git a/games/xemeraldia/pkg-plist b/games/xemeraldia/pkg-plist
new file mode 100644
index 000000000000..1319eb1cd889
--- /dev/null
+++ b/games/xemeraldia/pkg-plist
@@ -0,0 +1,8 @@
+@cd ${X11BASE}
+@owner games
+@mode 755
+bin/xemeraldia
+@exec touch -f %D/lib/X11/.xemeraldia.scores
+@exec chmod 666 %D/lib/X11/.xemeraldia.scores
+@exec chown games %D/lib/X11/.xemeraldia.scores
+@unexec rm -f %D/lib/X11/.xemeraldia.scores