aboutsummaryrefslogtreecommitdiff
path: root/games/xgalaga
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-11-16 00:41:30 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-11-16 00:41:30 +0000
commit735f3e02036dfc047672cb674d621ae4667f4bd3 (patch)
tree09e61b96d9881a327be2ab443c2dc81a0fa778b9 /games/xgalaga
parentb4ae4c146196e5f702562cdd74c37cb183b04244 (diff)
downloadports-735f3e02036dfc047672cb674d621ae4667f4bd3.tar.gz
ports-735f3e02036dfc047672cb674d621ae4667f4bd3.zip
Fix spacebar behaviour under KDE and GNOME.
PR: ports/59195 Submitted by: Lee Harr <missive@hotmail.com> Approved by: marcus (backup mentor)
Notes
Notes: svn path=/head/; revision=94073
Diffstat (limited to 'games/xgalaga')
-rw-r--r--games/xgalaga/Makefile2
-rw-r--r--games/xgalaga/files/patch-ae18
2 files changed, 19 insertions, 1 deletions
diff --git a/games/xgalaga/Makefile b/games/xgalaga/Makefile
index bea8bb66f5a6..a7a12ffd4499 100644
--- a/games/xgalaga/Makefile
+++ b/games/xgalaga/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xgalaga
PORTVERSION= 2.0.34
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.cit.uws.edu.au/pub/unix/games/ \
http://ftp.yars.free.net/pub/software/unix/games/arcade/ \
diff --git a/games/xgalaga/files/patch-ae b/games/xgalaga/files/patch-ae
new file mode 100644
index 000000000000..58c77cfb4d03
--- /dev/null
+++ b/games/xgalaga/files/patch-ae
@@ -0,0 +1,18 @@
+--- main.c.orig Mon May 11 08:52:59 1998
++++ main.c Sat Nov 15 19:34:53 2003
+@@ -779,6 +779,7 @@
+ if(gameOver) {
+ while(W_EventsPending()) {
+ W_NextEvent(&wev);
++ if (wev.key >= 256) wev.key -= 256;
+
+ if(gameOver)
+ mouseControl = 1;
+@@ -826,6 +827,7 @@
+
+ while(W_EventsPending()) {
+ W_NextEvent(&wev);
++ if (wev.key >= 256) wev.key -= 256;
+
+ switch(wev.type) {
+ case W_EV_KEY_OFF: