aboutsummaryrefslogtreecommitdiff
path: root/games/xkoules
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-06-22 10:05:54 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-06-22 10:05:54 +0000
commit7ca8dfe98a6cbf4210f3a3e952e780f373cc5608 (patch)
treead8affefb137d0654df0198d1649a017bfc700a2 /games/xkoules
parentaa0bdfa0c8c4e8d8c7552335f460ddc5d7e03e17 (diff)
downloadports-7ca8dfe98a6cbf4210f3a3e952e780f373cc5608.tar.gz
ports-7ca8dfe98a6cbf4210f3a3e952e780f373cc5608.zip
Notes
Diffstat (limited to 'games/xkoules')
-rw-r--r--games/xkoules/Makefile18
-rw-r--r--games/xkoules/files/patch-ab47
-rw-r--r--games/xkoules/pkg-plist1
3 files changed, 55 insertions, 11 deletions
diff --git a/games/xkoules/Makefile b/games/xkoules/Makefile
index 8ad6eb18dbf1..ac6c1b3704b5 100644
--- a/games/xkoules/Makefile
+++ b/games/xkoules/Makefile
@@ -24,19 +24,17 @@ MAN6= xkoules.6
MANCOMPRESSED= no
do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/xkoules ${PREFIX}/bin
- @ ${MKDIR} ${PREFIX}/share/xkoules
+ ${INSTALL_PROGRAM} ${WRKSRC}/xkoules ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/xkoules
.if ${MACHINE_ARCH} == "i386"
- @ ${INSTALL_PROGRAM} ${WRKSRC}/koules.sndsrv.freebsd ${PREFIX}/share/xkoules
+ ${INSTALL_PROGRAM} ${WRKSRC}/koules.sndsrv.freebsd ${PREFIX}/share/xkoules
.endif
- @ ${INSTALL_DATA} ${WRKSRC}/sounds/*.raw ${PREFIX}/share/xkoules
- @ ${INSTALL_MAN} ${WRKSRC}/xkoules.6 ${PREFIX}/man/man6
-
-post-install:
+ ${INSTALL_DATA} ${WRKSRC}/sounds/*.raw ${PREFIX}/share/xkoules
+ ${INSTALL_MAN} ${WRKSRC}/xkoules.6 ${PREFIX}/man/man6
.if !defined(NOPORTDOCS)
- @ ${MKDIR} ${PREFIX}/share/doc/xkoules
-.for file in ANNOUNCE BUGS COPYING Card ChangeLog Koules.FAQ TODO
- @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/xkoules
+ @${MKDIR} ${PREFIX}/share/doc/xkoules
+.for file in ANNOUNCE BUGS Card ChangeLog Koules.FAQ TODO
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/xkoules
.endfor
.endif
diff --git a/games/xkoules/files/patch-ab b/games/xkoules/files/patch-ab
new file mode 100644
index 000000000000..ea84438e9f75
--- /dev/null
+++ b/games/xkoules/files/patch-ab
@@ -0,0 +1,47 @@
+--- xlib/shmbitmap.c.orig Thu Mar 5 03:59:19 1998
++++ xlib/shmbitmap.c Tue Jun 13 03:45:28 2000
+@@ -237,7 +237,7 @@
+ #define __clipy1 0
+ #undef __clipy2
+ #define __clipy2 (MAPHEIGHT+19)
+-#ifdef __i386__
++#if defined(__i386__)&&defined(ASSEMBLY)
+ static INLINE int
+ muldiv64 (int CONST m1, int CONST m2, int CONST d)
+ {
+@@ -333,7 +333,7 @@
+ }
+ if (r1 & 1)
+ { /* left */
+-#ifdef __i386__
++#if defined(__i386__)&&defined(ASSEMBLY)
+ y1 += muldiv64 (__clipx1 - x1, y2 - y1, x2 - x1);
+ #else
+ y1 += (long) (__clipx1 - x1) * (long) (y2 - y1) / (long) (x2 - x1);
+@@ -342,7 +342,7 @@
+ }
+ else if (r1 & 2)
+ { /* right */
+-#ifdef __i386__
++#if defined(__i386__)&&defined(ASSEMBLY)
+ y1 += muldiv64 (__clipx2 - x1, y2 - y1, x2 - x1);
+ #else
+ y1 += (long) (__clipx2 - x1) * (long) (y2 - y1) / (long) (x2 - x1);
+@@ -351,7 +351,7 @@
+ }
+ else if (r1 & 4)
+ { /* top */
+-#ifdef __i386__
++#if defined(__i386__)&&defined(ASSEMBLY)
+ x1 += muldiv64 (__clipy1 - y1, x2 - x1, y2 - y1);
+ #else
+ x1 += (long) (__clipy1 - y1) * (long) (x2 - x1) / (long) (y2 - y1);
+@@ -360,7 +360,7 @@
+ }
+ else if (r1 & 8)
+ { /* bottom */
+-#ifdef __i386__
++#if defined(__i386__)&&defined(ASSEMBLY)
+ x1 += muldiv64 (__clipy2 - y1, x2 - x1, y2 - y1);
+ #else
+ x1 += (long) (__clipy2 - y1) * (long) (x2 - x1) / (long) (y2 - y1);
diff --git a/games/xkoules/pkg-plist b/games/xkoules/pkg-plist
index c3f236a7b7ac..bd47c64b28b3 100644
--- a/games/xkoules/pkg-plist
+++ b/games/xkoules/pkg-plist
@@ -1,7 +1,6 @@
bin/xkoules
share/doc/xkoules/ANNOUNCE
share/doc/xkoules/BUGS
-share/doc/xkoules/COPYING
share/doc/xkoules/Card
share/doc/xkoules/ChangeLog
share/doc/xkoules/Koules.FAQ