aboutsummaryrefslogtreecommitdiff
path: root/games/xkoules
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-06-22 18:07:45 +0000
committerSteve Price <steve@FreeBSD.org>1999-06-22 18:07:45 +0000
commitd7b0c7f42f7ce99e3693b99cc5a34335ca4ea696 (patch)
treef4fb253f29145161f2900822473c919436659bb2 /games/xkoules
parentb67d334e967b010fe54ed502c6e51a1d611cbedc (diff)
downloadports-d7b0c7f42f7ce99e3693b99cc5a34335ca4ea696.tar.gz
ports-d7b0c7f42f7ce99e3693b99cc5a34335ca4ea696.zip
Disable sound support for the Alpha.
Notes
Notes: svn path=/head/; revision=19688
Diffstat (limited to 'games/xkoules')
-rw-r--r--games/xkoules/Makefile8
-rw-r--r--games/xkoules/files/patch-aa13
2 files changed, 18 insertions, 3 deletions
diff --git a/games/xkoules/Makefile b/games/xkoules/Makefile
index b7bee5261d50..e20aaf4cd40f 100644
--- a/games/xkoules/Makefile
+++ b/games/xkoules/Makefile
@@ -3,7 +3,7 @@
# Date created: 11 March 1998
# Whom: Andrey Zakhvatov
#
-# $Id: Makefile,v 1.3 1998/08/25 00:43:54 asami Exp $
+# $Id: Makefile,v 1.4 1998/12/21 11:51:10 flathill Exp $
#
DISTNAME= koules1.4-src
@@ -14,6 +14,10 @@ MASTER_SITES= http://www.paru.cas.cz/~hubicka/koules/packages/ \
MAINTAINER= andy@icc.surw.chel.su
+.if ${MACHINE_ARCH} == "alpha"
+PLIST= ${PKGDIR}/PLIST.alpha
+.endif
+
USE_IMAKE= yes
WRKSRC= ${WRKDIR}/koules1.4
MAN6= xkoules.6
@@ -22,7 +26,9 @@ MANCOMPRESSED= no
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/xkoules ${PREFIX}/bin
@ ${MKDIR} ${PREFIX}/share/xkoules
+.if ${MACHINE_ARCH} == "i386"
@ ${INSTALL_PROGRAM} ${WRKSRC}/koules.sndsrv.freebsd ${PREFIX}/share/xkoules
+.endif
@ ${INSTALL_DATA} ${WRKSRC}/sounds/*.raw ${PREFIX}/share/xkoules
@ ${INSTALL_MAN} ${WRKSRC}/xkoules.6 ${PREFIX}/man/man6
diff --git a/games/xkoules/files/patch-aa b/games/xkoules/files/patch-aa
index eb18c96f0a29..961404c592c4 100644
--- a/games/xkoules/files/patch-aa
+++ b/games/xkoules/files/patch-aa
@@ -1,5 +1,5 @@
---- Iconfig.orig Wed Mar 4 15:29:05 1998
-+++ Iconfig Sun Apr 19 17:23:41 1998
+--- Iconfig.orig Wed Mar 4 14:29:05 1998
++++ Iconfig Sat Jun 19 16:50:40 1999
@@ -34,9 +34,9 @@
recomended for linux*/
/*#define I386ASSEMBLY*/
@@ -13,3 +13,12 @@
/*You need some extra libraryes for BSD sockets compatibility?*/
/* TOP_INCLUDES = /* Sun users with GCC need this */
+@@ -94,7 +94,7 @@
+
+ #if defined(FreeBSDArchitecture)
+ SYSDEFS =
+-#if !defined(NAS_SOUND)&&!defined(RSOUND)
++#if !defined(NAS_SOUND)&&!defined(RSOUND)&&defined(i386Architecture)
+ #define SOUND
+ SOUNDSERVER = koules.sndsrv.freebsd
+ SOUNDOBJS = sound.o