aboutsummaryrefslogtreecommitdiff
path: root/games/xlines/Makefile
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-09-01 16:07:59 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-09-01 16:07:59 +0000
commit534fffca27bb18f7529d548c46ee3326505a89c7 (patch)
treea09ac440edd299d85a3517dea62caa2b115543fc /games/xlines/Makefile
parent5bc499ce47fa1a8da853b36cc61cddf06075d203 (diff)
downloadports-534fffca27bb18f7529d548c46ee3326505a89c7.tar.gz
ports-534fffca27bb18f7529d548c46ee3326505a89c7.zip
Notes
Diffstat (limited to 'games/xlines/Makefile')
-rw-r--r--games/xlines/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/games/xlines/Makefile b/games/xlines/Makefile
index 8b7f0b387839..812f58a7e9a1 100644
--- a/games/xlines/Makefile
+++ b/games/xlines/Makefile
@@ -15,13 +15,14 @@ MAINTAINER= ports@FreeBSD.org
USE_QT_VER= 1
USE_X_PREFIX= yes
+USE_REINPLACE= yes
NO_WRKSUBDIR= yes
pre-patch:
- @find ${WRKSRC} -type f | xargs ${PERL} -pi -e "s|\r\n|\n|g"
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e "s|`/usr/bin/printf '\r'`||g"
post-patch:
- @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/*.cpp
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/*.cpp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xlines ${PREFIX}/bin