aboutsummaryrefslogtreecommitdiff
path: root/games/xmastermind
diff options
context:
space:
mode:
authorMike Heffner <mikeh@FreeBSD.org>2002-07-01 06:32:22 +0000
committerMike Heffner <mikeh@FreeBSD.org>2002-07-01 06:32:22 +0000
commit33b1ee2fb263ee2db24503f15d6f02a9d72546cb (patch)
treeeb873965e9964d3639f71e46ea1c9a97734ba8fd /games/xmastermind
parent16a396879177254e63b3e57ef7115a8ec1862b66 (diff)
downloadports-33b1ee2fb263ee2db24503f15d6f02a9d72546cb.tar.gz
ports-33b1ee2fb263ee2db24503f15d6f02a9d72546cb.zip
Prepare for xforms update.
Notes
Notes: svn path=/head/; revision=62252
Diffstat (limited to 'games/xmastermind')
-rw-r--r--games/xmastermind/Makefile2
-rw-r--r--games/xmastermind/files/patch-aa13
-rw-r--r--games/xmastermind/files/patch-ab13
3 files changed, 22 insertions, 6 deletions
diff --git a/games/xmastermind/Makefile b/games/xmastermind/Makefile
index fcab790f095c..7fa9858b0849 100644
--- a/games/xmastermind/Makefile
+++ b/games/xmastermind/Makefile
@@ -13,7 +13,7 @@ MASTER_SITE_SUBDIR= games/strategy
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= xforms.0:${PORTSDIR}/x11-toolkits/xforms
+LIB_DEPENDS= forms.0:${PORTSDIR}/x11-toolkits/xforms
USE_REINPLACE= yes
USE_X_PREFIX= yes
diff --git a/games/xmastermind/files/patch-aa b/games/xmastermind/files/patch-aa
index 88be9e3e4b86..ee322a413bff 100644
--- a/games/xmastermind/files/patch-aa
+++ b/games/xmastermind/files/patch-aa
@@ -1,15 +1,18 @@
---- Makefile Tue Dec 30 10:30:25 1997
-+++ /home/andy/tmp/wrk/Makefile Mon Mar 23 23:20:18 1998
-@@ -1,10 +1,10 @@
+--- Makefile.orig Tue Dec 30 05:30:25 1997
++++ Makefile Mon Jul 1 02:25:43 2002
+@@ -1,10 +1,13 @@
OBJS = main.o mymath.o mastermind.o guiglobal.o apptogui.o guitoapp.o mainwindowdesign.o
CC = gcc
-CFLAGS = -O2 -Wall -Wpointer-arith -Wstrict-prototypes -pedantic -ansi
-+CFLAGS+= -Wall -Wpointer-arith -Wstrict-prototypes -pedantic -ansi -I${X11BASE}/include
++.if exists(${X11BASE}/include/X11/forms.h)
++XFORMSINC=-I${X11BASE}/include/X11
++.endif
++CFLAGS+= -Wall -Wpointer-arith -Wstrict-prototypes -pedantic -ansi -I${X11BASE}/include ${XFORMSINC}
CLIBS = -lm
#GRAPHLIBS = -lforms -L/usr/X11R6/lib/ -lX11 -static
-GRAPHLIBS = -lforms -L/usr/X11R6/lib/ -lX11
-+GRAPHLIBS = -lxforms -L${X11BASE}/lib -lX11
++GRAPHLIBS = -lforms -L${X11BASE}/lib -lX11 -lXpm
MF = Makefile
ALLLIBS = $(GRAPHLIBS) $(CLIBS)
diff --git a/games/xmastermind/files/patch-ab b/games/xmastermind/files/patch-ab
new file mode 100644
index 000000000000..3cfc2ea3b852
--- /dev/null
+++ b/games/xmastermind/files/patch-ab
@@ -0,0 +1,13 @@
+--- configure.h.orig Mon Jul 1 02:27:59 2002
++++ configure.h Mon Jul 1 02:27:19 2002
+@@ -4,8 +4,10 @@
+ #define VERSION 0.1
+
+ /* some stuff */
++#ifndef TRUE
+ #define TRUE 1
+ #define FALSE 0
++#endif
+ #define BOOLEAN int
+
+ /* Don't change this, because it will not work right with the GUI. Sorry! */