aboutsummaryrefslogtreecommitdiff
path: root/games/xmille
diff options
context:
space:
mode:
authorSteven Wallace <swallace@FreeBSD.org>1994-12-31 05:34:27 +0000
committerSteven Wallace <swallace@FreeBSD.org>1994-12-31 05:34:27 +0000
commit7570343cac8e02f32372145530a547b03b02c471 (patch)
treecab88d088d1881fa7de60933d405ff582bbec5f0 /games/xmille
parente099d5e17cf6da33fec3bbc65dbac0b6e05cb9c4 (diff)
downloadports-7570343cac8e02f32372145530a547b03b02c471.tar.gz
ports-7570343cac8e02f32372145530a547b03b02c471.zip
port of xmille - X window mille bourne game
Notes
Notes: svn path=/head/; revision=655
Diffstat (limited to 'games/xmille')
-rw-r--r--games/xmille/Makefile16
-rw-r--r--games/xmille/files/patch-aa48
-rw-r--r--games/xmille/files/patch-ab19
-rw-r--r--games/xmille/files/patch-ac14
-rw-r--r--games/xmille/pkg-comment1
-rw-r--r--games/xmille/pkg-descr6
-rw-r--r--games/xmille/pkg-plist3
7 files changed, 107 insertions, 0 deletions
diff --git a/games/xmille/Makefile b/games/xmille/Makefile
new file mode 100644
index 000000000000..d304a2b8fac6
--- /dev/null
+++ b/games/xmille/Makefile
@@ -0,0 +1,16 @@
+# New ports collection makefile for: xmille
+# Version required: 2.0
+# Date created: 30 Dec 1994
+# Whom: swallace
+#
+# $Id: Makefile,v 1.2 1994/10/06 07:52:04 swallace Exp $
+#
+
+DISTNAME= xmille
+MASTER_SITES= ftp://gatekeeper.dec.com/.b/X11-contrib/
+USE_IMAKE= yes
+INSTALL_MANPAGES= yes
+EXTRACT_SUFX= .tar.Z
+NO_WRKSUBDIR= yes
+
+.include <bsd.port.mk>
diff --git a/games/xmille/files/patch-aa b/games/xmille/files/patch-aa
new file mode 100644
index 000000000000..e4901f80ece5
--- /dev/null
+++ b/games/xmille/files/patch-aa
@@ -0,0 +1,48 @@
+*** drawcard.c.orig Thu Sep 16 00:47:18 1993
+--- drawcard.c Thu Sep 16 00:41:29 1993
+***************
+*** 183,194 ****
+ WIDTH, HEIGHT);
+
+ XSetForeground(dpy, cheap_gc, bits_p);
+! XSetStipple(dpy, cheap_gc, bits);
+ XFillRectangle (dpy, cards[i].bits, cheap_gc, 0, 0,
+ WIDTH, HEIGHT);
+
+ XSetForeground(dpy, cheap_gc, mask_p);
+! XSetStipple(dpy, cheap_gc, mask);
+ XFillRectangle (dpy, cards[i].bits, cheap_gc, 0, 0,
+ WIDTH, HEIGHT);
+
+--- 183,194 ----
+ WIDTH, HEIGHT);
+
+ XSetForeground(dpy, cheap_gc, bits_p);
+! XSetStipple(dpy, cheap_gc, mask);
+ XFillRectangle (dpy, cards[i].bits, cheap_gc, 0, 0,
+ WIDTH, HEIGHT);
+
+ XSetForeground(dpy, cheap_gc, mask_p);
+! XSetStipple(dpy, cheap_gc, bits);
+ XFillRectangle (dpy, cards[i].bits, cheap_gc, 0, 0,
+ WIDTH, HEIGHT);
+
+*** roll.c.orig Thu Apr 2 06:15:57 1992
+--- roll.c Thu Sep 16 00:36:38 1993
+***************
+*** 7,13 ****
+
+ # define reg register
+
+! # if (! defined ultrix && ! defined mips && ! defined vax)
+ # define MAXRAND 32767L
+
+ roll(ndie, nsides)
+--- 7,13 ----
+
+ # define reg register
+
+! # if (! defined ultrix && ! defined mips && ! defined vax && ! defined __386BSD__ && ! defined __FreeBSD__)
+ # define MAXRAND 32767L
+
+ roll(ndie, nsides)
diff --git a/games/xmille/files/patch-ab b/games/xmille/files/patch-ab
new file mode 100644
index 000000000000..cd9ce57c259d
--- /dev/null
+++ b/games/xmille/files/patch-ab
@@ -0,0 +1,19 @@
+*** Imakefile.orig Thu Apr 2 06:03:24 1992
+--- Imakefile Fri Dec 30 21:14:47 1994
+***************
+*** 5,11 ****
+ /**/# Dana Chee
+ /**/#
+ #define IHaveSubdirs
+! #define PassCDebugFlags 'CDEBUGFLAGS=$(CDEBUGFLAGS) DEFINES=$(DEFINES)'
+
+ HEADERS = ui.h
+ SRCS= comp.c end.c extern.c init.c mille.c misc.c move.c print.c \
+--- 5,11 ----
+ /**/# Dana Chee
+ /**/#
+ #define IHaveSubdirs
+! #define PassCDebugFlags 'CDEBUGFLAGS=$(CDEBUGFLAGS) $(DEFINES)'
+
+ HEADERS = ui.h
+ SRCS= comp.c end.c extern.c init.c mille.c misc.c move.c print.c \
diff --git a/games/xmille/files/patch-ac b/games/xmille/files/patch-ac
new file mode 100644
index 000000000000..6a1f787e3137
--- /dev/null
+++ b/games/xmille/files/patch-ac
@@ -0,0 +1,14 @@
+*** save.c.orig Wed Apr 1 12:56:45 1992
+--- save.c Fri Dec 30 21:17:28 1994
+***************
+*** 22,28 ****
+--- 22,30 ----
+ * This routine saves the current game for use at a later date
+ */
+ extern int errno;
++ #ifndef __FreeBSD__
+ extern char *sys_errlist[];
++ #endif
+
+ save() {
+
diff --git a/games/xmille/pkg-comment b/games/xmille/pkg-comment
new file mode 100644
index 000000000000..b9b0c69d719b
--- /dev/null
+++ b/games/xmille/pkg-comment
@@ -0,0 +1 @@
+X window mille bourne game
diff --git a/games/xmille/pkg-descr b/games/xmille/pkg-descr
new file mode 100644
index 000000000000..05419e5ee4cd
--- /dev/null
+++ b/games/xmille/pkg-descr
@@ -0,0 +1,6 @@
+xmille - X window mille bourne game
+
+Xmille brings up a window for a mille bourne game. When selecting one
+of your cards, the left button plays the card, the right button
+discards the card and the middle button chooses whichever is appropriate,
+first trying to play the card, and then discarding it
diff --git a/games/xmille/pkg-plist b/games/xmille/pkg-plist
new file mode 100644
index 000000000000..325fc8747926
--- /dev/null
+++ b/games/xmille/pkg-plist
@@ -0,0 +1,3 @@
+@cwd /usr/X11R6
+bin/xmille
+man/man1/xmille.1.gz