aboutsummaryrefslogtreecommitdiff
path: root/games/xminehunter
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-12-05 13:13:08 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-12-05 13:13:08 +0000
commitf835159aca43c1f153b747ac51b68f4ebb7636cc (patch)
treecd58fe7af3d1f2030ddb4961f643f2a0f021aa5c /games/xminehunter
parentfc8bb9128cf4abacc0d14723790f8e1147e69122 (diff)
downloadports-f835159aca43c1f153b747ac51b68f4ebb7636cc.tar.gz
ports-f835159aca43c1f153b747ac51b68f4ebb7636cc.zip
- Add LICENSE (tricky to extract, but it's needed as license is non-commercial only)
- Pet portlint (whitespace fix) - Strip binary
Notes
Notes: svn path=/head/; revision=374023
Diffstat (limited to 'games/xminehunter')
-rw-r--r--games/xminehunter/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/games/xminehunter/Makefile b/games/xminehunter/Makefile
index 92af8aa28b14..7fd6bdcdde6f 100644
--- a/games/xminehunter/Makefile
+++ b/games/xminehunter/Makefile
@@ -10,6 +10,11 @@ MASTER_SITES= XCONTRIB/games
MAINTAINER= ports@FreeBSD.org
COMMENT= Motif minesweeper game
+LICENSE= XMINEHUNTER
+LICENSE_NAME= xminehunter license
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
+
WRKSRC= ${WRKDIR}/${PORTNAME}
USES= motif
@@ -22,6 +27,9 @@ LDFLAGS+= -L${LOCALBASE}/lib
DESKTOP_ENTRIES="XMineHunter" "" "${PREFIX}/share/pixmaps/${PORTNAME}.xpm" \
"${PORTNAME}" "" ""
+post-extract:
+ @${HEAD} -10 < ${WRKSRC}/xminehunter.cc > ${WRKSRC}/LICENSE
+
post-patch:
@${REINPLACE_CMD} -e \
'/^INSTALL_BIN/s|=.*|= $${PREFIX}/bin| ; \
@@ -34,7 +42,7 @@ post-patch:
s|$${CC}|$${CXX}| ; \
s|$${CFLAGS}|$${CXXFLAGS}| ; \
s| \($${INSTALL_SCORE_PATH}\)| $${DESTDIR}\1| ; \
- s|chmod 333|chmod 633| ; \
+ s|chmod 333|chmod 633| ; \
s|cp |$${BSD_INSTALL_DATA} | ; \
s| \($${INSTALL_BIN_PATH}\)| $${DESTDIR}\1|' \
${WRKSRC}/${MAKEFILE}
@@ -42,5 +50,6 @@ post-patch:
post-install:
(cd ${WRKSRC}/bitmaps && ${INSTALL_DATA} normal.xpm \
${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.xpm)
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>