aboutsummaryrefslogtreecommitdiff
path: root/games/xpipeman
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-05-31 14:18:20 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-05-31 14:18:20 +0000
commitfe6302c7633911c7e779bee40e0b1c093ff8260a (patch)
tree489ad9605f77c22c109b8c455b01a2373c7f11bd /games/xpipeman
parentbecc78d709a4922643ff0f710509541638234216 (diff)
downloadports-fe6302c7633911c7e779bee40e0b1c093ff8260a.tar.gz
ports-fe6302c7633911c7e779bee40e0b1c093ff8260a.zip
- Trim Makefile header
- Unbreak with clang - Respect PREFIX Approved by: miwi, eadler (mentors, implicit)
Notes
Notes: svn path=/head/; revision=319494
Diffstat (limited to 'games/xpipeman')
-rw-r--r--games/xpipeman/Makefile16
-rw-r--r--games/xpipeman/files/patch-ab6
-rw-r--r--games/xpipeman/files/patch-ac12
3 files changed, 21 insertions, 13 deletions
diff --git a/games/xpipeman/Makefile b/games/xpipeman/Makefile
index f69538073307..47f92d5496cb 100644
--- a/games/xpipeman/Makefile
+++ b/games/xpipeman/Makefile
@@ -1,15 +1,11 @@
-# New ports collection makefile for: xpipeman
-# Date created: 2 Jan 1995
-# Whom: swallace
-#
+# Created by: swallace
# $FreeBSD$
-#
PORTNAME= xpipeman
PORTVERSION= 1.0
PORTREVISION= 3
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITES= SUNSITE
MASTER_SITE_SUBDIR= games/strategy
DISTNAME= ${PORTNAME}
EXTRACT_SUFX= .tar.Z
@@ -23,8 +19,14 @@ ONLY_FOR_ARCHS= i386 amd64
USE_IMAKE= yes
USE_XORG= x11 xaw xext xmu xt sm ice
MAN6= xpipeman.6
+MANCOMPRESSED= no
+CFLAGS+= -Wno-error=return-type
+BINGRP= games
+BINMODE= 2555
-post-install:
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xpipeman ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/xpipeman.man ${MANPREFIX}/man/man6/xpipeman.6
${INSTALL} -c -g games -m 664 ${FILESDIR}/xpipescores ${PREFIX}/lib/X11
.include <bsd.port.mk>
diff --git a/games/xpipeman/files/patch-ab b/games/xpipeman/files/patch-ab
index 6bf293e882fa..f5f57b0be476 100644
--- a/games/xpipeman/files/patch-ab
+++ b/games/xpipeman/files/patch-ab
@@ -1,9 +1,9 @@
---- Imakefile.orig Tue Jul 28 19:56:27 1992
-+++ Imakefile Mon Jul 22 14:05:57 2002
+--- ./Imakefile.orig 1992-07-28 23:56:27.000000000 +0000
++++ ./Imakefile 2013-05-31 12:26:22.000000000 +0000
@@ -1,7 +1,7 @@
- SCORE_FILE = -DSCORE_FILE=\"/usr/games/lib/xpipescores\"
-+ SCORE_FILE = -DSCORE_FILE=\"$(LIBDIR)/xpipescores\"
++ SCORE_FILE = -DSCORE_FILE=\"$(PREFIX)/lib/X11/xpipescores\"
MAXSCORES = -DMAXSCORES=20
- DEFINES = $(SCORE_FILE) $(MAXSCORES) -DSYSV
+ DEFINES = $(SCORE_FILE) $(MAXSCORES)
diff --git a/games/xpipeman/files/patch-ac b/games/xpipeman/files/patch-ac
index 9c079224368d..df7d9d2379f1 100644
--- a/games/xpipeman/files/patch-ac
+++ b/games/xpipeman/files/patch-ac
@@ -1,6 +1,6 @@
---- main.c.orig 2011-02-02 19:11:34.000000000 +0100
-+++ main.c 2011-01-24 17:44:29.000000000 +0100
-@@ -146,16 +146,6 @@
+--- ./main.c.orig 1991-09-13 20:32:10.000000000 +0000
++++ ./main.c 2013-05-31 10:39:59.000000000 +0000
+@@ -146,21 +146,11 @@
{"-scorefile","scorefile",XrmoptionSepArg, NULL },
};
@@ -17,6 +17,12 @@
/*----------------------------------------------------------------------*/
+ main(argc, argv)
+- unsigned int argc;
++ int argc;
+ char **argv;
+ {
+ Arg args[1];
@@ -168,6 +158,17 @@
Widget quit_command,
new_game_command;