aboutsummaryrefslogtreecommitdiff
path: root/games/xrobots
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-02-28 11:40:16 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-02-28 11:40:16 +0000
commit83bcc30a853d6018c08a4d5473d95ba7be36c7f0 (patch)
tree9a2c1bd1abb3f691f4dbc629391aaa3ed594f11c /games/xrobots
parent85d1ba55173188e2114001149780f404098f6593 (diff)
downloadports-83bcc30a853d6018c08a4d5473d95ba7be36c7f0.tar.gz
ports-83bcc30a853d6018c08a4d5473d95ba7be36c7f0.zip
Unbreak for non-i386.
Notes
Notes: svn path=/head/; revision=102385
Diffstat (limited to 'games/xrobots')
-rw-r--r--games/xrobots/Makefile8
-rw-r--r--games/xrobots/files/patch-main.c11
2 files changed, 12 insertions, 7 deletions
diff --git a/games/xrobots/Makefile b/games/xrobots/Makefile
index 9e899d400bc2..353889c0bcc1 100644
--- a/games/xrobots/Makefile
+++ b/games/xrobots/Makefile
@@ -19,12 +19,6 @@ USE_IMAKE= yes
WRKSRC= ${WRKDIR}/xrobots-1.0
MAN6= xrobots.6
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
-.endif
-
post-install:
${INSTALL} -c -g games -m 664 ${FILESDIR}/xrobotscores ${PREFIX}/lib/X11
@@ -32,4 +26,4 @@ post-patch:
${REINPLACE_CMD} -e 's|__PREFIX__|${PREFIX}|g' \
${WRKSRC}/xrobots.man ${WRKSRC}/Imakefile
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/xrobots/files/patch-main.c b/games/xrobots/files/patch-main.c
new file mode 100644
index 000000000000..882172cf2dca
--- /dev/null
+++ b/games/xrobots/files/patch-main.c
@@ -0,0 +1,11 @@
+--- main.c.orig Sat Feb 28 22:37:53 2004
++++ main.c Sat Feb 28 22:38:30 2004
+@@ -170,7 +170,7 @@
+ {"-scorefile","scorefile",XrmoptionSepArg, NULL },
+ };
+
+-static XtResource application_resources[] = {
++XtResource application_resources[] = {
+ {"foreground", "Foreground", XtRPixel, sizeof(Pixel),
+ (Cardinal)&fg, XtRString, (caddr_t) "Black"},
+ {"background", "Background", XtRPixel, sizeof(Pixel),