aboutsummaryrefslogtreecommitdiff
path: root/games/xscorch/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-11-01 19:39:44 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-11-01 19:39:44 +0000
commit5ce7f76ecb5e31f715998db3f4bfc918bc23ad2c (patch)
tree83933655abbae4abc520ec415250317375ffbd12 /games/xscorch/Makefile
parentcf439dd621d9cf34d0feba802602542511c06d43 (diff)
downloadports-5ce7f76ecb5e31f715998db3f4bfc918bc23ad2c.tar.gz
ports-5ce7f76ecb5e31f715998db3f4bfc918bc23ad2c.zip
Notes
Diffstat (limited to 'games/xscorch/Makefile')
-rw-r--r--games/xscorch/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/games/xscorch/Makefile b/games/xscorch/Makefile
index 592cfd757950..05777a9357ab 100644
--- a/games/xscorch/Makefile
+++ b/games/xscorch/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xscorch
-PORTVERSION= 0.1.14
+PORTVERSION= 0.1.15
CATEGORIES= games
MASTER_SITES= http://chaos2.org/xscorch/ \
http://mirror.dok.org/xscorch/
@@ -20,6 +20,7 @@ USE_XPM= yes
USE_GMAKE= yes
USE_GNOMENG= yes
USE_GNOME= gtk12
+USE_REINPLACE= yes
WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gtk
@@ -31,12 +32,14 @@ MAN6= xscorch.6
.if ${HAVE_GNOME:Mgnomelibs}!=""
USE_GNOME+= gnomeprefix gnomelibs
PKGNAMESUFFIX= -gnome
+PLIST_SUB+= GNOME="gnome"
.else
CONFIGURE_ARGS+= --without-gnome
+PLIST_SUB+= GNOME=""
.endif
post-patch:
- @${PERL} -pi -e 's,MSG_NOSIGNAL,0,' \
+ @${REINPLACE_CMD} -e 's,MSG_NOSIGNAL,0,' \
${WRKSRC}/snet/tcpnet/tn_internal.c \
${WRKSRC}/snet/tcpnet/tn_read.c