aboutsummaryrefslogtreecommitdiff
path: root/games/xscrabble
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1997-08-04 11:45:49 +0000
committerThomas Gellekum <tg@FreeBSD.org>1997-08-04 11:45:49 +0000
commit7ae40f62da6b0e032c5311ae0d284d7b3fb7fe57 (patch)
tree0156dd35f8f7e542b755dfbf99ee77717dc3ac19 /games/xscrabble
parentdf589e19cbe52bfd089f986fc911897af586da9f (diff)
downloadports-7ae40f62da6b0e032c5311ae0d284d7b3fb7fe57.tar.gz
ports-7ae40f62da6b0e032c5311ae0d284d7b3fb7fe57.zip
Import xscrabble port.
Notes
Notes: svn path=/head/; revision=7470
Diffstat (limited to 'games/xscrabble')
-rw-r--r--games/xscrabble/Makefile27
-rw-r--r--games/xscrabble/distinfo1
-rw-r--r--games/xscrabble/files/patch-aa13
-rw-r--r--games/xscrabble/files/patch-ab15
-rw-r--r--games/xscrabble/files/patch-ac13
-rw-r--r--games/xscrabble/files/patch-ad21
-rw-r--r--games/xscrabble/pkg-comment1
-rw-r--r--games/xscrabble/pkg-descr20
-rw-r--r--games/xscrabble/pkg-plist7
9 files changed, 118 insertions, 0 deletions
diff --git a/games/xscrabble/Makefile b/games/xscrabble/Makefile
new file mode 100644
index 000000000000..443c53c1f17a
--- /dev/null
+++ b/games/xscrabble/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: xscrabble
+# Version required: 1.0
+# Date created: 27 July 1997
+# Whom: Thomas Gellekum <tg@FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= xscrabble
+PKGNAME= xscrabble-1.0
+CATEGORIES= games
+MASTER_SITES= http://www.belgarath.demon.co.uk/programs/
+
+MAINTAINER= ports@FreeBSD.ORG
+
+LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
+
+USE_IMAKE= yes
+NO_INSTALL_MANPAGES= yes
+
+post-patch:
+ @/usr/bin/perl -pi.bak -e "s|@XSCRABBLEDIR@|${PREFIX}/lib/X11/xscrabble|;" \
+ ${WRKSRC}/Imakefile
+ @/usr/bin/perl -pi.bak -e "s|@XSCRABBLEDIR@|${PREFIX}/lib/X11/xscrabble|;" \
+ ${WRKSRC}/XScrabble.ad
+
+.include <bsd.port.mk>
diff --git a/games/xscrabble/distinfo b/games/xscrabble/distinfo
new file mode 100644
index 000000000000..eca0b2b715ce
--- /dev/null
+++ b/games/xscrabble/distinfo
@@ -0,0 +1 @@
+MD5 (xscrabble.tar.gz) = 50608420d9d01a9acbec6ec816800ced
diff --git a/games/xscrabble/files/patch-aa b/games/xscrabble/files/patch-aa
new file mode 100644
index 000000000000..0ca4c7e06c59
--- /dev/null
+++ b/games/xscrabble/files/patch-aa
@@ -0,0 +1,13 @@
+--- Imakefile.orig Tue Mar 11 06:56:29 1997
++++ Imakefile Sun Jul 27 10:43:53 1997
+@@ -9,3 +9,10 @@
+ MakeLintLibSubdirs($(SUBDIRS))
+ MakeLintSubdirs($(SUBDIRS),install.ln,install.ln)
+
++InstallNamedNonExec(XScrabble.ad,XScrabble,$(LIBDIR)/app-defaults)
++InstallNonExecFile(OSPD3.gz,@XSCRABBLEDIR@)
++InstallNonExecFile(scrabble_permutations,@XSCRABBLEDIR@)
++InstallNonExecFile(xscrabble.scores,@XSCRABBLEDIR@)
++
++install::
++ @chmod a+rw @XSCRABBLEDIR@/xscrabble.scores
diff --git a/games/xscrabble/files/patch-ab b/games/xscrabble/files/patch-ab
new file mode 100644
index 000000000000..dac2cbd54197
--- /dev/null
+++ b/games/xscrabble/files/patch-ab
@@ -0,0 +1,15 @@
+--- XScrabble.ad.orig Tue Mar 11 06:57:16 1997
++++ XScrabble.ad Sun Jul 27 09:53:56 1997
+@@ -1,9 +1,9 @@
+ ! *** XScrabble resource file ***
+
+ ! edit the following three pathnames as required:
+-XScrabble.dictfile: /usr/local/lib/OSPD3
+-XScrabble.permfile: /usr/local/lib/scrabble_permutations
+-XScrabble.scorefile: /usr/local/lib/xscrabble.scores
++XScrabble.dictfile: @XSCRABBLEDIR@/OSPD3
++XScrabble.permfile: @XSCRABBLEDIR@/scrabble_permutations
++XScrabble.scorefile: @XSCRABBLEDIR@/xscrabble.scores
+
+ ! version string, to make sure correct resource file is loaded
+ XScrabble*version: 100
diff --git a/games/xscrabble/files/patch-ac b/games/xscrabble/files/patch-ac
new file mode 100644
index 000000000000..896e533cb75c
--- /dev/null
+++ b/games/xscrabble/files/patch-ac
@@ -0,0 +1,13 @@
+--- Xc/Imakefile.orig Fri Nov 10 18:53:09 1995
++++ Xc/Imakefile Sun Jul 27 10:23:24 1997
+@@ -22,10 +22,8 @@
+ #endif
+
+ NormalLibraryTarget(Xc,$(OBJS))
+-InstallLibrary(Xc,$(USRLIBDIR))
+
+ BuildIncludes($(HEADERS),Xc,..)
+-InstallMultiple($(HEADERS),$(INCDIR)/Xc)
+
+ #clean::
+ # $(RM) -r $(TOP)/X11
diff --git a/games/xscrabble/files/patch-ad b/games/xscrabble/files/patch-ad
new file mode 100644
index 000000000000..bfaa8eb19452
--- /dev/null
+++ b/games/xscrabble/files/patch-ad
@@ -0,0 +1,21 @@
+--- src/Imakefile.orig Tue Mar 11 06:56:24 1997
++++ src/Imakefile Sun Jul 27 10:04:12 1997
+@@ -28,8 +28,8 @@
+ PROGRAMS = xscrab xscrabble
+ SLIBS =
+
+- INCLUDES = -I.. -I/home/mchapman/include
+-SYS_LIBRARIES = -lXpm -L../Xc -lXc -L/home/mchapman/lib
++ INCLUDES = -I..
++SYS_LIBRARIES = -lXpm -L../Xc -lXc
+
+ CCOPTIONS =
+
+@@ -39,4 +39,7 @@
+ NormalProgramTarget(xscrabble,$(SETUP_OBJS),$(DEPLIBS),$(LOCAL_LIBS),$(SLIBS))
+
+ DependTarget()
++
++InstallProgram(xscrab,$(BINDIR))
++InstallProgram(xscrabble,$(BINDIR))
+
diff --git a/games/xscrabble/pkg-comment b/games/xscrabble/pkg-comment
new file mode 100644
index 000000000000..7dedd3ebaef7
--- /dev/null
+++ b/games/xscrabble/pkg-comment
@@ -0,0 +1 @@
+X version of the popular board game
diff --git a/games/xscrabble/pkg-descr b/games/xscrabble/pkg-descr
new file mode 100644
index 000000000000..8b763b58ed0c
--- /dev/null
+++ b/games/xscrabble/pkg-descr
@@ -0,0 +1,20 @@
+To run:
+
+Simpy type xscrabble. This will bring up the setup box which will allow
+you to enter the names and displays and other info for the game to wish
+to play. Then click on the Start Game button, (or Load Previous if you're
+restarting a game). The main program, xscrab, will then be automatically
+called with the appropriate options.
+
+The game is saved after every turn (in "~/.xscrabble.save" of the
+person running it) and can be restarted by running xscrabble, entering
+exactly the same info, and hitting the Load Previous button.
+
+This was a student project, and there are not likely to be any future
+releases.
+
+Have fun,
+
+Matt Chapman.
+E-mail: matt@belgarath.demon.co.uk (no longer csuoq@csv.warwick.ac.uk)
+
diff --git a/games/xscrabble/pkg-plist b/games/xscrabble/pkg-plist
new file mode 100644
index 000000000000..de960a51a483
--- /dev/null
+++ b/games/xscrabble/pkg-plist
@@ -0,0 +1,7 @@
+bin/xscrab
+bin/xscrabble
+lib/X11/app-defaults/XScrabble
+lib/X11/xscrabble/OSPD3.gz
+lib/X11/xscrabble/scrabble_permutations
+lib/X11/xscrabble/xscrabble.scores
+@dirrm lib/X11/xscrabble