aboutsummaryrefslogtreecommitdiff
path: root/games/xshogi
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-20 06:17:43 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-20 06:17:43 +0000
commitcda501d298c4d2b204b6c84c7db2e9721fd67c80 (patch)
tree86ce4ac6eb494961ac8c23d125989a7c1645ac80 /games/xshogi
parent0cf19a6f59f5f56b74adb72cb769c71b66f47d56 (diff)
downloadports-cda501d298c4d2b204b6c84c7db2e9721fd67c80.tar.gz
ports-cda501d298c4d2b204b6c84c7db2e9721fd67c80.zip
- Update to version 1.3
PR: ports/64468 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=104700
Diffstat (limited to 'games/xshogi')
-rw-r--r--games/xshogi/Makefile32
-rw-r--r--games/xshogi/distinfo2
-rw-r--r--games/xshogi/files/patch-aa50
-rw-r--r--games/xshogi/files/patch-ab19
4 files changed, 16 insertions, 87 deletions
diff --git a/games/xshogi/Makefile b/games/xshogi/Makefile
index 589333c92354..ddd39abd7e45 100644
--- a/games/xshogi/Makefile
+++ b/games/xshogi/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: xshogi
+# New ports collection makefile for: xshogi
# Date created: 20 October 1996
# Whom: Yukihiro Nakai <Nakai@Mlab.t.u-tokyo.ac.jp>
#
@@ -6,30 +6,30 @@
#
PORTNAME= xshogi
-PORTVERSION= 1.2.3
+PORTVERSION= ${GNUSHOGI_PORTVERSION}
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= xshogi
-DISTNAME= xshogi-1.2p03
+MASTER_SITES= ${GNUSHOGI_MASTER_SITES}
+MASTER_SITE_SUBDIR= ${GNUSHOGI_MASTER_SITE_SUBDIR}
+DISTNAME= ${GNUSHOGI_DISTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= The Japanese chess-like game for X Window System
-RUN_DEPENDS= ${LOCALBASE}/libexec/gnushogix:${PORTSDIR}/games/gnushogi
+RUN_DEPENDS= gnushogi:${PORTSDIR}/games/gnushogi
+
+BUILD_WRKSRC= ${WRKSRC}/xshogi
USE_X_PREFIX= yes
-MAKEFILE= Makefile.custom
+GNU_CONFIGURE= yes
+
MAN6= xshogi.6
PLIST_FILES= bin/xshogi
-post-configure:
- @${ECHO_CMD} "DISTDIR=${WRKDIR}" >> ${WRKSRC}/${MAKEFILE}
- @${ECHO_CMD} "LOCALBASE=${LOCALBASE}" >> ${WRKSRC}/${MAKEFILE}
+.include "${.CURDIR}/../../games/gnushogi/Makefile.common"
+.include <bsd.port.pre.mk>
-post-install:
- @${STRIP_CMD} ${PREFIX}/bin/xshogi
- @${CHMOD} 755 ${PREFIX}/bin/xshogi
- @${CHOWN} ${BINOWN}:${BINGRP} ${PREFIX}/bin/xshogi
- ${INSTALL_MAN} ${WRKSRC}/xshogi.man ${PREFIX}/man/man6/xshogi.6
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xshogi/xshogi ${PREFIX}/bin/xshogi
+ ${INSTALL_MAN} ${WRKSRC}/doc/xshogi.6 ${MANPREFIX}/man/man6/xshogi.6
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/xshogi/distinfo b/games/xshogi/distinfo
deleted file mode 100644
index 4c5cef9e8a91..000000000000
--- a/games/xshogi/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (xshogi-1.2p03.tar.gz) = 3dd09a7528e588782cfd5c6dbada2ea1
-SIZE (xshogi-1.2p03.tar.gz) = 129660
diff --git a/games/xshogi/files/patch-aa b/games/xshogi/files/patch-aa
deleted file mode 100644
index 66e690dc56b6..000000000000
--- a/games/xshogi/files/patch-aa
+++ /dev/null
@@ -1,50 +0,0 @@
---- Makefile.custom.orig Wed May 24 09:12:05 1995
-+++ Makefile.custom Sun Sep 27 12:04:31 1998
-@@ -28,18 +28,18 @@
- VERS = 1.2p03
-
- # Installation directory
--prefix=/usr/local
-+prefix=$(PREFIX)
- #prefix=/public/projects/shogi
-
- # Change these to something less transitory, like /usr/games, and then
- # compile.
- # Where the binaries live (especially gnushogix).
--BINDIR= $(prefix)/games
-+BINDIR= $(prefix)/bin
- #BINDIR=/public/projects/shogi/bin
-
-
- # Distribution directory
--DISTDIR=/public/projects/shogi
-+#DISTDIR=/public/projects/shogi
-
- # Compress program
- COMPRESS = gzip
-@@ -73,8 +73,12 @@
- #CCOPTIONS= -g
- #LDOPTIONS= -lXaw -lXmu -lXt -lXext -lX11
- # This is for cc on SunOS with debug
--CCOPTIONS= -g -I/usr/include
--LDOPTIONS= -L/usr/lib -lXaw -lXmu -lXt -lXext -lX11
-+CCOPTIONS= -g ${CFLAGS} -fno-strength-reduce \
-+ -I/usr/include -I$(PREFIX)/include
-+LDOPTIONS= -L/usr/lib -L$(PREFIX)/lib -lXaw -lXmu -lXt -lXext -lX11
-+.if ${PORTOBJFORMAT} == "elf"
-+LDOPTIONS+=-Wl,-rpath,$(X11BASE)/lib
-+.endif
-
- # Options for xshogi
- # Use -DSENDTIME with at least gnushogix 1.2 patchlevel 3
-@@ -88,8 +92,8 @@
- # The option -DISS compiles xshogi for supporting the Internet Shogi Server.
- OPT = -DHAS_GETTIMEOFDAY -DSENDTIME -DISS -DTOP_PART_BITMAPS # -DBOTH_BITMAPS -DWESTERN_BITMAPS
-
--FIRST_PROGRAM = -DFIRST_CHESS_PROGRAM=\"$(BINDIR)/gnushogix\"
--SECOND_PROGRAM = -DSECOND_CHESS_PROGRAM=\"$(BINDIR)/gnushogix\"
-+FIRST_PROGRAM = -DFIRST_CHESS_PROGRAM=\"$(LOCALBASE)/libexec/gnushogix\"
-+SECOND_PROGRAM = -DSECOND_CHESS_PROGRAM=\"$(LOCALBASE)/libexec/gnushogix\"
- FIRST_HOST = -DFIRST_HOST=\"localhost\"
- SECOND_HOST = -DSECOND_HOST=\"localhost\"
-
diff --git a/games/xshogi/files/patch-ab b/games/xshogi/files/patch-ab
deleted file mode 100644
index 05b984ec8ee8..000000000000
--- a/games/xshogi/files/patch-ab
+++ /dev/null
@@ -1,19 +0,0 @@
-*** xshogi.c.org Tue Oct 8 01:04:00 1996
---- xshogi.c Tue Oct 8 01:04:26 1996
-***************
-*** 7132,7138 ****
- XtInputId *id;
- {
- char message[MSG_SIZ], *end_str, *number, *name;
-! extern char *sys_errlist[];
-
- if (fgets(message, MSG_SIZ, fp) == NULL) {
- if (fp == fromFirstProgFP) {
---- 7132,7138 ----
- XtInputId *id;
- {
- char message[MSG_SIZ], *end_str, *number, *name;
-! /*extern char *sys_errlist[];*/
-
- if (fgets(message, MSG_SIZ, fp) == NULL) {
- if (fp == fromFirstProgFP) {