aboutsummaryrefslogtreecommitdiff
path: root/games/xtet42/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-04-19 04:21:27 +0000
committerSteve Price <steve@FreeBSD.org>1999-04-19 04:21:27 +0000
commit113c308a1bec635f1afd290f7c9c3e38b290718a (patch)
treeacdbb834fa95119f6a3a3fcfddb8418aa4e78d09 /games/xtet42/Makefile
parent113be388dc8a81f8a61b7952d11b37d691f6303a (diff)
downloadports-113c308a1bec635f1afd290f7c9c3e38b290718a.tar.gz
ports-113c308a1bec635f1afd290f7c9c3e38b290718a.zip
Notes
Diffstat (limited to 'games/xtet42/Makefile')
-rw-r--r--games/xtet42/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/games/xtet42/Makefile b/games/xtet42/Makefile
new file mode 100644
index 000000000000..84464ee23c5f
--- /dev/null
+++ b/games/xtet42/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: xtet42
+# Version required: 2.21
+# Date created: 14 Feb 1999
+# Whom: gmarco@scotty.masternet.it
+#
+# $Id$
+#
+
+DISTNAME= xtet42-2.21
+CATEGORIES= games
+MASTER_SITES= http://www.pvv.ntnu.no/~oyvindmo/xtet42/
+
+MAINTAINER= freebsd@scotty.masternet.it
+
+USE_X_PREFIX= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-setgid=games
+
+MAN6= xtet42.6
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/X11/xtet42
+ @chown games:games ${PREFIX}/lib/X11/xtet42
+ @chmod 775 ${PREFIX}/lib/X11/xtet42
+ ${INSTALL} -c -m 2755 -g games ${WRKSRC}/xtet42 ${PREFIX}/bin
+ ${INSTALL} -c -m 664 -g games ${WRKSRC}/xtet42.hiscore ${PREFIX}/lib/X11/xtet42/.xtet42.hiscore
+ ${INSTALL} -c -m 664 -g games ${WRKSRC}/xtet42.hiscore.single ${PREFIX}/lib/X11/xtet42/.xtet42.hiscore.single
+ ${INSTALL} -c -m 664 -g games /dev/null ${PREFIX}/lib/X11/xtet42/.xtet42.unlock
+ ${INSTALL} -c -m 664 -g games /dev/null ${PREFIX}/lib/X11/xtet42/.xtet42.log
+ ${INSTALL_MAN} ${WRKSRC}/xtet42.6 ${PREFIX}/man/man6
+
+.include <bsd.port.mk>