aboutsummaryrefslogtreecommitdiff
path: root/games/xtron
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-09-11 21:57:40 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-09-11 21:57:40 +0000
commit41f778ba31397ede79e70f0645c853afd439b4fb (patch)
treec8bf4ed4f92ac6e22e4da669b18ec0e12d62b125 /games/xtron
parent767960debff163320425110d5d4b5f6c89da4888 (diff)
downloadports-41f778ba31397ede79e70f0645c853afd439b4fb.tar.gz
ports-41f778ba31397ede79e70f0645c853afd439b4fb.zip
Notes
Diffstat (limited to 'games/xtron')
-rw-r--r--games/xtron/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/games/xtron/Makefile b/games/xtron/Makefile
index 28ea81dff25b..fd140215e520 100644
--- a/games/xtron/Makefile
+++ b/games/xtron/Makefile
@@ -17,19 +17,27 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Avoid running into walls, your own tail, and that of your opponent
USE_XORG= x11 xpm
+MAKE_JOBS_SAFE= yes
+
+DESKTOP_ENTRIES="xtron" \
+ "Avoid running into walls, your own tail, and that of your opponent" \
+ "${DATADIR}/Xtron_icon.xpm" \
+ "xtron" \
+ "Game;ArcadeGame;" \
+ false
post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/xtronrc
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xtron ${PREFIX}/bin
- @${MKDIR} ${PREFIX}/share/xtron
- ${INSTALL_DATA} ${WRKSRC}/pixmaps/* ${PREFIX}/share/xtron
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/pixmaps/* ${DATADIR}/
${INSTALL_DATA} ${WRKSRC}/xtronrc ${PREFIX}/lib/X11/app-defaults/Tron
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/CHANGES ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CHANGES ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.mk>