aboutsummaryrefslogtreecommitdiff
path: root/games/xtruco
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /games/xtruco
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'games/xtruco')
-rw-r--r--games/xtruco/Makefile4
-rw-r--r--games/xtruco/files/patch-aa4
2 files changed, 4 insertions, 4 deletions
diff --git a/games/xtruco/Makefile b/games/xtruco/Makefile
index f5f35dccaebd..5b6d02643f61 100644
--- a/games/xtruco/Makefile
+++ b/games/xtruco/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xtruco
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= games
@@ -16,8 +16,8 @@ DISTNAME= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple version for X Window of the famous card game Super Truco
+USE_XORG= x11
PLIST_FILES= bin/xtruco
-USE_X_PREFIX= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xtruco ${PREFIX}/bin
diff --git a/games/xtruco/files/patch-aa b/games/xtruco/files/patch-aa
index fad5bbb28e4d..dc7a6b43b017 100644
--- a/games/xtruco/files/patch-aa
+++ b/games/xtruco/files/patch-aa
@@ -5,13 +5,13 @@
################################
-INCLUDES = -I/usr/X11/include
-+INCLUDES = -I${X11BASE}/include
++INCLUDES = -I${LOCALBASE}/include
# Remove '-DIPC_OK' if you have problems with 'shared-memory' (IPC routines)
OPC = -DIPC_OK
-LIBRARIES = -lX11 -L/usr/X11/lib
-+LIBRARIES = -lX11 -L${X11BASE}/lib
++LIBRARIES = -lX11 -L${LOCALBASE}/lib
CFILES = xtruco.c bitmap.c cursor.c display.c event.c gc.c pixmap.c\
topwind.c window.c color.c button.c font.c read.c