aboutsummaryrefslogtreecommitdiff
path: root/games/xye
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-01-13 21:29:57 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-01-13 21:29:57 +0000
commit5d2a35702ab4d545dfcda627f86097874166be95 (patch)
tree5b718ee4d227cbe8e9fb69a32945decd0fedfede /games/xye
parentad127bfbfb9e24f5cf08309b62c074cb7674dac2 (diff)
downloadports-5d2a35702ab4d545dfcda627f86097874166be95.tar.gz
ports-5d2a35702ab4d545dfcda627f86097874166be95.zip
- Update to 0.12.1
- Pass maintainership to submitter - Add LICENSE - Add themes and levels PR: ports/173504 Submitted by: nemysis <nemysis@gmx.ch> (new maintainer) Approved by: Robert Gogolok <gogo@cs.uni-sb.de> (previous maintainer)
Notes
Notes: svn path=/head/; revision=310339
Diffstat (limited to 'games/xye')
-rw-r--r--games/xye/Makefile93
-rw-r--r--games/xye/distinfo44
-rw-r--r--games/xye/files/patch-src_editorsave.cpp23
-rw-r--r--games/xye/files/pkg-message.in31
-rw-r--r--games/xye/pkg-descr8
-rw-r--r--games/xye/pkg-plist79
6 files changed, 250 insertions, 28 deletions
diff --git a/games/xye/Makefile b/games/xye/Makefile
index b63c50312569..ebf21a785eaf 100644
--- a/games/xye/Makefile
+++ b/games/xye/Makefile
@@ -1,18 +1,34 @@
-# New ports collection makefile for: xye
-# Date created: 3 May 2006
-# Whom: Robert Gogolok <gogo@cs.uni-sb.de>
-#
+# Created by: Robert Gogolok <gogo@cs.uni-sb.de>
# $FreeBSD$
-#
PORTNAME= xye
-PORTVERSION= 0.9.1
-PORTREVISION= 6
+PORTVERSION= 0.12.1
CATEGORIES= games
-MASTER_SITES= SF
+MASTER_SITES= SF:game \
+ http://xye.sourceforge.net/levels/ \
+ http://xye.sourceforge.net/:xmas \
+ SF/nemysisfreebsdp/:nemysis \
+ http://xye.sourceforge.net/skins/:skins
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}:game \
+ ${LEVELS:S/$/.zip/} \
+ ${LEVELS_XYE:S/$/.xye/} \
+ xmas-xye-2009.zip:xmas \
+ xye_extra_levels.20121109.zip:nemysis \
+ XMASKYESKIN.zip:skins \
+ Xye%20skin%20-%20classic%20kye.zip:skins
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${LEVELS:S/$/.zip/} \
+ xmas-xye-2009.zip \
+ xye_extra_levels.20121109.zip \
+ ${SKINS:S/$/.zip/}
-MAINTAINER= gogo@cs.uni-sb.de
-COMMENT= A puzzle game for X
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Puzzle games like sokoban or boulderdash
+
+LICENSE= ZLIB
+
+EXTRACT_DEPENDS=unzip:${PORTSDIR}/archivers/unzip
USE_SDL= sdl image ttf
GNU_CONFIGURE= yes
@@ -20,10 +36,65 @@ CONFIGURE_ARGS= --with-docdir=${PREFIX}/share/doc
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
-.ifdef NOPORTDOCS
+LEVELS= Xye%20level%20-%20Open%20Ended Xye%20level%20-%20Sorting \
+ Xye%20level%20-%20The%20insider Xye%20level%20-%20The%20slow%20speedrun \
+ Xye%20level%20-%20disturbingarrows Xye%20level%20-%20Duels%20of%20fate \
+ nuffmagnets Xye%20levels%20-%20Pyramid%20treasure afirflood \
+ Xye%20level%20-%20Blob%20prison Xye%20levels%20-%20ActionReplay \
+ Xye%20level%20-%20gravity Xye%20level%20-%20pluzze
+
+LEVELS_XYE= dungeon turnaround chekhov
+
+SKINS= XMASKYESKIN Xye%20skin%20-%20classic%20kye
+
+DESKTOP_ENTRIES="Xye" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Game;LogicGame;" ${FALSE}
+
+SUB_FILES= pkg-message
+
+OPTIONS_DEFINE= DOCS SKINS
+OPTIONS_DEFAULT= SKINS
+SKINS_DESC= Install additional skins
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_SKINS)
+PLIST_SUB+= SKINS=""
+.else
+PLIST_SUB+= SKINS="@comment "
+.endif
+
+post-extract-script:
+.for l in ${LEVELS:S/$/.zip/} xmas-xye-2009.zip xye_extra_levels.20121109.zip
+ @${UNZIP_CMD} -qoj -d ${WRKDIR} ${DISTDIR}/${DIST_SUBDIR}/${l}
+.endfor
+
+.if ${PORT_OPTIONS:MSKINS}
+. for s in ${SKINS:S/$/.zip/}
+ @${UNZIP_CMD} -qoj -d ${WRKDIR}/skins ${DISTDIR}/${DIST_SUBDIR}/${s}
+. endfor
+.endif
+
post-patch:
+ @${REINPLACE_CMD} -e 's|docedir = $$(datadir)|docedir = ${PREFIX}/share/doc|' \
+ ${WRKSRC}/Makefile.in
+
+.if !${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} '/install-data-am:/s/install-doceDATA//' \
${WRKSRC}/Makefile.in
.endif
+post-install:
+ @cd ${WRKDIR} && ${COPYTREE_SHARE} "*.xye *.txt" ${DATADIR}/levels
+
+.if ${PORT_OPTIONS:MSKINS}
+ @cd ${WRKDIR}/skins && ${COPYTREE_SHARE} \* ${DATADIR}/res
+.endif
+
+ ${LN} -sf ${DATADIR}/res/detailed_icon.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
.include <bsd.port.mk>
diff --git a/games/xye/distinfo b/games/xye/distinfo
index 8d3b452ecb90..64bb91c36ae4 100644
--- a/games/xye/distinfo
+++ b/games/xye/distinfo
@@ -1,2 +1,42 @@
-SHA256 (xye-0.9.1.tar.gz) = 950851420c9b5d4ed4c993552092852b8261441a609150043c7fc20883299b30
-SIZE (xye-0.9.1.tar.gz) = 1217636
+SHA256 (xye/xye-0.12.1.tar.gz) = bbeb3265b0795f14deb2851b4a3bda7dde9b07d624a7ca5fb88cd7acabcf3967
+SIZE (xye/xye-0.12.1.tar.gz) = 2850776
+SHA256 (xye/Xye%20level%20-%20Open%20Ended.zip) = ef3076a0f7b77ce1195195788da7e62939513fac7a7bdd883618d115f3712348
+SIZE (xye/Xye%20level%20-%20Open%20Ended.zip) = 3244
+SHA256 (xye/Xye%20level%20-%20Sorting.zip) = f74894d02a99523f3b2f74d93613ea2bd0202cabd0c3467f57daabae20594457
+SIZE (xye/Xye%20level%20-%20Sorting.zip) = 2750
+SHA256 (xye/Xye%20level%20-%20The%20insider.zip) = d4f11e82727732012268178e824c4c725dc11b722a9e1d8761c699361bbe8973
+SIZE (xye/Xye%20level%20-%20The%20insider.zip) = 2658
+SHA256 (xye/Xye%20level%20-%20The%20slow%20speedrun.zip) = 266e3c72c0584c4f0c77339321827957e753d4611a248dd8bf4b4778fd847536
+SIZE (xye/Xye%20level%20-%20The%20slow%20speedrun.zip) = 2871
+SHA256 (xye/Xye%20level%20-%20disturbingarrows.zip) = d11a31cdfa015cc4a452363e10938eaa006811043b98308c077919f7e8464e8c
+SIZE (xye/Xye%20level%20-%20disturbingarrows.zip) = 2784
+SHA256 (xye/Xye%20level%20-%20Duels%20of%20fate.zip) = 64c5002e0fe9128277ff7798baf03af6d0c4bc174a79a20513e2a8900fac9cb2
+SIZE (xye/Xye%20level%20-%20Duels%20of%20fate.zip) = 2050
+SHA256 (xye/nuffmagnets.zip) = 03882bec5af7cfbfadcec39f0fe2ae5661c7268d7a62df90a8a41c8761d5c450
+SIZE (xye/nuffmagnets.zip) = 4117
+SHA256 (xye/Xye%20levels%20-%20Pyramid%20treasure.zip) = a85b535b94c30108036b8d2da4d042aa5602f3b2121b1b47a6c351a4cb3fee1d
+SIZE (xye/Xye%20levels%20-%20Pyramid%20treasure.zip) = 7660
+SHA256 (xye/afirflood.zip) = fc41dd6b290a5e2540d6f0bc9ce9f2bb3fc4adcf4b8b456bab9ff146ea3bce9b
+SIZE (xye/afirflood.zip) = 2217
+SHA256 (xye/Xye%20level%20-%20Blob%20prison.zip) = b4994086cf2ffbde695c537a003ba7f04e7e5e6ca7b33d787fb1d73be629e446
+SIZE (xye/Xye%20level%20-%20Blob%20prison.zip) = 2105
+SHA256 (xye/Xye%20levels%20-%20ActionReplay.zip) = ff3330abe2b13c23cc052442ccb7effb5efee0173ce815366d95331832e6e8a9
+SIZE (xye/Xye%20levels%20-%20ActionReplay.zip) = 37395
+SHA256 (xye/Xye%20level%20-%20gravity.zip) = d7c47493d09584209a7027ae5bcc3d5807764996178840ab86e25f4784728a1d
+SIZE (xye/Xye%20level%20-%20gravity.zip) = 2551
+SHA256 (xye/Xye%20level%20-%20pluzze.zip) = d62057824b8de3e83f39cdf9fa1bcd6c421d2a357cebf0644e171d7fbf623f16
+SIZE (xye/Xye%20level%20-%20pluzze.zip) = 1853
+SHA256 (xye/dungeon.xye) = 7615339919a3ae8991e5cee46d07e8e7e5fcf2c4456cad6c60b02cb85c1891bb
+SIZE (xye/dungeon.xye) = 11341
+SHA256 (xye/turnaround.xye) = 2038203c290bafe0b67605dbe3c209aa3f49a73dde5ea9a0d96df0c771c85c70
+SIZE (xye/turnaround.xye) = 11356
+SHA256 (xye/chekhov.xye) = 20f6ca6850d17fdd06e32370e5018940ccc8a2f231627aeec064d8ab4e53cb5b
+SIZE (xye/chekhov.xye) = 10247
+SHA256 (xye/xmas-xye-2009.zip) = 2db90f4155a16ad9a8edb343747b37adba82f1138b253b8a5aa531a451aec261
+SIZE (xye/xmas-xye-2009.zip) = 9763
+SHA256 (xye/xye_extra_levels.20121109.zip) = 3912f4b9b6849cc197733a38792ca623569e4e82428a910341cadea66579ef87
+SIZE (xye/xye_extra_levels.20121109.zip) = 47941
+SHA256 (xye/XMASKYESKIN.zip) = dcc3323eda62ccb81b1ecd8c06cd9412a68e4c27cf0cd64273a9b046b16c8524
+SIZE (xye/XMASKYESKIN.zip) = 45993
+SHA256 (xye/Xye%20skin%20-%20classic%20kye.zip) = 8c8b15afbc6f9aa363e78d8c986eaa86f2d74494e8c358642664ca68a36897f7
+SIZE (xye/Xye%20skin%20-%20classic%20kye.zip) = 81926
diff --git a/games/xye/files/patch-src_editorsave.cpp b/games/xye/files/patch-src_editorsave.cpp
new file mode 100644
index 000000000000..10c019fb0a2f
--- /dev/null
+++ b/games/xye/files/patch-src_editorsave.cpp
@@ -0,0 +1,23 @@
+--- src/editorsave.cpp.orig 2013-01-13 21:51:34.000000000 +0100
++++ src/editorsave.cpp 2013-01-13 21:50:22.000000000 +0100
+@@ -636,16 +636,16 @@
+ }
+ saveColorStuff(file, board);
+
+- int i,j;
++ int k,j;
+ file << "\t<ground>\n";
+ resetSavedPosition();
+- for (i=0;i<XYE_HORZ;i++) for (j=0;j<XYE_VERT;j++) saveGroundObject(file,editor::board->objects[i][j],i,XYE_VERT-j-1);
++ for (k=0;k<XYE_HORZ;k++) for (j=0;j<XYE_VERT;j++) saveGroundObject(file,editor::board->objects[k][j],k,XYE_VERT-j-1);
+ file << "\t</ground>\n";
+ file << "\t<objects>\n";
+ resetSavedPosition();
+- for (i=0;i<XYE_HORZ;i++) for (j=0;j<XYE_VERT;j++)
++ for (k=0;i<XYE_HORZ;k++) for (j=0;j<XYE_VERT;j++)
+ {
+- saveNormalObject(file,editor::board->objects[i][j],i,XYE_VERT-j-1);
++ saveNormalObject(file,editor::board->objects[k][j],k,XYE_VERT-j-1);
+ }
+ savePortals( file, editor::board);
+
diff --git a/games/xye/files/pkg-message.in b/games/xye/files/pkg-message.in
new file mode 100644
index 000000000000..0668330479c6
--- /dev/null
+++ b/games/xye/files/pkg-message.in
@@ -0,0 +1,31 @@
+===============================================================================
+
+Xye has been installed.
+
+Xye can use Kye and Sokoban levels.
+
+In addition, you can search for additional extra Levels here:
+
+ http://xye.sourceforge.net/levels.php
+
+ http://xyegame.blogspot.com/
+
+and other Sites and put it in:
+
+ ~/.xye/levels
+
+
+You could manually change Permissions these Levels with:
+
+ /bin/chmod 444 ~/.xye/levels
+
+
+In addition, you can use skins
+
+ http://xyegame.blogspot.com/search/label/skins
+
+and other Sites and put it in:
+
+ ~/.xye/res
+
+===============================================================================
diff --git a/games/xye/pkg-descr b/games/xye/pkg-descr
index 38c79da578a9..64666c9b6749 100644
--- a/games/xye/pkg-descr
+++ b/games/xye/pkg-descr
@@ -1,6 +1,6 @@
-In this game you have to get/eat all the diamonds in the level,
-but it is not as easy as it sounds, many dangers are present,
-traps made out of those arrow blocks, for example.
-Also beasts that try to eat you.
+Xye is a puzzle game in which the objective is to help a character that looks
+like a green circle to get all the gems in the room. This is, of course,
+not as easy as it sounds, Xye must solve all sorts of puzzles while
+at the same time avoiding all sorts of traps and beasts.
WWW: http://xye.sourceforge.net/
diff --git a/games/xye/pkg-plist b/games/xye/pkg-plist
index 2a848463a4e4..109fe8fb969e 100644
--- a/games/xye/pkg-plist
+++ b/games/xye/pkg-plist
@@ -1,33 +1,90 @@
bin/xye
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/GAMEINTRO.txt
-%%PORTDOCS%%%%DOCSDIR%%/xye.svg
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/ReadMe.html
+%%PORTDOCS%%%%DOCSDIR%%/xye.svg
+share/pixmaps/xye.png
%%DATADIR%%/levels/5levels.xye
+%%DATADIR%%/levels/ActionReplay v.1.xye
+%%DATADIR%%/levels/ActionReplay v.2.xye
+%%DATADIR%%/levels/ActionReplay v.3.xye
+%%DATADIR%%/levels/Cracked Puzzle.xye
+%%DATADIR%%/levels/Grassy.xye
%%DATADIR%%/levels/Mic4.xye
+%%DATADIR%%/levels/Phipps.xye
+%%DATADIR%%/levels/Puzzle of Pyramid.txt
+%%DATADIR%%/levels/Pyramid Treasure.xye
+%%DATADIR%%/levels/SuperJustin.xye
+%%DATADIR%%/levels/afirflood.xye
+%%DATADIR%%/levels/blobprison.xye
+%%DATADIR%%/levels/complexity.xye
%%DATADIR%%/levels/cracked.xye
-%%DATADIR%%/levels/kye.xye
+%%DATADIR%%/levels/decision.xye
+%%DATADIR%%/levels/disturbingarrows.xye
+%%DATADIR%%/levels/duelsfate.xye
+%%DATADIR%%/levels/fast.xye
+%%DATADIR%%/levels/find1.xye
+%%DATADIR%%/levels/gravity.xye
+%%DATADIR%%/levels/insider.xye
%%DATADIR%%/levels/levels.xye
%%DATADIR%%/levels/logo.xye
%%DATADIR%%/levels/microban.xsb
+%%DATADIR%%/levels/need2.xye
+%%DATADIR%%/levels/nuffmagnets.xye
%%DATADIR%%/levels/oldtutorials.xye
+%%DATADIR%%/levels/openended.xye
+%%DATADIR%%/levels/pluzze.xye
+%%DATADIR%%/levels/prison.xye
%%DATADIR%%/levels/pxlevels.xye
+%%DATADIR%%/levels/releasethem.xye
+%%DATADIR%%/levels/savage.xye
+%%DATADIR%%/levels/slowspeed.xye
+%%DATADIR%%/levels/snowforts.xye
+%%DATADIR%%/levels/sorting.xye
%%DATADIR%%/levels/sphinx.xye
%%DATADIR%%/levels/tutorials.xye
+%%DATADIR%%/levels/twoinone.xye
+%%DATADIR%%/levels/xmas2009.xye
+%%DATADIR%%/levels/xmas_xye_readme.txt
%%DATADIR%%/levels/xyester.xye
+%%DATADIR%%/levels/xyester2.xye
%%DATADIR%%/res/DejaVuSans-Bold.ttf
%%DATADIR%%/res/DejaVuSans.ttf
-%%DATADIR%%/res/classic.xml
+%%SKINS%%%%DATADIR%%/res/XMASKye.png
+%%SKINS%%%%DATADIR%%/res/XMASKye_luminosity.png
+%%SKINS%%%%DATADIR%%/res/XMASKye_luminositycopy.png
+%%SKINS%%%%DATADIR%%/res/classic.xml
+%%SKINS%%%%DATADIR%%/res/classic32.xml
+%%DATADIR%%/res/clean40.png
+%%DATADIR%%/res/clean40.xml
+%%DATADIR%%/res/clean40_luminosity.png
%%DATADIR%%/res/default.xml
+%%DATADIR%%/res/default_icon.png
+%%DATADIR%%/res/detailed.png
+%%DATADIR%%/res/detailed.xml
+%%DATADIR%%/res/detailed20.png
+%%DATADIR%%/res/detailed20.xml
+%%DATADIR%%/res/detailed30.png
+%%DATADIR%%/res/detailed30.xml
+%%DATADIR%%/res/detailed_COPYING
+%%DATADIR%%/res/detailed_L.png
+%%DATADIR%%/res/detailed_L20.png
+%%DATADIR%%/res/detailed_L30.png
+%%DATADIR%%/res/detailed_icon.png
%%DATADIR%%/res/fon.bmp
%%DATADIR%%/res/fon_bold.bmp
-%%DATADIR%%/res/kye.png
+%%SKINS%%%%DATADIR%%/res/kye.png
+%%SKINS%%%%DATADIR%%/res/kye.xcf
+%%SKINS%%%%DATADIR%%/res/kye32.png
+%%SKINS%%%%DATADIR%%/res/kye32_luminosity.png
+%%SKINS%%%%DATADIR%%/res/kye_icon.png
+%%SKINS%%%%DATADIR%%/res/kye_luminosity.png
+%%SKINS%%%%DATADIR%%/res/xmaskye jr..xml
+%%SKINS%%%%DATADIR%%/res/xmaskye.xml
%%DATADIR%%/res/xye.png
%%DATADIR%%/res/xye_luminosity.png
-@dirrm %%DATADIR%%/levels
@dirrm %%DATADIR%%/res
+@dirrm %%DATADIR%%/levels
@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%