aboutsummaryrefslogtreecommitdiff
path: root/games/yadex
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-11-07 09:31:01 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-11-07 09:31:01 +0000
commit954b38eec95761cf9d0752208cd63f90f50928dc (patch)
treed862b4bc55a3bb822218abed2929f6db1bf3b2e8 /games/yadex
parent966736f2f6f2f7b6432857013946c02cdad84833 (diff)
downloadports-954b38eec95761cf9d0752208cd63f90f50928dc.tar.gz
ports-954b38eec95761cf9d0752208cd63f90f50928dc.zip
- Provide working MASTER_SITES while the original website went down
- Install files with our native install(1) instead of handrolled one, this fixes "Warning: 'bin/yadex' is not stripped" reported by Q/A
Notes
Notes: svn path=/head/; revision=516952
Diffstat (limited to 'games/yadex')
-rw-r--r--games/yadex/Makefile5
-rw-r--r--games/yadex/files/patch-GNUmakefile8
2 files changed, 6 insertions, 7 deletions
diff --git a/games/yadex/Makefile b/games/yadex/Makefile
index 4aa681b48fcd..66c5bb70cf95 100644
--- a/games/yadex/Makefile
+++ b/games/yadex/Makefile
@@ -5,14 +5,13 @@ PORTNAME= yadex
PORTVERSION= 1.7.0
PORTREVISION= 3
CATEGORIES= games
-MASTER_SITES= http://www.teaser.fr/~amajorel/yadex/
+MASTER_SITES= http://vault.101011010.xyz/distfiles/yadex/ \
+ http://freebsd.nsu.ru/distfiles/yadex/ GENTOO
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= danfe@FreeBSD.org
COMMENT= WAD file editor, for games like Doom and Heretic
-BROKEN= unfetchable
-
LICENSE= GPLv2
USES= gmake perl5 shebangfix xorg
diff --git a/games/yadex/files/patch-GNUmakefile b/games/yadex/files/patch-GNUmakefile
index ae9020e66947..5bfdd6e70a04 100644
--- a/games/yadex/files/patch-GNUmakefile
+++ b/games/yadex/files/patch-GNUmakefile
@@ -50,11 +50,11 @@
+ @scripts/mkinstalldirs $(DESTDIR)$(MANDIR)/man6
+ @scripts/mkinstalldirs $(DESTDIR)$(SHAREDIR)
+ rm -f $(DESTDIR)$(BINDIR)/yadex
-+ $(OBJDIR)/install -m 755 $(OBJDIR)/yadex $(DESTDIR)$(BINDIR)/yadex
++ $(BSD_INSTALL_PROGRAM) $(OBJDIR)/yadex $(DESTDIR)$(BINDIR)
+ rm -f $(DESTDIR)$(MANDIR)/man6/yadex.6*
-+ $(OBJDIR)/install -m 644 doc/yadex.6 $(DESTDIR)$(MANDIR)/man6/yadex.6
-+ $(OBJDIR)/install -m 644 -d $(DESTDIR)$(SHAREDIR) $(YGD)
-+ $(OBJDIR)/install -m 644 -d $(DESTDIR)$(ETCDIR) yadex.cfg
++ $(BSD_INSTALL_MAN) doc/yadex.6 $(DESTDIR)$(MANDIR)/man6
++ $(BSD_INSTALL_DATA) $(YGD) $(DESTDIR)$(SHAREDIR)
++ $(BSD_INSTALL_DATA) yadex.cfg $(DESTDIR)$(ETCDIR)
+ifndef DESTDIR
@echo "---------------------------------------------------------------"
@echo " Yadex is now installed."