aboutsummaryrefslogtreecommitdiff
path: root/games/yadex
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2018-09-05 13:51:08 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2018-09-05 13:51:08 +0000
commitde6b03624f94ba781e401980ec9fa1f6709fd9ae (patch)
treea4f56c071cc5525f8162f0cab5975d0c928fe312 /games/yadex
parente59ea98af157d87dd60719a7a525343bff5e798b (diff)
downloadports-de6b03624f94ba781e401980ec9fa1f6709fd9ae.tar.gz
ports-de6b03624f94ba781e401980ec9fa1f6709fd9ae.zip
- Do not (ab)use PATCH_SITE_SUBDIR where it's not needed; this also makes
the address suitable for paste-and-go in the web browser - Use option helpers to construct PATCHFILES list and during post-patch
Notes
Notes: svn path=/head/; revision=479022
Diffstat (limited to 'games/yadex')
-rw-r--r--games/yadex/Makefile28
1 files changed, 11 insertions, 17 deletions
diff --git a/games/yadex/Makefile b/games/yadex/Makefile
index a3386907e881..a65e4d7c835f 100644
--- a/games/yadex/Makefile
+++ b/games/yadex/Makefile
@@ -30,36 +30,30 @@ SEARCH_DESC= Thing, linedef, or sector search by type
EXTRA_TOOLS_DESC= Add a few extra tools to Yadex' repertoire
LAPTOP_KEYS_DESC= Key bindings for easier editing on laptops
-.include <bsd.port.options.mk>
-
-PATCH_SITES= http://glbsp.sourceforge.net/%SUBDIR%/
-PATCH_SITE_SUBDIR= ${PORTNAME}
+PATCH_SITES= http://glbsp.sourceforge.net/yadex/
PATCH_DIST_STRIP= -p1
PATCH_PREFIX= Yadex_${PORTVERSION:S/.//g}
PATCH_SUFFIX= .diff
PATCHFILES= ${PATCH_PREFIX}_Depend${PATCH_SUFFIX}
+3D_RENDER_PATCHFILES= ${PATCH_PREFIX}_Render3D${PATCH_SUFFIX}
+SEARCH_PATCHFILES= ${PATCH_PREFIX}_Find${PATCH_SUFFIX}
+EXTRA_TOOLS_PATCHFILES= ${PATCH_PREFIX}_Tools${PATCH_SUFFIX}
+LAPTOP_KEYS_PATCHFILES= ${PATCH_PREFIX}_Keys${PATCH_SUFFIX}
+
+.include <bsd.port.options.mk>
+
.if ${PORT_OPTIONS:M3D_RENDER}
-PATCHFILES+= ${PATCH_PREFIX}_Render3D${PATCH_SUFFIX}
PLIST_SUB+= 3DRENDER=""
.else
PLIST_SUB+= 3DRENDER="@comment "
.endif
-.if ${PORT_OPTIONS:MSEARCH}
-PATCHFILES+= ${PATCH_PREFIX}_Find${PATCH_SUFFIX}
-.endif
-.if ${PORT_OPTIONS:MEXTRA_TOOLS}
-PATCHFILES+= ${PATCH_PREFIX}_Tools${PATCH_SUFFIX}
-.endif
-.if ${PORT_OPTIONS:MLAPTOP_KEYS}
-PATCHFILES+= ${PATCH_PREFIX}_Keys${PATCH_SUFFIX}
-.endif
-post-patch:
-.if ${PORT_OPTIONS:MWHITE_BG}
+post-patch-WHITE_BG-on:
@${REINPLACE_CMD} -E 's,^#(CXXFLAGS \+= -DWHITE_BACKGROUND)$$,\1,' \
${WRKSRC}/${MAKEFILE}
-.endif
+
+post-patch:
# Fix the build against Clang 6.0.0
@${REINPLACE_CMD} -e 's,1000000ul,1000000l,' ${WRKSRC}/src/input.cc