aboutsummaryrefslogtreecommitdiff
path: root/games/yahtzee
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-11-06 20:41:41 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-11-06 20:41:41 +0000
commit57599699ad2fd967b97d3baae82241d84ad053f7 (patch)
treea58b0af9901f7ec48614ce98000932ce753c33ee /games/yahtzee
parent5b7ca00e9d5d70675777239bfe5f13cafd71e232 (diff)
downloadports-57599699ad2fd967b97d3baae82241d84ad053f7.tar.gz
ports-57599699ad2fd967b97d3baae82241d84ad053f7.zip
- Fix build on -current
- Utilize DATADIR PR: 59007 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=93250
Diffstat (limited to 'games/yahtzee')
-rw-r--r--games/yahtzee/Makefile12
-rw-r--r--games/yahtzee/files/patch-ac31
-rw-r--r--games/yahtzee/pkg-plist4
3 files changed, 34 insertions, 13 deletions
diff --git a/games/yahtzee/Makefile b/games/yahtzee/Makefile
index 9c242035f178..8153131ab12c 100644
--- a/games/yahtzee/Makefile
+++ b/games/yahtzee/Makefile
@@ -19,17 +19,11 @@ COMMENT= A curses version of the dice game for one or more players
WRKSRC= ${WRKDIR}/${PORTNAME}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
# Distribution does not include an install target. So here it is.
#
do-install:
${INSTALL_PROGRAM} -m 2755 -o root -g games ${WRKSRC}/yahtzee ${PREFIX}/bin
- ${MKDIR} -m 0755 ${PREFIX}/share/yahtzee
- ${INSTALL_DATA} -m 0664 -o root -g games /dev/null ${PREFIX}/share/yahtzee/yahtzee.sco
+ ${MKDIR} -m 0755 ${DATADIR}
+ ${INSTALL_DATA} -m 0664 -o root -g games /dev/null ${DATADIR}/yahtzee.sco
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/yahtzee/files/patch-ac b/games/yahtzee/files/patch-ac
index 0b6f7679e4e5..c5c96b2893a6 100644
--- a/games/yahtzee/files/patch-ac
+++ b/games/yahtzee/files/patch-ac
@@ -1,5 +1,5 @@
---- main.c.orig Sat Jan 25 19:41:13 1992
-+++ main.c Fri Jul 4 13:39:01 1997
+--- main.c.orig Sat Jan 25 17:41:13 1992
++++ main.c Thu Nov 6 18:12:58 2003
@@ -12,7 +12,7 @@
* (c)1992 by orest zborowski
*/
@@ -9,6 +9,33 @@
extern errno;
+@@ -138,7 +138,7 @@
+
+ initscr();
+ if (LINES < 23)
+- abort("Not enough lines on the terminal");
++ _abort("Not enough lines on the terminal");
+ numlines = LINES;
+ clear();
+ mvaddstr(0, 9, header);
+@@ -156,7 +156,7 @@
+ endwin();
+ }
+
+-abort(char *msg)
++_abort(char *msg)
+ {
+ yend();
+ putchar('\n');
+@@ -278,7 +278,7 @@
+ int j;
+
+ if (num < 1 || num > 5)
+- abort("Bad dice loc passed");
++ _abort("Bad dice loc passed");
+
+ for (j = 0; j < 1; ++j)
+ {
@@ -820,6 +820,7 @@
int i;
int topscore;
diff --git a/games/yahtzee/pkg-plist b/games/yahtzee/pkg-plist
index 95324a34ae8c..b14f367b3f14 100644
--- a/games/yahtzee/pkg-plist
+++ b/games/yahtzee/pkg-plist
@@ -1,3 +1,3 @@
bin/yahtzee
-share/yahtzee/yahtzee.sco
-@dirrm share/yahtzee
+%%DATADIR%%/yahtzee.sco
+@dirrm %%DATADIR%%