aboutsummaryrefslogtreecommitdiff
path: root/games/yahtzee
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-02-04 22:34:56 +0000
committerJohn Marino <marino@FreeBSD.org>2016-02-04 22:34:56 +0000
commitfeb9d6a9e2806a6cee4f9af471530e9fd045b9cf (patch)
treec1e827992564a5f04d9311cbc303d1f579c4e660 /games/yahtzee
parent118d0018d26cba2cd268e60de35692ecf83dedeb (diff)
downloadports-feb9d6a9e2806a6cee4f9af471530e9fd045b9cf.tar.gz
ports-feb9d6a9e2806a6cee4f9af471530e9fd045b9cf.zip
games/yahtzee: USES+= ncurses, respect LDFLAGS
Notes
Notes: svn path=/head/; revision=408115
Diffstat (limited to 'games/yahtzee')
-rw-r--r--games/yahtzee/Makefile2
-rw-r--r--games/yahtzee/files/patch-Makefile8
2 files changed, 5 insertions, 5 deletions
diff --git a/games/yahtzee/Makefile b/games/yahtzee/Makefile
index f0bb5694a2a7..a06c57db113f 100644
--- a/games/yahtzee/Makefile
+++ b/games/yahtzee/Makefile
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= Curses version of the dice game for one or more players
-USES= tar:Z
+USES= ncurses tar:Z
WRKSRC= ${WRKDIR}/${PORTNAME}
do-install:
diff --git a/games/yahtzee/files/patch-Makefile b/games/yahtzee/files/patch-Makefile
index 514836de8226..b0ef2a472f25 100644
--- a/games/yahtzee/files/patch-Makefile
+++ b/games/yahtzee/files/patch-Makefile
@@ -1,17 +1,17 @@
---- Makefile.orig Sat Jan 25 17:45:26 1992
-+++ Makefile Wed Nov 8 04:48:42 2000
+--- Makefile.orig 1992-01-25 08:45:26 UTC
++++ Makefile
@@ -1,4 +1,4 @@
-CFLAGS =
+CFLAGS += -DHAS_RENAME -DSCOREDIR=\"/var/games/yahtzee\"
OBJ = computer.o main.o
-@@ -7,9 +7,11 @@
+@@ -7,9 +7,11 @@ LIBS = -lcurses
BIN = yahtzee
$(BIN): $(OBJ)
- cc -o $@ $(OBJ) -lcurses
-+ $(CC) -o $@ $(OBJ) -lcurses
++ $(CC) -o $@ $(OBJ) $(LDFLAGS) -lncurses
clean:
rm -f $(OBJ) $(BIN)