aboutsummaryrefslogtreecommitdiff
path: root/games/zatacka/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-10-18 01:20:27 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-10-18 01:20:27 +0000
commit9c5376ffe8ce93c57a1330f2c5ab4cbf6285c27b (patch)
treeb113b031d3ef015fd24bfa23b6ca349b392e08a2 /games/zatacka/Makefile
parent7e548627c90ec4791d5c57dd3d94612aea1c42a4 (diff)
downloadports-9c5376ffe8ce93c57a1330f2c5ab4cbf6285c27b.tar.gz
ports-9c5376ffe8ce93c57a1330f2c5ab4cbf6285c27b.zip
Notes
Diffstat (limited to 'games/zatacka/Makefile')
-rw-r--r--games/zatacka/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/games/zatacka/Makefile b/games/zatacka/Makefile
index 7333acce9c93..f9e93a776b68 100644
--- a/games/zatacka/Makefile
+++ b/games/zatacka/Makefile
@@ -11,13 +11,14 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}_src
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Nibbles-like multiplayer game
+GNU_CONFIGURE= yes
+USES= gmake
USE_SDL= sdl ttf image
-USE_GMAKE= yes
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include"
+CPPFLAGS+= -I${LOCALBASE}/include
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDATA= *
DESKTOP_ENTRIES="Zatacka" \
"Nibbles-like multiplayer game" \
@@ -26,7 +27,6 @@ DESKTOP_ENTRIES="Zatacka" \
"Game;ArcadeGame;" \
false
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|__linux__|__FreeBSD__|; s|\[30\]|[PATH_MAX]|' \
${WRKSRC}/src/main.cpp