aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-03-24 00:05:09 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-03-24 00:05:09 +0000
commit0b2e36f867f72b17d5d81630b46b2cc6e7974eef (patch)
tree9c39f379e42052d13eeb7c1f67ff24dbea00b98b /games
parente250721c7195ea2b19c3ee1d13da456187c3d609 (diff)
downloadports-0b2e36f867f72b17d5d81630b46b2cc6e7974eef.tar.gz
ports-0b2e36f867f72b17d5d81630b46b2cc6e7974eef.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/domination/Makefile47
-rw-r--r--games/domination/files/domination-FlashGUI.in4
-rw-r--r--games/domination/files/domination-Increment1GUI.in4
-rw-r--r--games/domination/files/domination-SimpleGUI.in4
-rw-r--r--games/domination/files/domination-SwingGUI.in4
-rw-r--r--games/domination/files/pkg-deinstall.in18
-rw-r--r--games/domination/pkg-descr2
-rw-r--r--games/domination/pkg-plist10
8 files changed, 53 insertions, 40 deletions
diff --git a/games/domination/Makefile b/games/domination/Makefile
index 9309c90235ff..f03879c8db35 100644
--- a/games/domination/Makefile
+++ b/games/domination/Makefile
@@ -1,10 +1,11 @@
-# Created by: nemysis <nemysis@gmx.ch>
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
# $FreeBSD$
PORTNAME= domination
PORTVERSION= 1.1.1.5
+PORTREVISION= 1
CATEGORIES= games java
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME:S/d/D/}/${PORTVERSION}/:game \
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME:S/d/D/}/${PORTVERSION}/:game \
http://domination.sourceforge.net/maps/
DISTFILES= ${PORTNAME:S/d/D/}_${DISTVERSION}${EXTRACT_SUFX}:game \
${MAPS:S/$/.zip/}
@@ -16,7 +17,8 @@ COMMENT= Board game that is a bit like the well known game Risk
LICENSE= GPLv3
-USES= zip:infozip
+USES= dos2unix zip:infozip
+DOS2UNIX_GLOB= *.txt *.ini *.htm *.cards *.map
USE_JAVA= yes
JAVA_VERSION= 1.6+
NO_BUILD= yes
@@ -27,28 +29,27 @@ WRKSRC= ${WRKDIR}/${PORTNAME:S/d/D/}
MAPS= solar bigeurope google europass europe artic sudamerica \
MiddleEast-Qatar kosova Falkland-Islands england sw_baltic \
spain swiss france austria austria-hungary eire haiti brasil \
- benelux canada germany northeurope germany1871 Deutsches_Reich_1871 \
- eesti estonia mexico serbia fletzmap greece North_of_Italy \
- bayern berlin navarra Illes_Balears calw wuppertal kerzell \
- ennepe-ruhr-kreis cologne saarland andorra catalunya astadt \
- dortmund rio_de_janeiro caribbean Nuremberg_Public_Transit \
- discworld aztec GTA_SAN_AN middleearth LOTR2 wow randland \
- Riskopoly SuperRiskopoly trivia chutes sudoku conquest \
- chrono_trigger startrek usa8 civilwar usa hawaii ohio nyc \
- zertina fortress estlandr periodictable sylsia troisdorf \
- wolken castle naerr cow westfalenhalle union rub gymnasium \
- simpsons_world simpsons germany2
-
-PORTDOCS= ChangeLog.txt ReadMe.txt commands.txt todo.txt
-
+ benelux canada germany northeurope germany1871 \
+ Deutsches_Reich_1871 eesti estonia mexico serbia fletzmap \
+ greece North_of_Italy bayern berlin navarra Illes_Balears \
+ calw wuppertal kerzell ennepe-ruhr-kreis cologne saarland \
+ andorra catalunya astadt dortmund rio_de_janeiro caribbean \
+ Nuremberg_Public_Transit discworld aztec GTA_SAN_AN \
+ middleearth LOTR2 wow randland Riskopoly SuperRiskopoly \
+ trivia chutes sudoku conquest chrono_trigger startrek usa8 \
+ civilwar usa hawaii ohio nyc zertina fortress estlandr \
+ periodictable sylsia troisdorf wolken castle naerr cow \
+ westfalenhalle union rub gymnasium simpsons_world simpsons \
+ germany2
+
+PORTDOCS= ChangeLog.txt ReadMe.txt commands.txt
OPTIONS_DEFINE= DOCS
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
-SUB_FILES= ${PORTNAME}-FlashGUI \
- ${PORTNAME}-Increment1GUI \
- ${PORTNAME}-SimpleGUI \
- ${PORTNAME}-SwingGUI
+SUB_FILES= ${PORTNAME}-FlashGUI ${PORTNAME}-Increment1GUI \
+ ${PORTNAME}-SimpleGUI ${PORTNAME}-SwingGUI \
+ pkg-deinstall
DESKTOP_ENTRIES="Domination" "" "${PORTNAME}" \
"${PORTNAME}-SwingGUI" "Game;StrategyGame;" ""
@@ -62,10 +63,10 @@ post-extract-script:
do-install:
(cd ${WRKSRC} && ${COPYTREE_SHARE} \
- "help lib maps resources saves *.jar *.cmd *.htm *.txt *.ini" \
+ "help lib maps resources saves *.jar *.htm *.txt *.ini" \
${STAGEDIR}${DATADIR})
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}-* ${STAGEDIR}${PREFIX}/bin/
- @(cd ${WRKSRC} && ${INSTALL_SCRIPT} *.sh ${STAGEDIR}${DATADIR})
+ (cd ${WRKSRC} && ${INSTALL_SCRIPT} *.sh ${STAGEDIR}${DATADIR})
@(cd ${STAGEDIR}${DATADIR} && ${CHMOD} 774 saves)
${LN} -sf ${DATADIR}/resources/icon.png \
${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
diff --git a/games/domination/files/domination-FlashGUI.in b/games/domination/files/domination-FlashGUI.in
index 64eb9927cc3d..a08e233b672f 100644
--- a/games/domination/files/domination-FlashGUI.in
+++ b/games/domination/files/domination-FlashGUI.in
@@ -5,5 +5,5 @@
export JAVA_VERSION="%%JAVA_VERSION%%"
-cd "%%DATADIR%%" && exec "%%LOCALBASE%%/bin/java" -Djava.ext.dirs="%%DATADIR%%" \
--Djava.ext.dirs="%%DATADIR%%" -cp Domination.jar net.yura.domination.ui.flashgui.MainMenu "${@}"
+cd "%%DATADIR%%" && exec "%%LOCALBASE%%/bin/java" \
+-cp Domination.jar net.yura.domination.ui.flashgui.MainMenu "${@}"
diff --git a/games/domination/files/domination-Increment1GUI.in b/games/domination/files/domination-Increment1GUI.in
index 294015e474e3..ecdb1a119abc 100644
--- a/games/domination/files/domination-Increment1GUI.in
+++ b/games/domination/files/domination-Increment1GUI.in
@@ -5,5 +5,5 @@
export JAVA_VERSION="%%JAVA_VERSION%%"
-cd "%%DATADIR%%" && exec "%%LOCALBASE%%/bin/java" -Djava.ext.dirs="%%DATADIR%%" \
--Djava.ext.dirs="%%DATADIR%%" -cp Domination.jar net.yura.domination.ui.increment1gui.Increment1Frame "${@}"
+cd "%%DATADIR%%" && exec "%%LOCALBASE%%/bin/java" \
+-cp Domination.jar net.yura.domination.ui.increment1gui.Increment1Frame "${@}"
diff --git a/games/domination/files/domination-SimpleGUI.in b/games/domination/files/domination-SimpleGUI.in
index f8649dcf9487..94da64833d50 100644
--- a/games/domination/files/domination-SimpleGUI.in
+++ b/games/domination/files/domination-SimpleGUI.in
@@ -5,5 +5,5 @@
export JAVA_VERSION="%%JAVA_VERSION%%"
-cd "%%DATADIR%%" && exec "%%LOCALBASE%%/bin/java" -Djava.ext.dirs="%%DATADIR%%" \
--Djava.ext.dirs="%%DATADIR%%" -cp Domination.jar net.yura.domination.ui.simplegui.RiskGUI "${@}"
+cd "%%DATADIR%%" && exec "%%LOCALBASE%%/bin/java" \
+-cp Domination.jar net.yura.domination.ui.simplegui.RiskGUI "${@}"
diff --git a/games/domination/files/domination-SwingGUI.in b/games/domination/files/domination-SwingGUI.in
index 8193af1752d6..93893d3ae09d 100644
--- a/games/domination/files/domination-SwingGUI.in
+++ b/games/domination/files/domination-SwingGUI.in
@@ -5,5 +5,5 @@
export JAVA_VERSION="%%JAVA_VERSION%%"
-cd "%%DATADIR%%" && exec "%%LOCALBASE%%/bin/java" -Djava.ext.dirs="%%DATADIR%%" \
--Djava.ext.dirs="%%DATADIR%%" -cp Domination.jar net.yura.domination.ui.swinggui.SwingGUIFrame "${@}"
+cd "%%DATADIR%%" && exec "%%LOCALBASE%%/bin/java" \
+-cp Domination.jar net.yura.domination.ui.swinggui.SwingGUIFrame "${@}"
diff --git a/games/domination/files/pkg-deinstall.in b/games/domination/files/pkg-deinstall.in
new file mode 100644
index 000000000000..4b297e3acd1f
--- /dev/null
+++ b/games/domination/files/pkg-deinstall.in
@@ -0,0 +1,18 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+if [ "$2" = "POST-DEINSTALL" ]; then
+ echo ""
+ echo ""
+ echo "==============================================================================="
+ echo ""
+ echo "After deinstallation, some files may stay in %%DATADIR%%,"
+ echo "you can delete them with"
+ echo ""
+ echo " /bin/rm -fr %%DATADIR%%"
+ echo ""
+ echo "==============================================================================="
+ echo ""
+fi
diff --git a/games/domination/pkg-descr b/games/domination/pkg-descr
index 30adc60cd71f..b6207d4edcc8 100644
--- a/games/domination/pkg-descr
+++ b/games/domination/pkg-descr
@@ -7,4 +7,4 @@ Written in java it includes a map editor, a simple map format, multiplayer
network play, single player, hotseat, 5 user interfaces and many more features,
it works in all OSs that run java.
-WWW: http://yura.net/projects/domination/
+WWW: http://domination.sourceforge.net/
diff --git a/games/domination/pkg-plist b/games/domination/pkg-plist
index 1fc0219725b0..c4d4f9823cc4 100644
--- a/games/domination/pkg-plist
+++ b/games/domination/pkg-plist
@@ -3,18 +3,13 @@ bin/domination-Increment1GUI
bin/domination-SimpleGUI
bin/domination-SwingGUI
%%DATADIR%%/ChangeLog.txt
-%%DATADIR%%/CommandLine.cmd
%%DATADIR%%/CommandLine.sh
%%DATADIR%%/Domination.jar
-%%DATADIR%%/FlashGUI.cmd
%%DATADIR%%/FlashGUI.htm
%%DATADIR%%/FlashGUI.sh
-%%DATADIR%%/Increment1GUI.cmd
%%DATADIR%%/Increment1GUI.sh
%%DATADIR%%/ReadMe.txt
-%%DATADIR%%/SimpleGUI.cmd
%%DATADIR%%/SimpleGUI.sh
-%%DATADIR%%/SwingGUI.cmd
%%DATADIR%%/SwingGUI.htm
%%DATADIR%%/SwingGUI.sh
%%DATADIR%%/commands.txt
@@ -497,14 +492,13 @@ bin/domination-SwingGUI
%%DATADIR%%/maps/zertina_pic.jpg
%%DATADIR%%/resources/icon.ico
%%DATADIR%%/resources/icon.png
-%%DATADIR%%/run.cmd
%%DATADIR%%/run.sh
%%DATADIR%%/todo.txt
share/pixmaps/domination.png
-@dirrm %%DATADIR%%/saves
+@dirrmtry %%DATADIR%%/saves
@dirrm %%DATADIR%%/resources
@dirrm %%DATADIR%%/maps/preview
@dirrm %%DATADIR%%/maps
@dirrm %%DATADIR%%/lib
@dirrm %%DATADIR%%/help
-@dirrm %%DATADIR%%
+@dirrmtry %%DATADIR%%