aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-03-13 21:44:26 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-03-13 21:44:26 +0000
commit0bc15d4a549b66c0887b81de10c36d0762c2e660 (patch)
tree025be2b66d2a2e5968ac3cf3d8d2c8e1a220b8cf /games
parentc6868aff9dd3f280f6cd043d8fbf0e00b9327be4 (diff)
downloadports-0bc15d4a549b66c0887b81de10c36d0762c2e660.tar.gz
ports-0bc15d4a549b66c0887b81de10c36d0762c2e660.zip
games/eboard: Update to 1.1.3
Notes
Notes: svn path=/head/; revision=568287
Diffstat (limited to 'games')
-rw-r--r--games/eboard/Makefile21
-rw-r--r--games/eboard/distinfo7
-rw-r--r--games/eboard/files/patch-configure56
-rw-r--r--games/eboard/files/patch-libpng1516
-rw-r--r--games/eboard/files/patch-main.cc11
-rw-r--r--games/eboard/files/patch-ntext.cc24
-rw-r--r--games/eboard/pkg-plist2
7 files changed, 27 insertions, 110 deletions
diff --git a/games/eboard/Makefile b/games/eboard/Makefile
index ea5055f6886a..aa29c6226197 100644
--- a/games/eboard/Makefile
+++ b/games/eboard/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= eboard
-PORTVERSION= 1.1.1
-PORTREVISION= 7
+PORTVERSION= 1.1.3
+DISTVERSIONPREFIX= v
CATEGORIES= games
-MASTER_SITES= SF \
- SF/${PORTNAME}/eboard-extras/pack%201%20patchlevel%202/:p1 \
+MASTER_SITES= SF/${PORTNAME}/eboard-extras/pack%201%20patchlevel%202/:p1 \
SF/${PORTNAME}/eboard-extras/pack%202/:p2
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
eboard-extras-1pl2.tar.gz:p1 \
@@ -16,15 +15,21 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK+ chess board interface (mainly for FICS and chessd)
-LIB_DEPENDS= libpng.so:graphics/png
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libpng.so:graphics/png
EXTRAS= 1pl2 2
USES= compiler:c++11-lang gnome perl5 pkgconfig shebangfix tar:bzip2
HAS_CONFIGURE= yes
USE_PERL5= build
-USE_GNOME= gtk20
+USE_GNOME= cairo gdkpixbuf2 gtk20
+USE_GSTREAMER1= yes
SHEBANG_FILES= configure
+USE_GITHUB= yes
+GH_ACCOUNT= fbergo
+
CONFIGURE_ARGS= --prefix=${PREFIX} \
--extra-inc=${LOCALBASE}/include \
--extra-ld=${LOCALBASE}/lib
@@ -60,6 +65,9 @@ post-configure:
${WRKSRC}/config.h
.endif
+pre-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+
post-install:
@${LN} -sf ${LOCALBASE}/bin/timeseal \
${STAGEDIR}${DATADIR}/timeseal.FreeBSD
@@ -75,6 +83,5 @@ post-install:
@cd ${WRKDIR}/eboard-extras-${extra} && ${SETENV} EBOARDCONFIG=${STAGEDIR}${PREFIX}/bin/eboard-config ${CONFIGURE_CMD} --prefix=${PREFIX}
@cd ${WRKDIR}/eboard-extras-${extra} && ${SETENV} ${MAKE_ENV} ${MAKE} install DATADIR=${STAGEDIR}${DATADIR}
.endfor
- @${INSTALL_DATA} ${WRKSRC}/icon-eboard.xpm ${STAGEDIR}${PREFIX}/share/pixmaps/eboard.xpm
.include <bsd.port.mk>
diff --git a/games/eboard/distinfo b/games/eboard/distinfo
index 7c21f00ca560..1803a90a3dbe 100644
--- a/games/eboard/distinfo
+++ b/games/eboard/distinfo
@@ -1,6 +1,9 @@
-SHA256 (eboard-1.1.1.tar.bz2) = ad971086697c0d5a1c8a64401f6675339e832acb386dc96fa4e17da1832ca26e
-SIZE (eboard-1.1.1.tar.bz2) = 462386
+TIMESTAMP = 1615669009
+SHA256 (fbergo-eboard-v1.1.3_GH0.tar.bz2) = 2a1ba23a27c94ee4ec167bb31ab7dd6eedf148e139c9a96e8cb5ac36ec8423c1
+SIZE (fbergo-eboard-v1.1.3_GH0.tar.bz2) = 1578858
SHA256 (eboard-extras-1pl2.tar.gz) = 6849cc104e454167db8b8e9ae0573accade5c941a140b47e58b601164e99fcc3
SIZE (eboard-extras-1pl2.tar.gz) = 361237
SHA256 (eboard-extras-2.tar.gz) = 0b98bd4c90b2e275f8535186c3e7cbeeef9c9bb611a7febfcd866486a9f41a9c
SIZE (eboard-extras-2.tar.gz) = 598909
+SHA256 (fbergo-eboard-v1.1.3_GH0.tar.gz) = 2a1ba23a27c94ee4ec167bb31ab7dd6eedf148e139c9a96e8cb5ac36ec8423c1
+SIZE (fbergo-eboard-v1.1.3_GH0.tar.gz) = 1578858
diff --git a/games/eboard/files/patch-configure b/games/eboard/files/patch-configure
index aa5c56eff85d..82f935bd6683 100644
--- a/games/eboard/files/patch-configure
+++ b/games/eboard/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2020-01-02 23:06:25 UTC
-+++ configure
-@@ -104,7 +104,7 @@ sub run_cmd {
+--- configure.orig 2021-03-13 13:18:59.466284000 -0800
++++ configure 2021-03-13 13:18:59.474328000 -0800
+@@ -106,7 +106,7 @@
}
sub cplusplus_lang {
@@ -9,50 +9,8 @@
my $x;
my $program = <<EOF;
#include <list>
-@@ -142,41 +142,6 @@ EOF
- print TESTCC "$program";
- close TESTCC;
+@@ -357,7 +357,7 @@
-- $cxx = 'no';
-- for (@compilers) {
-- $x = $_;
-- print " trying $x ... ";
--
-- unlink('test.o','yytest');
-- log_file("test.cc");
--
-- if (run_cmd($x, '-c', 'test.cc', '-o', 'test.o') != 0) {
-- print "compilation FAILED\n";
-- next;
-- }
--
-- if (run_cmd($x, 'test.o', '-o', 'yytest') != 0) {
-- print "compilation ok, linking FAILED\n";
-- next;
-- }
--
-- $y = `./yytest`;
-- if ($y ne "1710\n") {
-- print "compilation ok, linking ok, output FAILED\n";
-- next;
-- }
--
-- $cxx = $x;
-- print "it works\n";
-- last;
-- }
-- unlink('test.o','yytest','test.cc');
--
-- if ($cxx eq 'no') {
-- print "FAIL\n";
-- return 0;
-- }
--
- return 1;
- }
-
-@@ -354,7 +319,7 @@ sub header_check {
-
log_file("test.cc");
- if (run_cmd($cxx,@cxxflags,"-c","test.cc","-o","xxtest.o") != 0) {
@@ -60,9 +18,9 @@
print ": no\n";
$y = header_def($x);
print CONFIGH "#undef $y\n";
-@@ -512,17 +477,9 @@ if (!header_check("stdio.h","stdlib.h","string.h","uni
+@@ -511,17 +511,9 @@
#optional headers
- header_check("strings.h","sys/soundcard.h","sys/audioio.h","linux/joystick.h");
+ header_check("strings.h");
-$t1=macro_check("netinet/in.h","IPPROTO_TCP","HAVE_IPPROTO_TCP_ON_IN_H");
-$t2=macro_check("netinet/in.h","TCP_NODELAY","HAVE_TCP_NODELAY_ON_IN_H");
@@ -79,7 +37,7 @@
cppdef("USE_SOCK_OPTS");
if ($t1!=0 && $t3!=0) {
cppundef("NEED_TCP_H");
-@@ -536,10 +493,10 @@ if ($t2 != 0) {
+@@ -535,10 +527,10 @@
print "netinet/tcp.h not required, SOL_TCP present.\n";
}
} else {
diff --git a/games/eboard/files/patch-libpng15 b/games/eboard/files/patch-libpng15
deleted file mode 100644
index 8ab283259f79..000000000000
--- a/games/eboard/files/patch-libpng15
+++ /dev/null
@@ -1,16 +0,0 @@
---- cimg.cc
-+++ cimg.cc
-@@ -94,11 +95,11 @@
- ct == PNG_COLOR_TYPE_GRAY_ALPHA)
- png_set_gray_to_rgb(pngp);
-
-- alloc(pngp->width,pngp->height);
-+ alloc(width,height);
- if (!ok) { fclose(f); return; }
- ok = 0;
-
-- for(i=0;i<pngp->height;i++) {
-+ for(i=0;i<height;i++) {
- png_read_row(pngp, (png_bytep) (&data[i*rowlen]), NULL);
- }
-
diff --git a/games/eboard/files/patch-main.cc b/games/eboard/files/patch-main.cc
deleted file mode 100644
index afe72228d1e9..000000000000
--- a/games/eboard/files/patch-main.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- main.cc.orig Mon Jan 22 18:57:40 2007
-+++ main.cc Tue Jan 30 21:07:51 2007
-@@ -139,7 +139,7 @@
- char devname[64];
-
- for(i=0;i<10;i++) {
-- snprintf(devname,64,"/dev/js%d",i);
-+ snprintf(devname,64,"/dev/input/js%d",i);
- fd = open(devname,O_RDONLY);
- if (fd >= 0) break;
- }
diff --git a/games/eboard/files/patch-ntext.cc b/games/eboard/files/patch-ntext.cc
deleted file mode 100644
index b87bfa523882..000000000000
--- a/games/eboard/files/patch-ntext.cc
+++ /dev/null
@@ -1,24 +0,0 @@
---- ntext.cc.orig 2008-02-22 15:51:22 UTC
-+++ ntext.cc
-@@ -237,7 +237,7 @@ void NText::setBG(int c) {
- void NText::append(const char *text, int len, int color) {
- int i;
- NLine *nl;
-- char *p;
-+ const char *p;
-
- if (len < 0) {
- discardExcess();
-@@ -246,10 +246,8 @@ void NText::append(const char *text, int
-
- p = strchr(text, '\n');
- if (p!=NULL) {
-- *p = 0;
-- i = strlen(text);
-- nl = new NLine(text, color);
-- *p = '\n';
-+ i = p - text;
-+ nl = new NLine(text, color, i);
- lines.push_back(nl);
- formatLine(lines.size()-1);
- append(&p[1], len-(i+1), color);
diff --git a/games/eboard/pkg-plist b/games/eboard/pkg-plist
index e47135f447c0..6db8501d357a 100644
--- a/games/eboard/pkg-plist
+++ b/games/eboard/pkg-plist
@@ -70,6 +70,7 @@ man/man6/eboard.6.gz
%%DATADIR%%/eboard.hu.dict
%%DATADIR%%/eboard.pl.dict
%%DATADIR%%/eboard.pt_BR.dict
+%%DATADIR%%/eboard.zh_CN.dict
%%DATADIR%%/eboard_themes.conf
%%DATADIR%%/extras1.prevconf
%%DATADIR%%/extras2.prevconf
@@ -78,4 +79,3 @@ man/man6/eboard.6.gz
%%DATADIR%%/themeconf.extras1
%%DATADIR%%/themeconf.extras2
%%DATADIR%%/timeseal.FreeBSD
-share/pixmaps/eboard.xpm