aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-01-15 14:22:14 +0000
committerSteve Wills <swills@FreeBSD.org>2019-01-15 14:22:14 +0000
commit0dfe7839551c2a338175e9cf89b3b45febb7befc (patch)
treef178547ca609118afaf1a95fb3c52c67dbed9410 /games
parent8c510bc309cc965b9c894dc94e8f6cbaf49eab48 (diff)
games/chocolate-doom: update to 3.0.0
While here: * add rc script for server [1] * add pkg-message on music configuration [2] PR: 225453 Submitted by: jakub_lach@mailplus.pl (maintainer) Submitted by: Shirkdog <mshirk@daemon-security.com> (update and [1]) Submitted by: Patrick McMunn <doctorwhoguy@gmail.com> [2]
Notes
Notes: svn path=/head/; revision=490375
Diffstat (limited to 'games')
-rw-r--r--games/chocolate-doom/Makefile7
-rw-r--r--games/chocolate-doom/distinfo6
-rw-r--r--games/chocolate-doom/files/chocolate-server.in22
-rw-r--r--games/chocolate-doom/files/patch-src_d__iwad.c10
-rw-r--r--games/chocolate-doom/pkg-message44
5 files changed, 73 insertions, 16 deletions
diff --git a/games/chocolate-doom/Makefile b/games/chocolate-doom/Makefile
index aa73e2cf9500..076a1e5a5ede 100644
--- a/games/chocolate-doom/Makefile
+++ b/games/chocolate-doom/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= chocolate-doom
-PORTVERSION= 2.3.0
+PORTVERSION= 3.0.0
CATEGORIES= games
MASTER_SITES= http://www.chocolate-doom.org/downloads/${PORTVERSION}/
@@ -12,8 +12,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png
-USES= gmake python:build
-USE_SDL= mixer net sdl
+USES= gmake python:build pkgconfig
+USE_SDL= mixer2 net2 sdl2
GNU_CONFIGURE= yes
BINARY_ALIAS= python=${PYTHON_CMD}
@@ -21,6 +21,7 @@ PORTDOCS= CMDLINE.doom ChangeLog INSTALL.doom NEWS.md NOT-BUGS.md PHILOSOPHY.md
README.md README.Music.md
OPTIONS_DEFINE= DOCS
+USE_RC_SUBR= chocolate-server
.include "${.CURDIR}/../doom-data/Makefile.include"
diff --git a/games/chocolate-doom/distinfo b/games/chocolate-doom/distinfo
index b82923a4a890..1cb2a8e7e9fa 100644
--- a/games/chocolate-doom/distinfo
+++ b/games/chocolate-doom/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1483106037
-SHA256 (chocolate-doom-2.3.0.tar.gz) = 3e6d1a82ac5c8b025a9695ce1e47d0dc6ed142ebb1129b1e4a70e2740f79150c
-SIZE (chocolate-doom-2.3.0.tar.gz) = 2190744
+TIMESTAMP = 1514687305
+SHA256 (chocolate-doom-3.0.0.tar.gz) = 73aea623930c7d18a7a778eea391e1ddfbe90ad1ac40a91b380afca4b0e1dab8
+SIZE (chocolate-doom-3.0.0.tar.gz) = 2495591
diff --git a/games/chocolate-doom/files/chocolate-server.in b/games/chocolate-doom/files/chocolate-server.in
new file mode 100644
index 000000000000..b73c42c7c117
--- /dev/null
+++ b/games/chocolate-doom/files/chocolate-server.in
@@ -0,0 +1,22 @@
+#!/bin/sh
+#
+# PROVIDE: chocolate_server
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+
+. /etc/rc.subr
+
+name="chocolate_server"
+rcvar=`set_rcvar`
+
+load_rc_config $name
+
+: ${chocolate_server_enable:="NO"}
+: ${chocolate_server_commandline:=""}
+
+pidfile="/var/run/${name}.pid"
+command="/usr/sbin/daemon"
+procname="%%PREFIX%%/bin/chocolate-server"
+command_args="-f -p ${pidfile} -u nobody %%PREFIX%%/bin/chocolate-server $chocolate_server_commandline"
+
+run_rc_command "$1"
diff --git a/games/chocolate-doom/files/patch-src_d__iwad.c b/games/chocolate-doom/files/patch-src_d__iwad.c
index 7c1a9a0a1e1f..905684bd272b 100644
--- a/games/chocolate-doom/files/patch-src_d__iwad.c
+++ b/games/chocolate-doom/files/patch-src_d__iwad.c
@@ -1,11 +1,11 @@
---- src/d_iwad.c.orig 2015-09-26 11:05:54 UTC
-+++ src/d_iwad.c
-@@ -632,7 +632,7 @@ static void AddXdgDirs(void)
+--- src/d_iwad.c.orig 2017-12-30 16:20:28.000000000 -0500
++++ src/d_iwad.c 2018-01-25 09:43:00.567417000 -0500
+@@ -658,7 +658,7 @@
// The "standard" location for IWADs on Unix that is supported by most
// source ports is /usr/share/games/doom - we support this through the
// XDG_DATA_DIRS mechanism, through which it can be overridden.
- AddIWADPath(env, "/games/doom");
+ AddIWADPath(env, "/doom");
- }
- //
+ // The convention set by RBDOOM-3-BFG is to install Doom 3: BFG
+ // Edition into this directory, under which includes the Doom
diff --git a/games/chocolate-doom/pkg-message b/games/chocolate-doom/pkg-message
index 04637f1a12b9..2956bc7cc74d 100644
--- a/games/chocolate-doom/pkg-message
+++ b/games/chocolate-doom/pkg-message
@@ -1,10 +1,44 @@
******************************************************
-To switch on OPL (Adlib/SB) or GUS emulation you need
-to run chocolate-doom-setup, default Native MIDI is
-very similar to Roland SC-55.
+The default location for a configuration files and
+saves is no longer ~/.chocolate-doom, current one is
+~/.local/share/chocolate-doom/.
-GUS emulation needs setting "gus_patch_path" in *.cfg
-to GUS patch set (dgguspat.zip).
+You can recreate the sound of the historical vanilla
+game according to your own experience.
+
+The default is an emulation of OPL2 Chip (Adlib/
+Soundblaster) for MIDI music output. OPL3 is also
+available.
+
+If you prefer Gravis Ultrasound, ensure that
+audio/guspat is installed, run chocolate-doom-setup,
+select "Configure Sound", choose "GUS (emulated)",
+and enter the path:
+
+/usr/local/share/guspat/inst/GUS
+
+into the "Path to patch files:" field.
+
+If you wish to enable native MIDI, ensure that a
+suitable set of patches is installed such as
+audio/eawpats, audio/eawplus, audio/freepats, or
+audio/guspat, enter chocolate-doom-setup, select
+"Configure Sound", choose "Native MIDI", and enter
+the path to the Timidity configuration file.
+
+Examples:
+
+/usr/local/share/timidity/timidity.cfg-eawpats
+
+/usr/local/share/timidity/timidity.cfg-eawplus
+
+/usr/local/share/freepats/freepats.cfg
+
+/usr/local/share/timidity/timidity.cfg-guspat
+
+If you choose either Gravis Ultrasound emulation or
+native MIDI and provide no path, there will be no
+music.
******************************************************