aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-04-08 12:14:19 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-04-08 12:14:19 +0000
commit237e2d982dae4aafb0d37d84b9b8848a2928f11e (patch)
tree8f5ddb254fb39956a85cd4945308e5b86bc2ba6d /games
parent232b8620cafffb8960a3b810704a7eff6f89628b (diff)
downloadports-237e2d982dae4aafb0d37d84b9b8848a2928f11e.tar.gz
ports-237e2d982dae4aafb0d37d84b9b8848a2928f11e.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/openttd/Makefile47
-rw-r--r--games/openttd/distinfo6
-rw-r--r--games/openttd/pkg-plist13
3 files changed, 45 insertions, 21 deletions
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index e25a1df88091..e9b6669aafcc 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -2,16 +2,9 @@
# $FreeBSD$
PORTNAME= openttd
-DISTVERSION= 1.8.0
-PORTREVISION= 6
+DISTVERSION= 1.9.0
CATEGORIES= games
-MASTER_SITES= http://ca.binaries.openttd.org/binaries/releases/${DISTVERSION}/ \
- http://cz.binaries.openttd.org/binaries/releases/${DISTVERSION}/ \
- http://de.binaries.openttd.org/binaries/releases/${DISTVERSION}/ \
- http://fr.binaries.openttd.org/binaries/releases/${DISTVERSION}/ \
- http://ftp.snt.utwente.nl/pub/games/openttd/binaries/releases/${DISTVERSION}/ \
- http://uk.binaries.openttd.org/binaries/releases/${DISTVERSION}/ \
- http://us.binaries.openttd.org/binaries/releases/${DISTVERSION}/
+MASTER_SITES= https://proxy.binaries.openttd.org/openttd-releases/${DISTVERSION}/
DISTNAME= ${PORTNAME}-${DISTVERSION}-source
MAINTAINER= danfe@FreeBSD.org
@@ -25,7 +18,8 @@ LIB_DEPENDS= libpng.so:graphics/png \
USES= cpe gmake pkgconfig tar:xz
HAS_CONFIGURE= yes
CONFIGURE_ENV= STRIP="${STRIP_CMD} ${STRIP}"
-CONFIGURE_ARGS= --prefix-dir="${PREFIX}" --data-dir="${DATADIR_REL}"
+CONFIGURE_ARGS= --prefix-dir="${PREFIX}" --data-dir="${DATADIR_REL}" \
+ --without-libtimidity
MAKE_ARGS= VERBOSE=1
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
@@ -33,11 +27,12 @@ CXXFLAGS= # Set to empty as OpenTTD treats it as an addition to CFLAGS
SUB_FILES= pkg-message
-PORTDOCS= HOWTO_compile_lang_files.txt admin_network.txt \
- elrail.svg elrail_tile.png elrail_track.png landscape.html \
- landscape_externals.html landscape_grid.html multiplayer.txt \
- obg_format.txt obm_format.txt obs_format.txt \
- ottd-colourtext-palette.png tileh.png
+PORTDOCS= HOWTO_compile_lang_files.txt README.md admin_network.txt \
+ changelog.txt elrail.svg elrail_tile.png elrail_track.png \
+ known-bugs.txt landscape.html landscape_externals.html \
+ landscape_grid.html multiplayer.txt obg_format.txt \
+ obm_format.txt obs_format.txt ottd-colourtext-palette.png \
+ tileh.png
DESKTOP_ENTRIES="OpenTTD" "${COMMENT}" "${PORTNAME}" "${PORTNAME}" \
"Game;Simulation;StrategyGame;" false
@@ -52,13 +47,19 @@ CONFIGURE_ARGS+= --with-midi="${WITH_MIDI_PLAYER}"
CONFIGURE_ARGS+= --with-midi-arg="${WITH_MIDI_PLAYER_ARGS}"
.endif
+.if defined(WITH_FLUIDSYNTH)
+LIB_DEPENDS+= libfluidsynth.so:audio/fluidsynth
+.else
+CONFIGURE_ARGS+= --without-fluidsynth
+.endif
+
.if defined(WITH_DEDICATED_SERVER_ONLY)
CONFIGURE_ARGS+= --enable-dedicated
# Aid it to find lzo2 headers; client build gets it via sdl-config
CFLAGS+= -I${LOCALBASE}/include
USE_RC_SUBR= ${PORTNAME}
.else
-USES+= compiler:c++11-lib
+USES+= compiler:c++11-lib sdl
USE_CXXSTD= gnu++11
CXXFLAGS+= -DU_USING_ICU_NAMESPACE=1
LIB_DEPENDS+= libfreetype.so:print/freetype2 \
@@ -89,6 +90,9 @@ pre-everything::
.if !defined(WITH_MIDI_PLAYER_ARGS)
@${ECHO_MSG} "Define WITH_MIDI_PLAYER_ARGS=arguments for external MIDI player"
.endif
+.if !defined(WITH_FLUIDSYNTH)
+ @${ECHO_MSG} "Define WITH_FLUIDSYNTH to enable new Fluidsynth music driver"
+.endif
.if !defined(WITH_DEDICATED_SERVER_ONLY)
@${ECHO_MSG} "Define WITH_DEDICATED_SERVER_ONLY to build CLI-based dedicated server"
.endif
@@ -99,15 +103,22 @@ pre-everything::
@${ECHO_MSG} "Define WITH_SAVE_PASSWORDS to save passwords between server restarts"
.endif
+post-extract:
+ @${MV} ${WRKSRC}/README.md ${WRKSRC}/changelog.txt \
+ ${WRKSRC}/known-bugs.txt ${WRKSRC}/docs
+
post-patch:
@${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},' ${WRKSRC}/config.lib
+ @${REINPLACE_CMD} -e 's,OSX,${OPSYS:tu},' ${WRKSRC}/Makefile.grf.in
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${DATADIR}/ai ${STAGEDIR}${DATADIR}/baseset \
- ${STAGEDIR}${DATADIR}/lang ${STAGEDIR}${DATADIR}/scripts
+ ${STAGEDIR}${DATADIR}/game ${STAGEDIR}${DATADIR}/lang \
+ ${STAGEDIR}${DATADIR}/scripts
${INSTALL_DATA} ${WRKSRC}/bin/ai/*.nut ${STAGEDIR}${DATADIR}/ai
${INSTALL_DATA} ${WRKSRC}/bin/baseset/* ${STAGEDIR}${DATADIR}/baseset
+ ${INSTALL_DATA} ${WRKSRC}/bin/game/* ${STAGEDIR}${DATADIR}/game
${INSTALL_DATA} ${WRKSRC}/bin/lang/* ${STAGEDIR}${DATADIR}/lang
${INSTALL_DATA} ${WRKSRC}/bin/scripts/* ${STAGEDIR}${DATADIR}/scripts
${INSTALL_MAN} ${WRKSRC}/docs/${PORTNAME}.6 \
@@ -121,6 +132,8 @@ do-install:
${STAGEDIR}${PREFIX}/share/icons/hicolor/${n}x${n}/apps/openttd.png
. endfor
.endif
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/docs/,} ${STAGEDIR}${DOCSDIR}
diff --git a/games/openttd/distinfo b/games/openttd/distinfo
index 167022e095cf..78c30cf2cbe9 100644
--- a/games/openttd/distinfo
+++ b/games/openttd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1522588020
-SHA256 (openttd-1.8.0-source.tar.xz) = c2d32d9d736d27202a020027a3729ae763f5432ae6f424891e57a4095eeb087f
-SIZE (openttd-1.8.0-source.tar.xz) = 6521016
+TIMESTAMP = 1554141178
+SHA256 (openttd-1.9.0-source.tar.xz) = 45fded554d973328496f6e01b0769d7b8b64048a8fe2cf252242194c08ea7419
+SIZE (openttd-1.9.0-source.tar.xz) = 6575956
diff --git a/games/openttd/pkg-plist b/games/openttd/pkg-plist
index c69b79989710..a0a3b738c8eb 100644
--- a/games/openttd/pkg-plist
+++ b/games/openttd/pkg-plist
@@ -1,6 +1,5 @@
bin/openttd
man/man6/openttd.6.gz
-share/pixmaps/openttd.32.xpm
%%DATADIR%%/ai/compat_0.7.nut
%%DATADIR%%/ai/compat_1.0.nut
%%DATADIR%%/ai/compat_1.1.nut
@@ -11,17 +10,28 @@ share/pixmaps/openttd.32.xpm
%%DATADIR%%/ai/compat_1.6.nut
%%DATADIR%%/ai/compat_1.7.nut
%%DATADIR%%/ai/compat_1.8.nut
+%%DATADIR%%/ai/compat_1.9.nut
%%DATADIR%%/baseset/no_music.obm
%%DATADIR%%/baseset/no_sound.obs
%%DATADIR%%/baseset/openttd.grf
%%DATADIR%%/baseset/opntitle.dat
%%DATADIR%%/baseset/orig_dos.obg
+%%DATADIR%%/baseset/orig_dos.obm
%%DATADIR%%/baseset/orig_dos.obs
%%DATADIR%%/baseset/orig_dos_de.obg
%%DATADIR%%/baseset/orig_extra.grf
+%%DATADIR%%/baseset/orig_tto.obm
%%DATADIR%%/baseset/orig_win.obg
%%DATADIR%%/baseset/orig_win.obm
%%DATADIR%%/baseset/orig_win.obs
+%%DATADIR%%/game/compat_1.2.nut
+%%DATADIR%%/game/compat_1.3.nut
+%%DATADIR%%/game/compat_1.4.nut
+%%DATADIR%%/game/compat_1.5.nut
+%%DATADIR%%/game/compat_1.6.nut
+%%DATADIR%%/game/compat_1.7.nut
+%%DATADIR%%/game/compat_1.8.nut
+%%DATADIR%%/game/compat_1.9.nut
%%DATADIR%%/lang/afrikaans.lng
%%DATADIR%%/lang/arabic_egypt.lng
%%DATADIR%%/lang/basque.lng
@@ -93,3 +103,4 @@ share/icons/hicolor/48x48/apps/openttd.png
share/icons/hicolor/64x64/apps/openttd.png
share/icons/hicolor/128x128/apps/openttd.png
share/icons/hicolor/256x256/apps/openttd.png
+share/pixmaps/openttd.32.xpm