aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-07-26 06:50:02 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-07-26 06:50:02 +0000
commit2ca9bcd573e3cae9538e22df3992d987726c537a (patch)
tree923a4049fb358f3ceb7efda825bf46fb16fa04f8 /games
parentba6aae7a1df5d4d75065a127e776a7bd4b129252 (diff)
downloadports-2ca9bcd573e3cae9538e22df3992d987726c537a.tar.gz
ports-2ca9bcd573e3cae9538e22df3992d987726c537a.zip
Diffstat (limited to 'games')
-rw-r--r--games/quake2-rogue/Makefile5
-rw-r--r--games/quake2-rogue/files/Makefile6
2 files changed, 4 insertions, 7 deletions
diff --git a/games/quake2-rogue/Makefile b/games/quake2-rogue/Makefile
index 30cdca4d6d5a..03c16f218937 100644
--- a/games/quake2-rogue/Makefile
+++ b/games/quake2-rogue/Makefile
@@ -10,6 +10,7 @@ MAINTAINER= danfe@FreeBSD.org
COMMENT= Quake II: Ground Zero (Rogue) official mission pack
WWW= http://www.idsoftware.com/games/quake/quake2-grndzero/
+MAKEFILE= ${FILESDIR}/Makefile
NO_WRKSUBDIR= yes
SUB_FILES= pkg-message
@@ -20,11 +21,9 @@ do-extract:
@cd ${WRKSRC} && uncompress -c ${DISTDIR}/${DISTFILES} | \
${TAIL} +454 | ${SH}
-post-extract:
- @${CP} ${FILESDIR}/${MAKEFILE} ${WRKSRC}
-
post-patch:
@${REINPLACE_CMD} -e '/#include <nan\.h>/d' ${WRKSRC}/g_local.h
+ @${REINPLACE_CMD} -e '/extern SP_monster_makron/d' ${WRKSRC}/m_boss31.c
@${REINPLACE_CMD} -e 's/__linux__/__unix__/' ${WRKSRC}/q_shared.[ch]
do-install:
diff --git a/games/quake2-rogue/files/Makefile b/games/quake2-rogue/files/Makefile
index a56946b74afe..bfc8d9385be2 100644
--- a/games/quake2-rogue/files/Makefile
+++ b/games/quake2-rogue/files/Makefile
@@ -64,9 +64,7 @@ SRCS= dm_ball.c \
p_weapon.c \
q_shared.c
-CFLAGS+= -Dstricmp=strcasecmp -ffast-math -funroll-loops \
- -fomit-frame-pointer -fexpensive-optimizations
-
-LDFLAGS+= -L/lib -L/usr/lib -lm
+CFLAGS+= -Dstricmp=strcasecmp -ffast-math \
+ -Wno-incompatible-function-pointer-types
.include <bsd.lib.mk>