aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-18 11:47:28 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-18 11:47:28 +0000
commit2e0b612dd8c4778bb079cba2f25b95125c63ffb5 (patch)
tree5914a2d1eeed738ecc3d5c28008b3db72fa3ff58 /games
parent028629e4f3459ae4eb19ec90f0923534574b417b (diff)
downloadports-2e0b612dd8c4778bb079cba2f25b95125c63ffb5.tar.gz
ports-2e0b612dd8c4778bb079cba2f25b95125c63ffb5.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/bsp/Makefile25
-rw-r--r--games/bsp/distinfo1
-rw-r--r--games/bsp/pkg-comment1
-rw-r--r--games/bsp/pkg-descr17
-rw-r--r--games/bsp/pkg-plist3
6 files changed, 48 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 7c26511e4da5..6a1310e9fcf9 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -39,6 +39,7 @@
SUBDIR += bomberinstinct
SUBDIR += bombermaze
SUBDIR += bs
+ SUBDIR += bsp
SUBDIR += bugsx
SUBDIR += burgerspace
SUBDIR += bzflag
diff --git a/games/bsp/Makefile b/games/bsp/Makefile
new file mode 100644
index 000000000000..56abb86e50f4
--- /dev/null
+++ b/games/bsp/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: bsp
+# Date created: 22 April 2002
+# Whom: Christian Brueffer <chris@unixpages.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bsp
+PORTVERSION= 5.1
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= doombsp
+
+MAINTAINER= chris@unixpages.org
+
+GNU_CONFIGURE= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bsp ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/bsp/distinfo b/games/bsp/distinfo
new file mode 100644
index 000000000000..d29cb2f03558
--- /dev/null
+++ b/games/bsp/distinfo
@@ -0,0 +1 @@
+MD5 (bsp-5.1.tar.gz) = a8d7cf42baf7ecb291869899e2aefae8
diff --git a/games/bsp/pkg-comment b/games/bsp/pkg-comment
new file mode 100644
index 000000000000..576ef827f741
--- /dev/null
+++ b/games/bsp/pkg-comment
@@ -0,0 +1 @@
+Node builder for Doom
diff --git a/games/bsp/pkg-descr b/games/bsp/pkg-descr
new file mode 100644
index 000000000000..971fa3a7e7c6
--- /dev/null
+++ b/games/bsp/pkg-descr
@@ -0,0 +1,17 @@
+BSP is one of the best node builders for Doom.
+
+What are Nodes?
+
+Doom uses a rendering algorithm based on a binary space partition,
+otherwise known as a BSP tree. This is stored in a data lump called
+NODES in the WAD file. So tools to build the BSP tree are known as
+node builders.
+
+Before you can play a level that you have created, you must use a node
+builder to create the data that Doom will use to render the level. BSP
+is one of several node builders that can do this.
+
+WWW: http://doombsp.sourceforge.net/
+
+- Christian Brueffer
+chris@unixpages.org
diff --git a/games/bsp/pkg-plist b/games/bsp/pkg-plist
new file mode 100644
index 000000000000..ef955435f9ab
--- /dev/null
+++ b/games/bsp/pkg-plist
@@ -0,0 +1,3 @@
+bin/bsp
+%%PORTDOCS%%share/doc/bsp/README
+%%PORTDOCS%%@dirrm share/doc/bsp