aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-06-29 12:52:49 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-06-29 12:52:49 +0000
commit2e69f4d0fd0fbad269e552bc60a60ee434fd4c90 (patch)
treed2f9acfa0dcdd2f7b69c944484087547de4efe3f /games
parent3371a26c23a921743ee32476dc7f83afd8b7fd74 (diff)
downloadports-2e69f4d0fd0fbad269e552bc60a60ee434fd4c90.tar.gz
ports-2e69f4d0fd0fbad269e552bc60a60ee434fd4c90.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/kiki/Makefile5
-rw-r--r--games/kiki/files/extra-patch-ino6411
2 files changed, 15 insertions, 1 deletions
diff --git a/games/kiki/Makefile b/games/kiki/Makefile
index f23bf47c6dc1..0d8e7a7bfa29 100644
--- a/games/kiki/Makefile
+++ b/games/kiki/Makefile
@@ -39,6 +39,10 @@ DESKTOP_ENTRIES="kiki the nanobot" \
CXXFLAGS+= -Werror=tautological-constant-out-of-range-compare
.endif
+.if ${OSVERSION} > 1200031
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-ino64
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/^CXXFLAGS/ s|.*|CXXFLAGS+=$$(KODI_INCLUDES) -I${LOCALBASE}/include `${SDL_CONFIG} --cflags`|' ${WRKSRC}/kodilib/linux/Makefile
@${REINPLACE_CMD} -e 's|getenv("KIKI_HOME")|"${DATADIR}"|' ${WRKSRC}/src/main/KikiController.cpp
@@ -50,7 +54,6 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/linux/kiki ${STAGEDIR}${PREFIX}/bin/
- ${MKDIR} ${STAGEDIR}${DATADIR}
cd ${WRKSRC} && ${COPYTREE_SHARE} "py sound" ${STAGEDIR}${DATADIR}/
.include <bsd.port.post.mk>
diff --git a/games/kiki/files/extra-patch-ino64 b/games/kiki/files/extra-patch-ino64
new file mode 100644
index 000000000000..b9de2d0b1e0c
--- /dev/null
+++ b/games/kiki/files/extra-patch-ino64
@@ -0,0 +1,11 @@
+--- kodilib/src/tools/KFileTools.cpp.orig 2004-06-30 20:03:38.000000000 +0400
++++ kodilib/src/tools/KFileTools.cpp 2013-12-24 05:02:16.028538916 +0400
+@@ -299,7 +299,7 @@ bool kFileGetDirEntries ( const string &
+ int fd = open (dirPath.c_str(), O_RDONLY | O_NONBLOCK);
+
+ struct stat sb;
+- long basep;
++ off_t basep;
+ char * entry;
+
+ if (fstat(fd, &sb) == -1)