aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 19:00:36 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 20:02:29 +0000
commit344e7cf1377bb8ab2b35e3aa714ab1eef794c475 (patch)
treeeb74ab61d63f8c6714335361c558edd50584d384 /games
parentb5a9d60472b920b5a533cdab117570b584e106f7 (diff)
downloadports-344e7cf1377bb8ab2b35e3aa714ab1eef794c475.tar.gz
ports-344e7cf1377bb8ab2b35e3aa714ab1eef794c475.zip
Diffstat (limited to 'games')
-rw-r--r--games/vavoom/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/games/vavoom/Makefile b/games/vavoom/Makefile
index c08c206b8e6c..b544ca5521e3 100644
--- a/games/vavoom/Makefile
+++ b/games/vavoom/Makefile
@@ -14,6 +14,7 @@ LIB_DEPENDS= libpng.so:graphics/png
USES= cmake:noninja cpe dos2unix jpeg tar:bzip2
DOS2UNIX_REGEX= ((.*\.(c|cpp|h|s|asm|inc|vc|ls|acs|cfg|txt|vs|mak|mgw"))$$|\/(makefile\..*|makefile|Makefile)$$)
+USE_CXXSTD= c++14
# The `-fno-strict-aliasing' flag (default on FreeBSD 6.0+) produces
# non-working code for `vcc', so we remove it here if present.
@@ -51,8 +52,10 @@ OPENAL_USES= openal:al
OPENAL_CMAKE_ON= -DWITH_OPENAL:BOOL=ON
OPENAL_CMAKE_OFF= -DWITH_OPENAL:BOOL=OFF
+OPTIMIZED_CFLAGS_CFLAGS= -O3 -ffast-math -fomit-frame-pointer
+
SDL_USES= gl sdl
-SDL_USE= GL=glu SDL=mixer,sdl
+SDL_USE= GL=gl,glu SDL=mixer,sdl
SDL_CMAKE_ON= -DWITH_SDL:BOOL=ON -DWITH_OPENGL:BOOL=ON
SDL_CMAKE_OFF= -DWITH_SDL:BOOL=OFF -DWITH_OPENGL:BOOL=OFF
@@ -60,8 +63,6 @@ VORBIS_LIB_DEPENDS= libvorbis.so:audio/libvorbis
VORBIS_CMAKE_ON= -DWITH_VORBIS:BOOL=ON
VORBIS_CMAKE_OFF= -DWITH_VORBIS:BOOL=OFF
-OPTIMIZED_CFLAGS_CFLAGS= -O3 -ffast-math -fomit-frame-pointer
-
.include <bsd.port.options.mk>
post-patch: