aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-08-25 12:05:21 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-08-27 23:49:12 +0000
commit3f9b003911b98de863a5d1ea93163851ceb6059f (patch)
tree89ca7cc67f9106cea47baf851cbbf50386195394 /games
parentcda6b1f7b0914beab58972467d8a1171d9f045da (diff)
downloadports-3f9b003911b98de863a5d1ea93163851ceb6059f.tar.gz
ports-3f9b003911b98de863a5d1ea93163851ceb6059f.zip
Diffstat (limited to 'games')
-rw-r--r--games/freeorion/Makefile15
-rw-r--r--games/freeorion/distinfo6
-rw-r--r--games/freeorion/files/patch-UI_CombatReport_GraphicalSummary.cpp21
-rw-r--r--games/freeorion/files/patch-universe_Conditions.cpp11
4 files changed, 14 insertions, 39 deletions
diff --git a/games/freeorion/Makefile b/games/freeorion/Makefile
index 9dcc19d741c9..ff26d74852f4 100644
--- a/games/freeorion/Makefile
+++ b/games/freeorion/Makefile
@@ -1,7 +1,6 @@
PORTNAME= freeorion
DISTVERSIONPREFIX= v
-DISTVERSION= 0.4.10.1
-PORTREVISION= 1
+DISTVERSION= 0.4.10.2
CATEGORIES= games
MAINTAINER= amdmi3@FreeBSD.org
@@ -15,7 +14,7 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
USE_GITHUB= yes
-USES= cmake compiler:c++14-lang python:3.5+
+USES= cmake compiler:c++14-lang python:3.5-3.9 # inherited from boost-python-libs
CMAKE_ARGS= -Wno-dev
LDFLAGS_i386= -Wl,-znotext
@@ -40,10 +39,18 @@ HEADLESS_LIB_DEPENDS_OFF= \
libvorbis.so:audio/libvorbis \
libpng.so:graphics/png
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_VER} != ${PYTHON_DEFAULT}
+# unable to detect boost_python otherwise since required files are
+# not installed by boost-python-libs
+CMAKE_ARGS+= -DBoost_NO_BOOST_CMAKE:BOOL=YES
+.endif
+
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/freeorion/distinfo b/games/freeorion/distinfo
index 5f2e2a1c58c5..f8d71d452ac2 100644
--- a/games/freeorion/distinfo
+++ b/games/freeorion/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1602008570
-SHA256 (freeorion-freeorion-v0.4.10.1_GH0.tar.gz) = ce53307f25c82efaa52b5ea98934648e76b9fa3de5fffbf012bda7cf97bf3168
-SIZE (freeorion-freeorion-v0.4.10.1_GH0.tar.gz) = 124693099
+TIMESTAMP = 1629828016
+SHA256 (freeorion-freeorion-v0.4.10.2_GH0.tar.gz) = 8c3bd4dcae7e2b160361b88f9a97cdb62b5c7413675acc15774054878228e709
+SIZE (freeorion-freeorion-v0.4.10.2_GH0.tar.gz) = 124720711
diff --git a/games/freeorion/files/patch-UI_CombatReport_GraphicalSummary.cpp b/games/freeorion/files/patch-UI_CombatReport_GraphicalSummary.cpp
deleted file mode 100644
index 4947e31e7220..000000000000
--- a/games/freeorion/files/patch-UI_CombatReport_GraphicalSummary.cpp
+++ /dev/null
@@ -1,21 +0,0 @@
-Change similar to upstream commit 9cc1926e8126163d3b8877c0112e11c462a96384:
-remove unused code to fix build with boost 1.76
-
---- UI/CombatReport/GraphicalSummary.cpp.orig 2020-09-25 11:06:39 UTC
-+++ UI/CombatReport/GraphicalSummary.cpp
-@@ -409,6 +409,7 @@ class SideBar : public GG::Wnd { (public)
- m_y_axis_label->MoveTo(GG::Pt(-m_y_axis_label->MinUsableSize().x / 2 - AXIS_WIDTH, Height()/2 - m_y_axis_label->Height()/2));
- }
-
-+ /*
- void DrawArrow(GG::Pt begin, GG::Pt end) {
- double head_width = 5.0;
- // A vector (math) of the arrow we wish to draw
-@@ -493,6 +494,7 @@ class SideBar : public GG::Wnd { (public)
- DrawArrow(begin, x_end);
- DrawArrow(begin, y_end);
- }
-+ */
-
- void SizeMove(const GG::Pt& ul, const GG::Pt& lr) override {
- GG::Wnd::SizeMove(ul, lr);
diff --git a/games/freeorion/files/patch-universe_Conditions.cpp b/games/freeorion/files/patch-universe_Conditions.cpp
deleted file mode 100644
index 9b5737aea98f..000000000000
--- a/games/freeorion/files/patch-universe_Conditions.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- universe/Conditions.cpp.orig 2020-09-25 11:06:39 UTC
-+++ universe/Conditions.cpp
-@@ -32,6 +32,8 @@
- #include <boost/graph/adjacency_list.hpp>
- #include <boost/graph/st_connected.hpp>
-
-+#include <cfloat> // for FLT_MAX
-+
-
- using boost::io::str;
-