aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-09-16 11:07:08 +0000
committerSimon Barner <barner@FreeBSD.org>2005-09-16 11:07:08 +0000
commit4eac9f1b182ef9e0273b2857517bcb96a1a9000d (patch)
tree3f3631191bf07c9022190f3c40f4b80b2ab53d8b /games
parent30915f5be3d81839c31ecf00c611342c99d0dcd3 (diff)
downloadports-4eac9f1b182ef9e0273b2857517bcb96a1a9000d.tar.gz
ports-4eac9f1b182ef9e0273b2857517bcb96a1a9000d.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/warzone/Makefile79
-rw-r--r--games/warzone/distinfo2
-rw-r--r--games/warzone/files/warzone.in7
-rw-r--r--games/warzone/pkg-descr13
-rw-r--r--games/warzone/pkg-plist93
-rw-r--r--games/warzone2100/Makefile79
-rw-r--r--games/warzone2100/distinfo2
-rw-r--r--games/warzone2100/files/warzone.in7
-rw-r--r--games/warzone2100/pkg-descr13
-rw-r--r--games/warzone2100/pkg-plist93
11 files changed, 389 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index b6fda628770a..d10bb6aaac6b 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -562,6 +562,7 @@
SUBDIR += vor
SUBDIR += wanderer
SUBDIR += wargus
+ SUBDIR += warzone2100
SUBDIR += wesnoth
SUBDIR += wmeyes
SUBDIR += wmfortune
diff --git a/games/warzone/Makefile b/games/warzone/Makefile
new file mode 100644
index 000000000000..4103f01a9c1f
--- /dev/null
+++ b/games/warzone/Makefile
@@ -0,0 +1,79 @@
+# New ports collection makefile for: warzone2100
+# Date created: 21 Aug 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= warzone2100
+PORTVERSION= 0.2.2
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Innovative 3D real-time strategy game
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ mad.2:${PORTSDIR}/audio/libmad \
+ ogg.5:${PORTSDIR}/audio/libogg \
+ openal.0:${PORTSDIR}/audio/openal \
+ vorbis.3:${PORTSDIR}/audio/libvorbis
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_GL= yes
+USE_SDL= net sdl
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-transform-name=""
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
+ LDFLAGS="-L${X11BASE}/lib"
+
+SUB_FILES= warzone
+
+post-patch:
+# Remove "-m32" flag
+ @${REINPLACE_CMD} -e 's|-m32||' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT} \
+ ${WRKSRC}/makerules/common.mk
+
+# Fix SDL include statement
+.for f in configure *.c *.h
+ @${FIND} ${WRKSRC} -type f -name "${f}" -print0 | \
+ ${XARGS} -0 ${REINPLACE_CMD} -e \
+ 's|\(#include.*\)SDL/\(SDL.*\)|\1\2|'
+.endfor
+
+do-install:
+# Script
+ @${INSTALL_SCRIPT} ${WRKDIR}/warzone ${PREFIX}/bin
+
+# Program
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/warzone ${PREFIX}/libexec
+
+# Data
+ @${MKDIR} ${DATADIR}
+ @${CP} -R ${WRKSRC}/data/* ${DATADIR}
+
+# Documentation
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+post-install:
+# Fix permissions
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
+ @${FIND} ${DATADIR} -type f -print0 | \
+ ${XARGS} -0 ${CHMOD} ${SHAREMODE}
+ @${FIND} ${DATADIR} -type d -print0 | \
+ ${XARGS} -0 ${CHMOD} ${BINMODE}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= does not compile (missing stdint.h)
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/warzone/distinfo b/games/warzone/distinfo
new file mode 100644
index 000000000000..a4e996e781ed
--- /dev/null
+++ b/games/warzone/distinfo
@@ -0,0 +1,2 @@
+MD5 (warzone2100-0.2.2.tar.bz2) = b23fa1896856c3b9ee37b39029e4c532
+SIZE (warzone2100-0.2.2.tar.bz2) = 31076323
diff --git a/games/warzone/files/warzone.in b/games/warzone/files/warzone.in
new file mode 100644
index 000000000000..c8dd49cba4bb
--- /dev/null
+++ b/games/warzone/files/warzone.in
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+# The executable needs to be run from its data directory.
+
+cd %%DATADIR%% || exit 1
+
+exec %%PREFIX%%/libexec/warzone
diff --git a/games/warzone/pkg-descr b/games/warzone/pkg-descr
new file mode 100644
index 000000000000..36e7beeda67d
--- /dev/null
+++ b/games/warzone/pkg-descr
@@ -0,0 +1,13 @@
+Warzone 2100 was an innovative 3D real-time strategy game back in 1999, and
+most will agree it didn't enjoy the commercial success it should have had. The
+game's source code was liberated on December 6th, 2004, under a GPL license
+(see COPYING in this directory for details). Soon after that, the Warzone 2100
+ReDev project was formed to take care of its future.
+
+Our goal is to make warzone run on all possible platforms. Therefore, we
+stripped the original code of all proprietary technologies and replaced them
+with cross-platform and free equivalents, like OpenGL, OpenAL, etc... Right
+now, Warzone 2100 works very well on Windows and GNU/Linux, and we have even
+heard of it running on BSD with no particular issue.
+
+WWW: http://warzone2100.sf.net/
diff --git a/games/warzone/pkg-plist b/games/warzone/pkg-plist
new file mode 100644
index 000000000000..e640281f2d7f
--- /dev/null
+++ b/games/warzone/pkg-plist
@@ -0,0 +1,93 @@
+bin/warzone
+libexec/warzone
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%DATADIR%%/2c-ardvark.wdg
+%%DATADIR%%/2c-bitofabarny.wdg
+%%DATADIR%%/2c-marspyscho.wdg
+%%DATADIR%%/8c-mars3gorges_8.wdg
+%%DATADIR%%/8c-marscodao.wdg
+%%DATADIR%%/8c-marsendgame.wdg
+%%DATADIR%%/8c-marsnrglvalis.wdg
+%%DATADIR%%/8c-marsrelic.wdg
+%%DATADIR%%/aug27.wdg
+%%DATADIR%%/cam2tech.wdg
+%%DATADIR%%/dec00.wdg
+%%DATADIR%%/july30.wdg
+%%DATADIR%%/june25.wdg
+%%DATADIR%%/marsbetamaps.txt
+%%DATADIR%%/may21.wdg
+%%DATADIR%%/may28.wdg
+%%DATADIR%%/multiplay/skirmish/player0.slo
+%%DATADIR%%/multiplay/skirmish/player0.vlo
+%%DATADIR%%/multiplay/skirmish/player1.slo
+%%DATADIR%%/multiplay/skirmish/player1.vlo
+%%DATADIR%%/multiplay/skirmish/player2.slo
+%%DATADIR%%/multiplay/skirmish/player2.vlo
+%%DATADIR%%/multiplay/skirmish/player3.slo
+%%DATADIR%%/multiplay/skirmish/player3.vlo
+%%DATADIR%%/multiplay/skirmish/player4.slo
+%%DATADIR%%/multiplay/skirmish/player4.vlo
+%%DATADIR%%/multiplay/skirmish/player5.slo
+%%DATADIR%%/multiplay/skirmish/player5.vlo
+%%DATADIR%%/multiplay/skirmish/player6.slo
+%%DATADIR%%/multiplay/skirmish/player6.vlo
+%%DATADIR%%/multiplay/skirmish/player7.slo
+%%DATADIR%%/multiplay/skirmish/player7.vlo
+%%DATADIR%%/multiplay/skirmish/rules.slo
+%%DATADIR%%/multiplay/skirmish/rules.vlo
+%%DATADIR%%/multiplay/skirmish/scriptlang.rtf
+%%DATADIR%%/multiplay/skirmish/sk2tech.vlo
+%%DATADIR%%/multiplay/skirmish/sk3tech.vlo
+%%DATADIR%%/multiplay/skirmish/sktech.slo
+%%DATADIR%%/music/music.wpl
+%%DATADIR%%/music/neos_aurore.ogg
+%%DATADIR%%/music/neos_chocolat.ogg
+%%DATADIR%%/music/neos_down.ogg
+%%DATADIR%%/music/neos_esperance.ogg
+%%DATADIR%%/music/neos_indy.ogg
+%%DATADIR%%/music/neos_symphonie_du_vide.ogg
+%%DATADIR%%/newmaps.wdg
+%%DATADIR%%/newtech.wdg
+%%DATADIR%%/nov.wdg
+%%DATADIR%%/oct.wdg
+%%DATADIR%%/sep30.wdg
+%%DATADIR%%/skirmish3.wdg
+%%DATADIR%%/stats/names.txt
+%%DATADIR%%/texpages/bdrops/00-bdrop.jpg
+%%DATADIR%%/texpages/bdrops/00-bdrop.pcx
+%%DATADIR%%/texpages/bdrops/01-bdrop.jpg
+%%DATADIR%%/texpages/bdrops/01-bdrop.pcx
+%%DATADIR%%/texpages/bdrops/02-bdrop.jpg
+%%DATADIR%%/texpages/bdrops/02-bdrop.pcx
+%%DATADIR%%/texpages/bdrops/03-bdrop.jpg
+%%DATADIR%%/texpages/bdrops/03-bdrop.pcx
+%%DATADIR%%/texpages/bdrops/04-bdrop.jpg
+%%DATADIR%%/texpages/bdrops/04-bdrop.pcx
+%%DATADIR%%/texpages/bdrops/05-bdrop.jpg
+%%DATADIR%%/texpages/bdrops/05-bdrop.pcx
+%%DATADIR%%/texpages/bdrops/06-bdrop.jpg
+%%DATADIR%%/texpages/bdrops/06-bdrop.pcx
+%%DATADIR%%/texpages/bdrops/credits.jpg
+%%DATADIR%%/texpages/bdrops/credits.pcx
+%%DATADIR%%/texpages/bdrops/missionend.jpg
+%%DATADIR%%/texpages/bdrops/missionend.pcx
+%%DATADIR%%/texpages/readme.txt
+%%DATADIR%%/texpages/tertilesc1.pcx
+%%DATADIR%%/texpages/tertilesc2.pcx
+%%DATADIR%%/texpages/tertilesc3.pcx
+%%DATADIR%%/texpages/tertilesc4hw.pcx
+%%DATADIR%%/texpages/tertilesc5.pcx
+%%DATADIR%%/texpages/tertilesc5hw.pcx
+%%DATADIR%%/texpages/tertilesc6.pcx
+%%DATADIR%%/texpages/tertilesc7.pcx
+%%DATADIR%%/texpages/tertilesc7hw.pcx
+%%DATADIR%%/update.rtf
+%%DATADIR%%/warzone.wdg
+@dirrm %%DATADIR%%/texpages/bdrops
+@dirrm %%DATADIR%%/texpages
+@dirrm %%DATADIR%%/stats
+@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/multiplay/skirmish
+@dirrm %%DATADIR%%/multiplay
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/games/warzone2100/Makefile b/games/warzone2100/Makefile
new file mode 100644
index 000000000000..4103f01a9c1f
--- /dev/null
+++ b/games/warzone2100/Makefile
@@ -0,0 +1,79 @@
+# New ports collection makefile for: warzone2100
+# Date created: 21 Aug 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= warzone2100
+PORTVERSION= 0.2.2
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Innovative 3D real-time strategy game
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ mad.2:${PORTSDIR}/audio/libmad \
+ ogg.5:${PORTSDIR}/audio/libogg \
+ openal.0:${PORTSDIR}/audio/openal \
+ vorbis.3:${PORTSDIR}/audio/libvorbis
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_GL= yes
+USE_SDL= net sdl
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-transform-name=""
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
+ LDFLAGS="-L${X11BASE}/lib"
+
+SUB_FILES= warzone
+
+post-patch:
+# Remove "-m32" flag
+ @${REINPLACE_CMD} -e 's|-m32||' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT} \
+ ${WRKSRC}/makerules/common.mk
+
+# Fix SDL include statement
+.for f in configure *.c *.h
+ @${FIND} ${WRKSRC} -type f -name "${f}" -print0 | \
+ ${XARGS} -0 ${REINPLACE_CMD} -e \
+ 's|\(#include.*\)SDL/\(SDL.*\)|\1\2|'
+.endfor
+
+do-install:
+# Script
+ @${INSTALL_SCRIPT} ${WRKDIR}/warzone ${PREFIX}/bin
+
+# Program
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/warzone ${PREFIX}/libexec
+
+# Data
+ @${MKDIR} ${DATADIR}
+ @${CP} -R ${WRKSRC}/data/* ${DATADIR}
+
+# Documentation
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+post-install:
+# Fix permissions
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
+ @${FIND} ${DATADIR} -type f -print0 | \
+ ${XARGS} -0 ${CHMOD} ${SHAREMODE}
+ @${FIND} ${DATADIR} -type d -print0 | \
+ ${XARGS} -0 ${CHMOD} ${BINMODE}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= does not compile (missing stdint.h)
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/warzone2100/distinfo b/games/warzone2100/distinfo
new file mode 100644
index 000000000000..a4e996e781ed
--- /dev/null
+++ b/games/warzone2100/distinfo
@@ -0,0 +1,2 @@
+MD5 (warzone2100-0.2.2.tar.bz2) = b23fa1896856c3b9ee37b39029e4c532
+SIZE (warzone2100-0.2.2.tar.bz2) = 31076323
diff --git a/games/warzone2100/files/warzone.in b/games/warzone2100/files/warzone.in
new file mode 100644
index 000000000000..c8dd49cba4bb
--- /dev/null
+++ b/games/warzone2100/files/warzone.in
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+# The executable needs to be run from its data directory.
+
+cd %%DATADIR%% || exit 1
+
+exec %%PREFIX%%/libexec/warzone
diff --git a/games/warzone2100/pkg-descr b/games/warzone2100/pkg-descr
new file mode 100644
index 000000000000..36e7beeda67d
--- /dev/null
+++ b/games/warzone2100/pkg-descr
@@ -0,0 +1,13 @@
+Warzone 2100 was an innovative 3D real-time strategy game back in 1999, and
+most will agree it didn't enjoy the commercial success it should have had. The
+game's source code was liberated on December 6th, 2004, under a GPL license
+(see COPYING in this directory for details). Soon after that, the Warzone 2100
+ReDev project was formed to take care of its future.
+
+Our goal is to make warzone run on all possible platforms. Therefore, we
+stripped the original code of all proprietary technologies and replaced them
+with cross-platform and free equivalents, like OpenGL, OpenAL, etc... Right
+now, Warzone 2100 works very well on Windows and GNU/Linux, and we have even
+heard of it running on BSD with no particular issue.
+
+WWW: http://warzone2100.sf.net/
diff --git a/games/warzone2100/pkg-plist b/games/warzone2100/pkg-plist
new file mode 100644
index 000000000000..e640281f2d7f
--- /dev/null
+++ b/games/warzone2100/pkg-plist
@@ -0,0 +1,93 @@
+bin/warzone
+libexec/warzone
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%DATADIR%%/2c-ardvark.wdg
+%%DATADIR%%/2c-bitofabarny.wdg
+%%DATADIR%%/2c-marspyscho.wdg
+%%DATADIR%%/8c-mars3gorges_8.wdg
+%%DATADIR%%/8c-marscodao.wdg
+%%DATADIR%%/8c-marsendgame.wdg
+%%DATADIR%%/8c-marsnrglvalis.wdg
+%%DATADIR%%/8c-marsrelic.wdg
+%%DATADIR%%/aug27.wdg
+%%DATADIR%%/cam2tech.wdg
+%%DATADIR%%/dec00.wdg
+%%DATADIR%%/july30.wdg
+%%DATADIR%%/june25.wdg
+%%DATADIR%%/marsbetamaps.txt
+%%DATADIR%%/may21.wdg
+%%DATADIR%%/may28.wdg
+%%DATADIR%%/multiplay/skirmish/player0.slo
+%%DATADIR%%/multiplay/skirmish/player0.vlo
+%%DATADIR%%/multiplay/skirmish/player1.slo
+%%DATADIR%%/multiplay/skirmish/player1.vlo
+%%DATADIR%%/multiplay/skirmish/player2.slo
+%%DATADIR%%/multiplay/skirmish/player2.vlo
+%%DATADIR%%/multiplay/skirmish/player3.slo
+%%DATADIR%%/multiplay/skirmish/player3.vlo
+%%DATADIR%%/multiplay/skirmish/player4.slo
+%%DATADIR%%/multiplay/skirmish/player4.vlo
+%%DATADIR%%/multiplay/skirmish/player5.slo
+%%DATADIR%%/multiplay/skirmish/player5.vlo
+%%DATADIR%%/multiplay/skirmish/player6.slo
+%%DATADIR%%/multiplay/skirmish/player6.vlo
+%%DATADIR%%/multiplay/skirmish/player7.slo
+%%DATADIR%%/multiplay/skirmish/player7.vlo
+%%DATADIR%%/multiplay/skirmish/rules.slo
+%%DATADIR%%/multiplay/skirmish/rules.vlo
+%%DATADIR%%/multiplay/skirmish/scriptlang.rtf
+%%DATADIR%%/multiplay/skirmish/sk2tech.vlo
+%%DATADIR%%/multiplay/skirmish/sk3tech.vlo
+%%DATADIR%%/multiplay/skirmish/sktech.slo
+%%DATADIR%%/music/music.wpl
+%%DATADIR%%/music/neos_aurore.ogg
+%%DATADIR%%/music/neos_chocolat.ogg
+%%DATADIR%%/music/neos_down.ogg
+%%DATADIR%%/music/neos_esperance.ogg
+%%DATADIR%%/music/neos_indy.ogg
+%%DATADIR%%/music/neos_symphonie_du_vide.ogg
+%%DATADIR%%/newmaps.wdg
+%%DATADIR%%/newtech.wdg
+%%DATADIR%%/nov.wdg
+%%DATADIR%%/oct.wdg
+%%DATADIR%%/sep30.wdg
+%%DATADIR%%/skirmish3.wdg
+%%DATADIR%%/stats/names.txt
+%%DATADIR%%/texpages/bdrops/00-bdrop.jpg
+%%DATADIR%%/texpages/bdrops/00-bdrop.pcx
+%%DATADIR%%/texpages/bdrops/01-bdrop.jpg
+%%DATADIR%%/texpages/bdrops/01-bdrop.pcx
+%%DATADIR%%/texpages/bdrops/02-bdrop.jpg
+%%DATADIR%%/texpages/bdrops/02-bdrop.pcx
+%%DATADIR%%/texpages/bdrops/03-bdrop.jpg
+%%DATADIR%%/texpages/bdrops/03-bdrop.pcx
+%%DATADIR%%/texpages/bdrops/04-bdrop.jpg
+%%DATADIR%%/texpages/bdrops/04-bdrop.pcx
+%%DATADIR%%/texpages/bdrops/05-bdrop.jpg
+%%DATADIR%%/texpages/bdrops/05-bdrop.pcx
+%%DATADIR%%/texpages/bdrops/06-bdrop.jpg
+%%DATADIR%%/texpages/bdrops/06-bdrop.pcx
+%%DATADIR%%/texpages/bdrops/credits.jpg
+%%DATADIR%%/texpages/bdrops/credits.pcx
+%%DATADIR%%/texpages/bdrops/missionend.jpg
+%%DATADIR%%/texpages/bdrops/missionend.pcx
+%%DATADIR%%/texpages/readme.txt
+%%DATADIR%%/texpages/tertilesc1.pcx
+%%DATADIR%%/texpages/tertilesc2.pcx
+%%DATADIR%%/texpages/tertilesc3.pcx
+%%DATADIR%%/texpages/tertilesc4hw.pcx
+%%DATADIR%%/texpages/tertilesc5.pcx
+%%DATADIR%%/texpages/tertilesc5hw.pcx
+%%DATADIR%%/texpages/tertilesc6.pcx
+%%DATADIR%%/texpages/tertilesc7.pcx
+%%DATADIR%%/texpages/tertilesc7hw.pcx
+%%DATADIR%%/update.rtf
+%%DATADIR%%/warzone.wdg
+@dirrm %%DATADIR%%/texpages/bdrops
+@dirrm %%DATADIR%%/texpages
+@dirrm %%DATADIR%%/stats
+@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/multiplay/skirmish
+@dirrm %%DATADIR%%/multiplay
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%