aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-04-12 21:33:19 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-04-12 21:35:17 +0000
commit5ac091e57e9c9e320afe391aab57deb6ed6f2118 (patch)
tree0dc3d46f8b9f441e82b506ef0be4d4e1621c79ed /games
parent3490a531954e1746ee3ce97d5a75e4cef298a214 (diff)
downloadports-5ac091e57e9c9e320afe391aab57deb6ed6f2118.tar.gz
ports-5ac091e57e9c9e320afe391aab57deb6ed6f2118.zip
games/pink-pony: make compatible with Imath 3.0, update glfw dep
The LIB_DEPENDS on glfw2 was tightened up to check the .so major version component, to avoid it picking up the incompatible glfw (3). Reported by: Koichiro Iwao (meta@)
Diffstat (limited to 'games')
-rw-r--r--games/pink-pony/Makefile11
-rw-r--r--games/pink-pony/files/patch-SConstruct9
-rw-r--r--games/pink-pony/files/patch-src_Line.cc9
3 files changed, 19 insertions, 10 deletions
diff --git a/games/pink-pony/Makefile b/games/pink-pony/Makefile
index fbceaa1d4bca..6100c2bad0dc 100644
--- a/games/pink-pony/Makefile
+++ b/games/pink-pony/Makefile
@@ -1,6 +1,6 @@
PORTNAME= pink-pony
PORTVERSION= 1.4.1
-PORTREVISION= 28
+PORTREVISION= 29
CATEGORIES= games
MAINTAINER= amdmi3@FreeBSD.org
@@ -8,15 +8,12 @@ COMMENT= Tron-like multiplayer racing game
LICENSE= GPLv3+
-BROKEN= depends on removed port graphics/ilmbase
-
LIB_DEPENDS= libIL.so:graphics/devil \
libprotobuf.so:devel/protobuf \
- libglfw.so:graphics/glfw2 \
+ libglfw.so.0:graphics/glfw2 \
libftgl.so:graphics/ftgl \
- libsigc-2.0.so:devel/libsigc++20
-# FIXME: which port has a drop-in replacement of libHalf.so?
-# libHalf.so:graphics/ilmbase
+ libsigc-2.0.so:devel/libsigc++20 \
+ libImath.so:math/Imath
USE_GITHUB= yes
GH_ACCOUNT= ginkgo
diff --git a/games/pink-pony/files/patch-SConstruct b/games/pink-pony/files/patch-SConstruct
index ed8805c988e1..c8224a1d424a 100644
--- a/games/pink-pony/files/patch-SConstruct
+++ b/games/pink-pony/files/patch-SConstruct
@@ -1,17 +1,20 @@
--- SConstruct.orig 2014-01-01 01:39:36 UTC
+++ SConstruct
-@@ -3,11 +3,10 @@ import os
+@@ -3,13 +3,12 @@ import os
optimization_flags = ['-O3']
#optimization_flags = ['-O0', '-ggdb']
-env = Environment()
-+env = Environment(ENV=os.environ, **dict((k, v.split()) for k, v in ARGUMENTS.items()))
-env['CC'] = 'g++'
-env['CCFLAGS'] = ['-Wall', '-Wextra', '-Wno-reorder', '-Wno-unused-parameter'] + optimization_flags
++env = Environment(ENV=os.environ, **dict((k, v.split()) for k, v in ARGUMENTS.items()))
+env.Append(CCFLAGS = ['-Wall', '-Wextra', '-Wno-reorder', '-Wno-unused-parameter'])
env['LIBS'] = ['GLU', 'GL', 'protobuf', 'IL']
-env['CPPPATH'] = ['#', '#/src', '#/external/tinyXML', '#/external/flextGL/', '/usr/include/OpenEXR']
+env['CPPPATH'] = ['#', '#/src', '#/external/tinyXML', '#/external/flextGL/']
- env.ParseConfig("pkg-config IlmBase --cflags --libs")
+-env.ParseConfig("pkg-config IlmBase --cflags --libs")
++env.ParseConfig("pkg-config Imath --cflags --libs")
env.ParseConfig("pkg-config libglfw --cflags --libs")
+ env.ParseConfig("pkg-config ftgl --cflags --libs")
+ env.ParseConfig("pkg-config sigc++-2.0 --cflags --libs")
diff --git a/games/pink-pony/files/patch-src_Line.cc b/games/pink-pony/files/patch-src_Line.cc
new file mode 100644
index 000000000000..42a19e5ea01e
--- /dev/null
+++ b/games/pink-pony/files/patch-src_Line.cc
@@ -0,0 +1,9 @@
+--- src/Line.cc.orig 2014-01-01 01:39:36 UTC
++++ src/Line.cc
+@@ -1,5 +1,5 @@
+ #include "Line.hh"
+-#include <ImathLimits.h>
++#include <halfLimits.h>
+
+ #define EPSILON limits<double>::epsilon()
+