aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-01-08 15:32:54 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-01-08 15:32:54 +0000
commit6368fa5823d42373221b2a8a4cd5b9075f2ccb4e (patch)
treeb426f8de95a91afe66b37e0cb2cf504cb00802a5 /games
parent9446dd8091ef5d60a1d077c334ca0dd3898f0ca3 (diff)
- Update to 3.5.2
Notes
Notes: svn path=/head/; revision=489712
Diffstat (limited to 'games')
-rw-r--r--games/wyrmsun/Makefile2
-rw-r--r--games/wyrmsun/distinfo6
-rw-r--r--games/wyrmsun/files/patch-cmake68
-rw-r--r--games/wyrmsun/files/patch-scripts_tilesets_cave.lua10
-rw-r--r--games/wyrmsun/files/patch-scripts_tilesets_dungeon.lua10
5 files changed, 4 insertions, 92 deletions
diff --git a/games/wyrmsun/Makefile b/games/wyrmsun/Makefile
index ab17f06a8c98..8a3a63cc8caa 100644
--- a/games/wyrmsun/Makefile
+++ b/games/wyrmsun/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= wyrmsun
-PORTVERSION= 3.5.1
+PORTVERSION= 3.5.2
DISTVERSIONPREFIX= v
CATEGORIES= games
diff --git a/games/wyrmsun/distinfo b/games/wyrmsun/distinfo
index 34cc22ad5670..a1f17b966a01 100644
--- a/games/wyrmsun/distinfo
+++ b/games/wyrmsun/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1545918235
-SHA256 (Andrettin-Wyrmsun-v3.5.1_GH0.tar.gz) = a2f5c0521a8d6fa0b4643478946b01957357f5c99a6b7ab5d629e519aa02f4ac
-SIZE (Andrettin-Wyrmsun-v3.5.1_GH0.tar.gz) = 273083934
+TIMESTAMP = 1546954164
+SHA256 (Andrettin-Wyrmsun-v3.5.2_GH0.tar.gz) = 3311343a7d03a90d0641d704c4bba003a7bf06c0dda4fb31b1e8d222111be2be
+SIZE (Andrettin-Wyrmsun-v3.5.2_GH0.tar.gz) = 273235972
diff --git a/games/wyrmsun/files/patch-cmake b/games/wyrmsun/files/patch-cmake
deleted file mode 100644
index db90dc94c445..000000000000
--- a/games/wyrmsun/files/patch-cmake
+++ /dev/null
@@ -1,68 +0,0 @@
-commit 15caa201694821770e1355f989a716afd3ea650b
-Author: Dmitry Marakasov <amdmi3@amdmi3.ru>
-Date: Wed Dec 26 22:14:17 2018 +0300
-
- Add CMake-based installation support
-
- - Provide script to run wyrmsun from command line
- - Fix hardcoded path to /usr/share/wyrmsun
- - Install data, documentation, script, desktop and appdata files as well
- as icons into designated locations
-
-diff --git CMakeLists.txt CMakeLists.txt
-new file mode 100644
-index 00000000..91ef748a
---- /dev/null
-+++ CMakeLists.txt
-@@ -0,0 +1,30 @@
-+project(wyrmsun)
-+cmake_minimum_required(VERSION 3.0)
-+
-+set(DATADIR share/wyrmsun CACHE STRING "Where to install Wyrmsun data files")
-+set(DOCSDIR share/doc/wyrmsun CACHE STRING "Where to install Wyrmsun documentation")
-+
-+configure_file(linux/wyrmsun.sh.in linux/wyrmsun.sh @ONLY)
-+
-+install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/linux/wyrmsun.sh DESTINATION bin RENAME wyrmsun)
-+install(FILES linux/wyrmsun.desktop DESTINATION share/applications)
-+install(FILES linux/wyrmsun.appdata.xml DESTINATION share/appdata)
-+install(FILES graphics/ui/icons/wyrmsun_icon_32.png DESTINATION share/icons/hicolor/32x32/apps RENAME wyrmsun.png)
-+install(FILES graphics/ui/icons/wyrmsun_icon_64.png DESTINATION share/icons/hicolor/64x64/apps RENAME wyrmsun.png)
-+install(FILES graphics/ui/icons/wyrmsun_icon_128.png DESTINATION share/icons/hicolor/128x128/apps RENAME wyrmsun.png)
-+
-+install(FILES oaml.defs DESTINATION ${DATADIR})
-+
-+install(DIRECTORY
-+ data
-+ graphics
-+ maps
-+ music
-+ scripts
-+ sounds
-+ translations
-+ DESTINATION ${DATADIR}
-+)
-+
-+install(FILES readme.txt DESTINATION ${DOCSDIR})
-+install(DIRECTORY documents DESTINATION ${DOCSDIR})
-diff --git linux/wyrmsun.desktop linux/wyrmsun.desktop
-index b779fa63..cad9ea6b 100644
---- linux/wyrmsun.desktop
-+++ linux/wyrmsun.desktop
-@@ -1,6 +1,6 @@
- [Desktop Entry]
- Categories=Game;StrategyGame;
--Exec=wyrmgus -d /usr/share/wyrmsun
-+Exec=wyrmsun
- GenericName=Mythologic realtime-strategy game
- GenericName[de]=Mythologisches Echtzeitstrategiespiel
- Icon=wyrmsun
-diff --git linux/wyrmsun.sh.in linux/wyrmsun.sh.in
-new file mode 100644
-index 00000000..6bcb0675
---- /dev/null
-+++ linux/wyrmsun.sh.in
-@@ -0,0 +1,3 @@
-+#!/bin/sh
-+
-+exec wyrmgus -d @CMAKE_INSTALL_PREFIX@/@DATADIR@ "$@"
diff --git a/games/wyrmsun/files/patch-scripts_tilesets_cave.lua b/games/wyrmsun/files/patch-scripts_tilesets_cave.lua
deleted file mode 100644
index 00ec19c52aa6..000000000000
--- a/games/wyrmsun/files/patch-scripts_tilesets_cave.lua
+++ /dev/null
@@ -1,10 +0,0 @@
---- scripts/tilesets/cave.lua.orig 2018-12-25 12:18:32 UTC
-+++ scripts/tilesets/cave.lua
-@@ -165,4 +165,6 @@ BuildTilesetTables()
-
- Load("scripts/scripts.lua")
- GameSettings.Inside = true
--SetTimeOfDaySchedule("")
-+if (LoadedGame == false) then
-+ SetTimeOfDaySchedule("")
-+end
diff --git a/games/wyrmsun/files/patch-scripts_tilesets_dungeon.lua b/games/wyrmsun/files/patch-scripts_tilesets_dungeon.lua
deleted file mode 100644
index 9daea28c40a2..000000000000
--- a/games/wyrmsun/files/patch-scripts_tilesets_dungeon.lua
+++ /dev/null
@@ -1,10 +0,0 @@
---- scripts/tilesets/dungeon.lua.orig 2018-12-25 12:18:32 UTC
-+++ scripts/tilesets/dungeon.lua
-@@ -216,4 +216,6 @@ BuildTilesetTables()
-
- Load("scripts/scripts.lua")
- GameSettings.Inside = true
--SetTimeOfDaySchedule("")
-+if (LoadedGame == false) then
-+ SetTimeOfDaySchedule("")
-+end