aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2018-02-21 16:24:53 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2018-02-21 16:24:53 +0000
commit6747cb9b4e52c875e3a9ca4d7d79407c101b0670 (patch)
treeb63cd55e9deac0f11169f04c64d04dd84d68b3b5 /games
parent9050c8e414cba36ceda4084dba51377cf6b95a30 (diff)
Remove dependency on the python metaport
PR: 225752 Submitted by: Yasuhiro KIMURA
Notes
Notes: svn path=/head/; revision=462532
Diffstat (limited to 'games')
-rw-r--r--games/0ad/Makefile4
-rw-r--r--games/chocolate-doom/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/games/0ad/Makefile b/games/0ad/Makefile
index 8abe6b7146d3..a87cb220d563 100644
--- a/games/0ad/Makefile
+++ b/games/0ad/Makefile
@@ -13,7 +13,6 @@ MAINTAINER= madpilot@FreeBSD.org
COMMENT= Real-time strategy (RTS) game of ancient warfare
BUILD_DEPENDS= zip:archivers/zip \
- python:lang/python \
cmake:devel/cmake
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libicui18n.so:devel/icu \
@@ -31,13 +30,14 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-alpha
BUILD_WRKSRC= ${WRKSRC}/build/workspaces/gcc
MAKE_ARGS= config=release
USES= compiler:c++11-lib dos2unix gmake iconv jpeg openal:al \
- pkgconfig tar:xz
+ pkgconfig python:build tar:xz
USE_GNOME= libxml2 gtk20
USE_GL= gl
USE_SDL= sdl2
USE_XORG= x11 xcursor
BUNDLE_LIBS= yes
DOS2UNIX_REGEX= .*\.([ch]p{0,2}|make)
+BINARY_ALIAS= python=${PYTHON_CMD}
USE_WX= 2.8+
WX_COMPS= wx:lib
diff --git a/games/chocolate-doom/Makefile b/games/chocolate-doom/Makefile
index 03e23f06d9c3..aa73e2cf9500 100644
--- a/games/chocolate-doom/Makefile
+++ b/games/chocolate-doom/Makefile
@@ -10,12 +10,12 @@ COMMENT= Doom/Heretic/Hexen/Strife engine port compatible with the originals
LICENSE= GPLv2
-BUILD_DEPENDS= python:lang/python
LIB_DEPENDS= libpng.so:graphics/png
-USES= gmake
+USES= gmake python:build
USE_SDL= mixer net sdl
GNU_CONFIGURE= yes
+BINARY_ALIAS= python=${PYTHON_CMD}
PORTDOCS= CMDLINE.doom ChangeLog INSTALL.doom NEWS.md NOT-BUGS.md PHILOSOPHY.md \
README.md README.Music.md