aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-10-23 18:18:43 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-10-23 18:18:43 +0000
commit74e4ec521699ece63a3e14de006a6da7c318506b (patch)
treee922eae6f90a5e2ae95163598c242e5e7a83ef5c /games
parent726fcd0619ebf0a579df7d5dbdc897e7af2227c7 (diff)
downloadports-74e4ec521699ece63a3e14de006a6da7c318506b.tar.gz
ports-74e4ec521699ece63a3e14de006a6da7c318506b.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/toppler/Makefile30
-rw-r--r--games/toppler/files/patch-Makefile.in29
-rw-r--r--games/toppler/pkg-plist8
3 files changed, 40 insertions, 27 deletions
diff --git a/games/toppler/Makefile b/games/toppler/Makefile
index 2e6fd5e153da..60e7170708a4 100644
--- a/games/toppler/Makefile
+++ b/games/toppler/Makefile
@@ -3,43 +3,23 @@
PORTNAME= toppler
PORTVERSION= 1.1.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
MAINTAINER= makc@FreeBSD.org
COMMENT= Climb a tower and avoid monsters
+LICENSE= GPLv2
+
USE_SDL= mixer sdl
-USES= gettext
-USE_GMAKE= yes
+USES= gettext gmake
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=${PREFIX}/share
-
-MAN6= ${PORTNAME}.6
+CONFIGURE_ARGS= --localstatedir=/var/games
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|DATA install-dist_pkgdocDATA|DATA|g' ${WRKSRC}/Makefile.in
-
-post-install:
- @${CHMOD} 2755 ${PREFIX}/bin/${PORTNAME}
- @${CHOWN} root:games ${PREFIX}/bin/${PORTNAME}
- @${CHMOD} 0664 ${DATADIR}/${PORTNAME}.hsc
- @${CHOWN} root:games ${DATADIR}/${PORTNAME}.hsc
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
-.for file in AUTHORS ChangeLog NEWS README
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
-.endif
-
.include <bsd.port.mk>
diff --git a/games/toppler/files/patch-Makefile.in b/games/toppler/files/patch-Makefile.in
new file mode 100644
index 000000000000..c5fd1c802f7f
--- /dev/null
+++ b/games/toppler/files/patch-Makefile.in
@@ -0,0 +1,29 @@
+--- ./Makefile.in.orig 2011-03-06 20:00:43.000000000 +0000
++++ ./Makefile.in 2013-10-23 16:58:33.155503773 +0000
+@@ -359,7 +359,7 @@
+ dist_pixmaps_DATA = $(PACKAGE).xpm
+ applications_DATA = $(PACKAGE).desktop
+ dist_man_MANS = toppler.6
+-dist_pkgdoc_DATA = AUTHORS COPYING ChangeLog NEWS README
++dist_pkgdoc_DATA = AUTHORS ChangeLog README
+ dist_pkgdata_DATA = \
+ toppler.dat toppler.ogg \
+ m1.ttm m2.ttm ball1.ttm ball2.ttm ball3.ttm abc.ttm pasi2.ttm david1.ttm
+@@ -1084,16 +1084,14 @@
+
+ install-data-am: install-applicationsDATA install-dist_pixmapsDATA \
+ install-dist_pkgdataDATA install-dist_pkgdocDATA \
+- install-dist_pkglocalstateDATA install-man
++ install-man
+ @$(NORMAL_INSTALL)
+- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
+ install-dvi: install-dvi-recursive
+
+ install-dvi-am:
+
+ install-exec-am: install-binPROGRAMS
+ @$(NORMAL_INSTALL)
+- $(MAKE) $(AM_MAKEFLAGS) install-exec-hook
+ install-html: install-html-recursive
+
+ install-html-am:
diff --git a/games/toppler/pkg-plist b/games/toppler/pkg-plist
index 2e63931a1f89..6e1eadb50ead 100644
--- a/games/toppler/pkg-plist
+++ b/games/toppler/pkg-plist
@@ -1,8 +1,8 @@
bin/toppler
+man/man6/toppler.6.gz
share/applications/toppler.desktop
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
share/locale/cs/LC_MESSAGES/toppler.mo
share/locale/de/LC_MESSAGES/toppler.mo
@@ -22,7 +22,11 @@ share/pixmaps/toppler.xpm
%%DATADIR%%/m2.ttm
%%DATADIR%%/pasi2.ttm
%%DATADIR%%/toppler.dat
-%%DATADIR%%/toppler.hsc
%%DATADIR%%/toppler.ogg
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@exec mkdir -p /var/games/toppler
+@exec chgrp games /var/games/toppler
+@unexec if [ ! -s /var/games/toppler/toppler.hsc ] ; then rm -f /var/games/toppler/toppler.hsc; rmdir /var/games/toppler ; fi
+@exec touch /var/games/toppler/toppler.hsc
+@exec chmod 664 /var/games/toppler/toppler.hsc