aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-11-03 17:09:20 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-11-03 17:09:20 +0000
commit7618bc6e1cf1d1a1ae186f50ad75a9cf43a3bf44 (patch)
tree5f1c03a71240db1cfce444a50c004152c6e27729 /games
parent50935dfbce419bcd7462702d5ecc5e4f67d19d33 (diff)
downloadports-7618bc6e1cf1d1a1ae186f50ad75a9cf43a3bf44.tar.gz
ports-7618bc6e1cf1d1a1ae186f50ad75a9cf43a3bf44.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/tty-solitaire/Makefile31
-rw-r--r--games/tty-solitaire/distinfo3
-rw-r--r--games/tty-solitaire/files/patch-Makefile30
-rw-r--r--games/tty-solitaire/pkg-descr3
5 files changed, 68 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 0092bc29f296..00ccf043178e 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -1003,6 +1003,7 @@
SUBDIR += tt
SUBDIR += ttraffic
SUBDIR += ttt
+ SUBDIR += tty-solitaire
SUBDIR += tux-aqfh
SUBDIR += tuxfighter
SUBDIR += tuxkart
diff --git a/games/tty-solitaire/Makefile b/games/tty-solitaire/Makefile
new file mode 100644
index 000000000000..96b955b22d84
--- /dev/null
+++ b/games/tty-solitaire/Makefile
@@ -0,0 +1,31 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= tty-solitaire
+PORTVERSION= 1.0.0
+DISTVERSIONPREFIX= v
+CATEGORIES= games
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Play solitaire in your terminal
+
+LICENSE= MIT
+
+USE_GITHUB= yes
+GH_ACCOUNT= mpereira
+
+USES= gmake ncurses
+
+PORTDOCS= *
+PLIST_FILES= bin/ttysolitaire
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ttysolitaire ${STAGEDIR}${PREFIX}/bin/
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>
diff --git a/games/tty-solitaire/distinfo b/games/tty-solitaire/distinfo
new file mode 100644
index 000000000000..a2b5aed97a07
--- /dev/null
+++ b/games/tty-solitaire/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1509721642
+SHA256 (mpereira-tty-solitaire-v1.0.0_GH0.tar.gz) = d3512beb8844ffb295cbea03bb3515fec12851bce38692e05cd55494beb2cc1f
+SIZE (mpereira-tty-solitaire-v1.0.0_GH0.tar.gz) = 277091
diff --git a/games/tty-solitaire/files/patch-Makefile b/games/tty-solitaire/files/patch-Makefile
new file mode 100644
index 000000000000..c5612a75eac1
--- /dev/null
+++ b/games/tty-solitaire/files/patch-Makefile
@@ -0,0 +1,30 @@
+--- Makefile.orig 2017-01-07 22:39:19 UTC
++++ Makefile
+@@ -1,14 +1,14 @@
+-CC = gcc
+-CFLAGS = -W -Wall -pedantic -ansi -std=c99 -g
++CC? = gcc
++CFLAGS+= -W -Wall -pedantic -ansi -std=c99
+
+-LDFLAGS = -lncursesw
++LDFLAGS+= -lncursesw
+
+ # OS X installs ncurses with wide character support, but not as "libncurses"
+ ifeq ($(shell uname -s),Darwin)
+ LDFLAGS = -lncurses
+ endif
+
+-PREFIX = /usr/local
++PREFIX? = /usr/local
+
+ EXECUTABLE = ttysolitaire
+ SRC_DIR = src
+@@ -39,6 +39,8 @@ TESTS_OBJECTS = $(TESTS_DIR)/frame_test.
+
+ .PHONY: test clean install uninstall
+
++all: ttysolitaire
++
+ ttysolitaire: $(SRC_OBJECTS)
+ $(CC) $(CFLAGS) $(SRC) -o $(EXECUTABLE) $(SRC_OBJECTS) $(LDFLAGS)
+
diff --git a/games/tty-solitaire/pkg-descr b/games/tty-solitaire/pkg-descr
new file mode 100644
index 000000000000..099906297128
--- /dev/null
+++ b/games/tty-solitaire/pkg-descr
@@ -0,0 +1,3 @@
+Ncurses-based klondike solitaire game
+
+WWW: https://github.com/mpereira/tty-solitaire