aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-08-29 13:47:15 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-08-29 13:47:15 +0000
commit83e0ccc36f3d8896d879500b4db8839703c71524 (patch)
treee6d112745e4c6e65d369bff8d78debaf43e09afa /games
parent41ba25ca525708d47075dd170ffe06998b161f4d (diff)
downloadports-83e0ccc36f3d8896d879500b4db8839703c71524.tar.gz
ports-83e0ccc36f3d8896d879500b4db8839703c71524.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/gtkatlantic/Makefile5
-rw-r--r--games/gtkatlantic/distinfo5
-rw-r--r--games/gtkatlantic/files/patch-src_client.c23
-rw-r--r--games/gtkatlantic/pkg-plist9
4 files changed, 30 insertions, 12 deletions
diff --git a/games/gtkatlantic/Makefile b/games/gtkatlantic/Makefile
index a4026dbac09e..a3bdc7491bca 100644
--- a/games/gtkatlantic/Makefile
+++ b/games/gtkatlantic/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gtkatlantic
-PORTVERSION= 0.4.4
-PORTREVISION= 1
+DISTVERSION= 0.6.3
CATEGORIES= games
MASTER_SITES= http://download.tuxfamily.org/gtkatlantic/downloads/v${PORTVERSION:R}/ \
SF/nemysisfreebsdp/${CATEGORIES}/:icons
@@ -17,7 +16,7 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
USES= gnome localbase:ldflags pkgconfig
-USE_GNOME= gtk20
+USE_GNOME= cairo gtk30 libxml2
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
diff --git a/games/gtkatlantic/distinfo b/games/gtkatlantic/distinfo
index 71c603b3f3a5..f71ab5995705 100644
--- a/games/gtkatlantic/distinfo
+++ b/games/gtkatlantic/distinfo
@@ -1,4 +1,5 @@
-SHA256 (gtkatlantic-0.4.4.tar.gz) = 188e6502438948cb46246b50d761f7e3588cdd2f6fc45fa7fada996d116073ae
-SIZE (gtkatlantic-0.4.4.tar.gz) = 962568
+TIMESTAMP = 1598708229
+SHA256 (gtkatlantic-0.6.3.tar.gz) = b24e20a47688459909c08c01a01095bcc18d6a2568c7fa91115e0e0adbf734e5
+SIZE (gtkatlantic-0.6.3.tar.gz) = 618449
SHA256 (gtkatlantic_icons.tar.gz) = 0686beae348ef8835190731ebe45af594da3db8ec7f9c38220bcb3138ef74a08
SIZE (gtkatlantic_icons.tar.gz) = 41163
diff --git a/games/gtkatlantic/files/patch-src_client.c b/games/gtkatlantic/files/patch-src_client.c
new file mode 100644
index 000000000000..0aac6fb4bc6b
--- /dev/null
+++ b/games/gtkatlantic/files/patch-src_client.c
@@ -0,0 +1,23 @@
+--- src/client.c.orig 2020-08-29 13:39:41 UTC
++++ src/client.c
+@@ -213,17 +213,17 @@ static void* client_connect_async(connection *c) {
+ #if defined(TCP_KEEPIDLE) && defined(TCP_KEEPINTVL) && defined(TCP_KEEPCNT)
+ /* 10s idle before keepalive probe */
+ opt = 10;
+- if (setsockopt(sock, SOL_TCP, TCP_KEEPIDLE, (char*)&opt, sizeof(opt))) {
++ if (setsockopt(sock, IPPROTO_TCP, TCP_KEEPIDLE, (char*)&opt, sizeof(opt))) {
+ fprintf(stderr, "setsockopt() TCP_KEEPIDLE failed on socket %d: %s\n", sock, strerror(errno));
+ }
+ /* 10s probe interval */
+ opt = 10;
+- if (setsockopt(sock, SOL_TCP, TCP_KEEPINTVL, (char*)&opt, sizeof(opt))) {
++ if (setsockopt(sock, IPPROTO_TCP, TCP_KEEPINTVL, (char*)&opt, sizeof(opt))) {
+ fprintf(stderr, "setsockopt() TCP_KEEPINTVL failed on socket %d: %s\n", sock, strerror(errno));
+ }
+ /* consider session down after 10 missed probes */
+ opt = 10;
+- if (setsockopt(sock, SOL_TCP, TCP_KEEPCNT, (char*)&opt, sizeof(opt))) {
++ if (setsockopt(sock, IPPROTO_TCP, TCP_KEEPCNT, (char*)&opt, sizeof(opt))) {
+ fprintf(stderr, "setsockopt() TCP_KEEPCNT failed on socket %d: %s\n", sock, strerror(errno));
+ }
+ #endif /* TCP_KEEPIDLE && TCP_KEEPINTVL && TCP_KEEPCNT */
diff --git a/games/gtkatlantic/pkg-plist b/games/gtkatlantic/pkg-plist
index f8919a0018c5..d00a5987f0ea 100644
--- a/games/gtkatlantic/pkg-plist
+++ b/games/gtkatlantic/pkg-plist
@@ -2,15 +2,8 @@ bin/gtkatlantic
%%DATADIR%%/board.png
%%DATADIR%%/cards.png
%%DATADIR%%/commands.png
-%%DATADIR%%/default.conf
-%%DATADIR%%/help.index
%%DATADIR%%/houses.png
-%%DATADIR%%/icon16x16.ico
-%%DATADIR%%/icon16x16.xpm
-%%DATADIR%%/icon32x32.ico
-%%DATADIR%%/icon32x32.xpm
%%DATADIR%%/interface.xml
-%%DATADIR%%/logo.png
%%DATADIR%%/stars.png
%%DATADIR%%/stars_m.png
%%DATADIR%%/themes/generic_gradient/cards.png
@@ -24,9 +17,11 @@ bin/gtkatlantic
%%DATADIR%%/themes/generic_gradient/tokens.png
%%DATADIR%%/tokens.png
share/icons/hicolor/128x128/apps/gtkatlantic.png
+share/icons/hicolor/16x16/apps/gtkatlantic.png
share/icons/hicolor/32x32/apps/gtkatlantic.png
share/icons/hicolor/48x48/apps/gtkatlantic.png
share/icons/hicolor/64x64/apps/gtkatlantic.png
share/icons/hicolor/72x72/apps/gtkatlantic.png
share/icons/hicolor/96x96/apps/gtkatlantic.png
share/pixmaps/gtkatlantic.png
+share/pixmaps/gtkatlantic.xpm