aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-12-21 23:27:51 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-12-21 23:27:51 +0000
commit843132459e844ef2d9cbb077d71992af300347a5 (patch)
tree17c44e1b832791637921e4c39d94938e8384183f /games
parent9c6fef98447fe0df2da9e8f3bfac781a50284b75 (diff)
Notes
Diffstat (limited to 'games')
-rw-r--r--games/dhewm3/Makefile2
-rw-r--r--games/dhewm3/files/patch-fix-ppc64le-build36
2 files changed, 37 insertions, 1 deletions
diff --git a/games/dhewm3/Makefile b/games/dhewm3/Makefile
index 2e0218432baa..57948d17a17e 100644
--- a/games/dhewm3/Makefile
+++ b/games/dhewm3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dhewm3
PORTVERSION= 1.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MAINTAINER= amdmi3@FreeBSD.org
diff --git a/games/dhewm3/files/patch-fix-ppc64le-build b/games/dhewm3/files/patch-fix-ppc64le-build
new file mode 100644
index 000000000000..87e377f6f6b6
--- /dev/null
+++ b/games/dhewm3/files/patch-fix-ppc64le-build
@@ -0,0 +1,36 @@
+From 12fa28b260c89d39fc4fe83ed02d92da172257a3 Mon Sep 17 00:00:00 2001
+From: yamir <yamir@localhost.localdomain>
+Date: Sun, 7 Jul 2019 18:07:39 +0200
+Subject: [PATCH] Fix ppc64le build
+
+---
+ neo/idlib/math/Simd_AltiVec.cpp | 2 +-
+ neo/idlib/math/Simd_AltiVec.h | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/neo/idlib/math/Simd_AltiVec.cpp b/neo/idlib/math/Simd_AltiVec.cpp
+index 96ac930a..8f8ab4ea 100644
+--- idlib/math/Simd_AltiVec.cpp
++++ idlib/math/Simd_AltiVec.cpp
+@@ -45,7 +45,7 @@ If you have questions concerning this license or the applicable additional terms
+ //
+ //===============================================================
+
+-#if defined(__GNUC__) && defined(__ALTIVEC__)
++#if defined(MACOS_X) && defined(__GNUC__) && defined(__ALTIVEC__)
+
+ #ifdef PPC_INTRINSICS
+ // for square root estimate instruction
+diff --git a/neo/idlib/math/Simd_AltiVec.h b/neo/idlib/math/Simd_AltiVec.h
+index 2a5776eb..d5080824 100644
+--- idlib/math/Simd_AltiVec.h
++++ idlib/math/Simd_AltiVec.h
+@@ -110,7 +110,7 @@ If you have questions concerning this license or the applicable additional terms
+ //#define DRAWVERT_PADDED
+
+ class idSIMD_AltiVec : public idSIMD_Generic {
+-#if defined(__GNUC__) && defined(__ALTIVEC__)
++#if defined(MACOS_X) && defined(__GNUC__) && defined(__ALTIVEC__)
+ public:
+
+ virtual const char * VPCALL GetName( void ) const;