aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-08-12 05:53:20 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-08-12 05:53:20 +0000
commit883c49ba5277950f2f31f4bed070ef2e37cbecab (patch)
tree442c5b012fd7398578a1d51b839c104be587c5cf /games
parentf67f1e10d20cdd047c87f8faedb99c722a7e3d80 (diff)
downloadports-883c49ba5277950f2f31f4bed070ef2e37cbecab.tar.gz
ports-883c49ba5277950f2f31f4bed070ef2e37cbecab.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/crossword/Makefile27
-rw-r--r--games/crossword/distinfo1
-rw-r--r--games/crossword/pkg-comment1
-rw-r--r--games/crossword/pkg-descr6
-rw-r--r--games/crossword/pkg-plist3
6 files changed, 39 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index cce0cdf5f9d1..3a87cdb982b3 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -59,6 +59,7 @@
SUBDIR += crimson
SUBDIR += crossfire-client
SUBDIR += crossfire-server
+ SUBDIR += crossword
SUBDIR += cryptoslam
SUBDIR += cursive
SUBDIR += deal
diff --git a/games/crossword/Makefile b/games/crossword/Makefile
new file mode 100644
index 000000000000..fbb7c669d1d3
--- /dev/null
+++ b/games/crossword/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: crossword
+# Date created: Aug 11, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= crossword
+PORTVERSION= 0.8.1
+CATEGORIES= games
+MASTER_SITES= http://www.ldc.usb.ve/~96-28234/
+
+MAINTAINER= ports@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/Crossword
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|^CFLAGS|#CFLAGS|g" ${WRKSRC}/Makefile
+
+do-install:
+.for file in crossword crossword_heur crw2tex
+ ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin
+.endfor
+
+.include <bsd.port.mk>
diff --git a/games/crossword/distinfo b/games/crossword/distinfo
new file mode 100644
index 000000000000..39809dceb6cf
--- /dev/null
+++ b/games/crossword/distinfo
@@ -0,0 +1 @@
+MD5 (crossword-0.8.1.tar.gz) = 6470f9ec820f3bc9e7dc7e8c3ec897b5
diff --git a/games/crossword/pkg-comment b/games/crossword/pkg-comment
new file mode 100644
index 000000000000..6e0ba4ebdc1d
--- /dev/null
+++ b/games/crossword/pkg-comment
@@ -0,0 +1 @@
+Crossword Generator
diff --git a/games/crossword/pkg-descr b/games/crossword/pkg-descr
new file mode 100644
index 000000000000..5bb31e54bc89
--- /dev/null
+++ b/games/crossword/pkg-descr
@@ -0,0 +1,6 @@
+Crossword Generator generates crosswords from scratch to PostScript. It just
+needs the board and a dictionary and it fills it up. It uses an optimized
+branch and bound algorithm to try all the posible combinations. There is also
+an optional heuristic to speed up the process. This heuristic is not exhastive,
+but it gives much better time that the normal one. When the crossword is ready
+it can translate it into TeX format so that it can be compiled using LaTeX.
diff --git a/games/crossword/pkg-plist b/games/crossword/pkg-plist
new file mode 100644
index 000000000000..2325a3503e83
--- /dev/null
+++ b/games/crossword/pkg-plist
@@ -0,0 +1,3 @@
+bin/crossword
+bin/crossword_heur
+bin/crw2tex