aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-05-11 18:34:57 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-05-11 18:34:57 +0000
commit88bfe4bd43787219ab4de75bd68c490c98776dfc (patch)
tree634e1ef4990207301493f26b46d80abe56b9f2b3 /games
parent9e8bfe9c71187ea60ac9f3a55c0c7bde80d76033 (diff)
downloadports-88bfe4bd43787219ab4de75bd68c490c98776dfc.tar.gz
ports-88bfe4bd43787219ab4de75bd68c490c98776dfc.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/blockade/Makefile4
-rw-r--r--games/fillets-ng/Makefile4
-rw-r--r--games/gnuchess/Makefile3
-rw-r--r--games/heroes/Makefile2
-rw-r--r--games/linux-enemyterritory-etpro/Makefile5
-rw-r--r--games/nimuh/Makefile2
-rw-r--r--games/pydance/Makefile4
-rw-r--r--games/tuxracer/Makefile2
-rw-r--r--games/unnethack/Makefile4
-rw-r--r--games/uqm/Makefile4
-rw-r--r--games/viruskiller/Makefile2
-rw-r--r--games/wmtictactoe/Makefile2
-rw-r--r--games/xmine/Makefile3
-rw-r--r--games/zangband/Makefile3
14 files changed, 19 insertions, 25 deletions
diff --git a/games/blockade/Makefile b/games/blockade/Makefile
index ed26400324e3..55d9fa92bdb1 100644
--- a/games/blockade/Makefile
+++ b/games/blockade/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= blockade
-PORTVERSION= 1.00
+DISTVERSION= 1_00
PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= http://www.sourcefiles.org/Games/Arcade/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/./_/}-linux
+DISTNAME= ${PORTNAME}-${DISTVERSION}-linux
MAINTAINER= ports@FreeBSD.org
COMMENT= X version of the `blockade' Macintosh game
diff --git a/games/fillets-ng/Makefile b/games/fillets-ng/Makefile
index 5b6654cb2a9d..ce19af874d65 100644
--- a/games/fillets-ng/Makefile
+++ b/games/fillets-ng/Makefile
@@ -5,9 +5,9 @@ PORTNAME= fillets-ng
PORTVERSION= 1.0.1
PORTREVISION= 6
CATEGORIES= games
-MASTER_SITES= SF/fillets/Fish%20Fillets%20-%20Next%20Generation/${PORTVERSION}:source \
+MASTER_SITES= SF/fillets/Fish%20Fillets%20-%20Next%20Generation/${PORTVERSION} \
SF/fillets/Fish%20Fillets%20-%20Next%20Generation/${DATAVERSION}:data
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:source \
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
${PORTNAME}-data-${DATAVERSION}${EXTRACT_SUFX}:data
MAINTAINER= amdmi3@FreeBSD.org
diff --git a/games/gnuchess/Makefile b/games/gnuchess/Makefile
index ce13ab313cbf..60ed9ea7f9d7 100644
--- a/games/gnuchess/Makefile
+++ b/games/gnuchess/Makefile
@@ -4,8 +4,7 @@
PORTNAME= gnuchess
PORTVERSION= 6.2.1
CATEGORIES= games
-MASTER_SITES= GNU
-MASTER_SITE_SUBDIR= chess
+MASTER_SITES= GNU/chess
# The DISTFILES here is explicitly needed because it can be extended later.
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
diff --git a/games/heroes/Makefile b/games/heroes/Makefile
index 47d4a8731fa3..1e2fc613e6d7 100644
--- a/games/heroes/Makefile
+++ b/games/heroes/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= SF \
SF/${PORTNAME}/${PORTNAME}-data/${DATAVERSION}:data \
SF/${PORTNAME}/${PORTNAME}-sound-effects/${SOUNDVERSION}:sound \
SF/${PORTNAME}/${PORTNAME}-sound-tracks/${MUSICVERSION}:music
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
${DATADISTNAME}${EXTRACT_SUFX}:data \
${SOUNDISTNAME}${EXTRACT_SUFX}:sound \
${MUSICDISTNAME}${EXTRACT_SUFX}:music
diff --git a/games/linux-enemyterritory-etpro/Makefile b/games/linux-enemyterritory-etpro/Makefile
index 8380ecc337b6..e49243af09b1 100644
--- a/games/linux-enemyterritory-etpro/Makefile
+++ b/games/linux-enemyterritory-etpro/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= etpro
-PORTVERSION= 3.2.6
+DISTVERSION= 3_2_6
CATEGORIES= games linux
MASTER_SITES= http://bani.anime.net/etpro/ \
http://dl.vpclan.de/etpro/ \
@@ -12,7 +12,6 @@ MASTER_SITES= http://bani.anime.net/etpro/ \
http://www.dakteam.org/ \
http://www.enemyterritory.cl/files/
PKGNAMEPREFIX= linux-enemyterritory-
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/./_/g}
MAINTAINER= ports@FreeBSD.org
COMMENT= ET Pro - Enemy Territory Competition Mod
@@ -25,7 +24,7 @@ NO_WRKSUBDIR= yes
DATADIR= ${PREFIX}/lib/enemyterritory/${PORTNAME}
-PLIST_SUB= VERSION="${PORTVERSION:S/./_/g}"
+PLIST_SUB= VERSION="${DISTVERSION}"
do-build:
.for f in et etded
diff --git a/games/nimuh/Makefile b/games/nimuh/Makefile
index 8af0bf19aaa0..d72435b29e70 100644
--- a/games/nimuh/Makefile
+++ b/games/nimuh/Makefile
@@ -6,7 +6,7 @@ PORTVERSION= 1.02
PORTREVISION= 10
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20${PORTVERSION}/Nimuh%20SRC%20%28Source%20Code%29
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} ${PORTNAME}-data-${PORTVERSION}${EXTRACT_SUFX}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${PORTNAME}-data-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Puzzle game destined to improve the knowledge of Andalusia
diff --git a/games/pydance/Makefile b/games/pydance/Makefile
index 75f5c697af88..cbf7ffce7a19 100644
--- a/games/pydance/Makefile
+++ b/games/pydance/Makefile
@@ -9,9 +9,9 @@ MASTER_SITES= http://people.freebsd.org/~sylvio/pydance/ \
http://icculus.org/pyddr/ \
http://offload1.icculus.org/pyddr/ \
http://www.informatik.uni-frankfurt.de/~polzer/distfiles/
-DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz ${SONGS}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${SONGS}
DIST_SUBDIR= pydance
-EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tar.gz
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Dancing simulation game similar to the kind in arcades
diff --git a/games/tuxracer/Makefile b/games/tuxracer/Makefile
index 69102885c42b..9722c13d68b7 100644
--- a/games/tuxracer/Makefile
+++ b/games/tuxracer/Makefile
@@ -7,7 +7,7 @@ PORTREVISION= 13
CATEGORIES= games
MASTER_SITES= SF \
SF/${PORTNAME}/${PORTNAME}-data/${PORTVERSION}:data
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
${PORTNAME}-data-${PORTVERSION}${EXTRACT_SUFX}:data
MAINTAINER= ports@FreeBSD.org
diff --git a/games/unnethack/Makefile b/games/unnethack/Makefile
index 52f8931708f2..5caab514274f 100644
--- a/games/unnethack/Makefile
+++ b/games/unnethack/Makefile
@@ -2,13 +2,11 @@
# $FreeBSD$
PORTNAME= unnethack
-PORTVERSION= 4.0.0.20120401
+DISTVERSION= 4.0.0-20120401
PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}
-DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}
-
MAINTAINER= knu@FreeBSD.org
COMMENT= New variant of NetHack
diff --git a/games/uqm/Makefile b/games/uqm/Makefile
index a21c8f8a463a..66331ca7ce0b 100644
--- a/games/uqm/Makefile
+++ b/games/uqm/Makefile
@@ -6,8 +6,8 @@ PORTVERSION= 0.7.0
PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= SF/sc2/UQM/${PORTVERSION:R}
-DISTFILES= ${PORTNAME}-${PORTVERSION}-source.tgz ${PORTNAME}-${DATAVERSION}-content.uqm
-EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}-source.tgz
+DISTFILES= ${DISTNAME}-source.tgz ${PORTNAME}-${DATAVERSION}-content.uqm
+EXTRACT_ONLY= ${DISTNAME}-source.tgz
MAINTAINER= mail@maxlor.com
COMMENT= Port of the original Star Control 2 for 3DO consoles
diff --git a/games/viruskiller/Makefile b/games/viruskiller/Makefile
index c43b3990f8bf..2f9e9d3e182c 100644
--- a/games/viruskiller/Makefile
+++ b/games/viruskiller/Makefile
@@ -3,10 +3,10 @@
PORTNAME= viruskiller
PORTVERSION= 1.03
+DISTVERSIONSUFFIX= -1
PORTREVISION= 7
CATEGORIES= games
MASTER_SITES= FRUGALWARE/games-extra/${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION}-1
MAINTAINER= ports@FreeBSD.org
COMMENT= Arcade game that relies on quick reflexes
diff --git a/games/wmtictactoe/Makefile b/games/wmtictactoe/Makefile
index 976b63f17a29..883f57c5c77d 100644
--- a/games/wmtictactoe/Makefile
+++ b/games/wmtictactoe/Makefile
@@ -3,10 +3,10 @@
PORTNAME= wmtictactoe
PORTVERSION= 1.1
+DISTVERSIONSUFFIX= -1
PORTREVISION= 3
CATEGORIES= games windowmaker afterstep
MASTER_SITES= LOCAL/jim
-DISTNAME= ${PORTNAME}-${PORTVERSION}-1
MAINTAINER= ports@FreeBSD.org
COMMENT= Dockable TicTacToe game for WindowMaker and AfterStep
diff --git a/games/xmine/Makefile b/games/xmine/Makefile
index 85bec0f5a896..af4b0b6bf6ee 100644
--- a/games/xmine/Makefile
+++ b/games/xmine/Makefile
@@ -6,8 +6,7 @@ PORTVERSION= 1.0.3
PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= ftp://ftp.sw.ru/pub/x11/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= joerg
+ LOCAL/joerg
DISTNAME= ${PORTNAME}-${PORTVERSION}-Xaw
MAINTAINER= joerg@FreeBSD.org
diff --git a/games/zangband/Makefile b/games/zangband/Makefile
index cbd1583279a7..685a9d819e76 100644
--- a/games/zangband/Makefile
+++ b/games/zangband/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= zangband
-PORTVERSION= 2.7.5.p1
+DISTVERSION= 2.7.5pre1
CATEGORIES+= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-src/${PORTVERSION:R}%20preview%20I
-DISTNAME= ${PORTNAME}-${PORTVERSION:R}pre1
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org