aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-09-29 11:17:14 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-09-29 11:17:14 +0000
commit91a7d9d4d3dfa3c3cc97d78ac398c83feebbcac2 (patch)
tree590af9cdaa9625a7327d4458c8556490b1eecd45 /games
parentd4e2a77842d54c6e325348d5b4378464e90a820d (diff)
Notes
Diffstat (limited to 'games')
-rw-r--r--games/netpanzer/Makefile24
-rw-r--r--games/netpanzer/pkg-plist1
2 files changed, 11 insertions, 14 deletions
diff --git a/games/netpanzer/Makefile b/games/netpanzer/Makefile
index 9ab26a0a132e..2ad4a862cb65 100644
--- a/games/netpanzer/Makefile
+++ b/games/netpanzer/Makefile
@@ -24,25 +24,21 @@ SCONS_BUILDENV= ${SCONS_ENV}
PORTDOCS= *
PORTDATA= *
-MAN6= netpanzer.6
-NO_STAGE= yes
post-configure:
${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/SConstruct
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/netpanzer ${PREFIX}/bin
- ${MKDIR} ${DATADIR}
- (cd ${WRKSRC} && ${COPYTREE_SHARE} "cache maps pics powerups scripts sound units wads" ${DATADIR})
- ${INSTALL_MAN} ${WRKSRC}/docs/netpanzer.6 ${MANPREFIX}/man/man6
- ${MKDIR} ${PREFIX}/share/applications
- ${INSTALL_DATA} ${WRKSRC}/netpanzer.desktop ${PREFIX}/share/applications
- ${INSTALL_DATA} ${WRKSRC}/netpanzer.png ${WRKSRC}/netpanzer.xpm ${PREFIX}/share/pixmaps
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_MAN} COPYING ChangeLog README RELNOTES TODO ${DOCSDIR})
- (cd ${WRKSRC}/docs && ${INSTALL_MAN} Doxyfile code-notes.txt coding.txt serverhowto.html tipofday.txt ${DOCSDIR})
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/netpanzer ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "cache maps pics powerups scripts sound units wads" ${STAGEDIR}${DATADIR})
+ ${INSTALL_MAN} ${WRKSRC}/docs/netpanzer.6 ${STAGEDIR}${MANPREFIX}/man/man6
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/netpanzer.desktop ${STAGEDIR}${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/netpanzer.png ${WRKSRC}/netpanzer.xpm ${STAGEDIR}${PREFIX}/share/pixmaps
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_MAN} COPYING ChangeLog README RELNOTES TODO ${STAGEDIR}${DOCSDIR})
+ (cd ${WRKSRC}/docs && ${INSTALL_MAN} Doxyfile code-notes.txt coding.txt serverhowto.html tipofday.txt ${STAGEDIR}${DOCSDIR})
do-fetch-svn:
svn export svn://svn.berlios.de/${PORTNAME}/tags/${PORTNAME}/${PORTVERSION} ${PORTNAME}-${PORTVERSION}
diff --git a/games/netpanzer/pkg-plist b/games/netpanzer/pkg-plist
index ee9e27eea36c..eb7d6e76b5a6 100644
--- a/games/netpanzer/pkg-plist
+++ b/games/netpanzer/pkg-plist
@@ -1,4 +1,5 @@
bin/netpanzer
+man/man6/netpanzer.6.gz
share/applications/netpanzer.desktop
share/pixmaps/netpanzer.png
share/pixmaps/netpanzer.xpm