aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-04-13 11:15:11 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-04-13 11:19:35 +0000
commit91f15977cec6282962f2fd6599799b16949e8c21 (patch)
tree03c6ec87629e13edbd10af71e73cee9a9a3fde08 /games
parent430ce7373fd96fe725183d49178f404b5d80e902 (diff)
downloadports-91f15977cec6282962f2fd6599799b16949e8c21.tar.gz
ports-91f15977cec6282962f2fd6599799b16949e8c21.zip
games/exult: fixup after aae00cbee1cef8d51abff5de932f7cf64c62dc87
Apparently, I did not pick up the very last patch in the PR. This additional commit adds the remaining bits discussed in the PR: * Convert to DISTVERSION * Use c++17 * Add missing glib dependency * Make ALSA optional * Reorder some variables PR: 254801 Reported by: gspurki@gmail.com
Diffstat (limited to 'games')
-rw-r--r--games/exult/Makefile61
-rw-r--r--games/exult/distinfo6
-rw-r--r--games/exult/pkg-descr13
-rw-r--r--games/exult/pkg-plist32
4 files changed, 67 insertions, 45 deletions
diff --git a/games/exult/Makefile b/games/exult/Makefile
index 29b4f1333a42..5124e4159b44 100644
--- a/games/exult/Makefile
+++ b/games/exult/Makefile
@@ -1,52 +1,65 @@
# Created by: Igor Pokrovsky <tiamat@telegraph.spb.ru>
PORTNAME= exult
-PORTVERSION= 1.7.0.20210405
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.7.0.20210410
+PORTREVISION= 1
CATEGORIES= games
MAINTAINER= ports@FreeBSD.org
-COMMENT= Ultima VII engine
+COMMENT= Engine for Ultima VII (BG, FOV, SI, SS)
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libvorbis.so:audio/libvorbis \
- libpng.so:graphics/png \
+LIB_DEPENDS= libfreetype.so:print/freetype2 \
libogg.so:audio/libogg \
- libfreetype.so:print/freetype2
+ libpng.so:graphics/png \
+ libvorbis.so:audio/libvorbis
-USES= autoreconf compiler:c++11-lib gmake libtool localbase pkgconfig \
- xorg sdl
+USES= autoreconf compiler:c++17-lang gmake libtool localbase \
+ pkgconfig sdl xorg
USE_GITHUB= yes
-GH_TAGNAME= 6150ae4
+GH_TAGNAME= snapshot-${DISTVERSIONPREFIX}${DISTVERSION}
+USE_GNOME= cairo gdkpixbuf2 glib20 gtk30
+USE_SDL= mixer2 sdl2
+USE_XORG= xext x11
-USE_CXXSTD= c++17
-USE_XORG= x11 xext
-USE_SDL= mixer2
-USE_GNOME= gtk30 cairo gdkpixbuf2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-alsa --with-sdl=sdl2 \
+
+CONFIGURE_ARGS= --disable-static \
+ --enable-shared \
--with-icondir=${PREFIX}/share/pixmaps
+
SUB_FILES= pkg-message
-OPTIONS_DEFINE= DOCS FLUIDSYNTH GIMP STUDIO THUMBNAILER
+OPTIONS_DEFINE= ALSA DOCS DEBUG FLUIDSYNTH GIMP STUDIO THUMBNAILER
OPTIONS_DEFAULT= STUDIO
OPTIONS_SUB= yes
-FLUIDSYNTH_LIB_DEPENDS= libfluidsynth.so:audio/fluidsynth
-FLUIDSYNTH_CONFIGURE_ENABLE= fluidsynth
GIMP_DESC= GIMP plugin support
-GIMP_LIB_DEPENDS= libgimp-2.0.so:graphics/gimp-app
-GIMP_CONFIGURE_ENABLE= gimp-plugin
-
STUDIO_DESC= Install Exult Studio
-STUDIO_CONFIGURE_ENABLE= exult-studio exult-studio-support
-STUDIO_USES= gnome
-STUDIO_USE= gnome=libglade2
THUMBNAILER_DESC= Gnome SHP thumbnailer support
-THUMBNAILER_USES= gnome shared-mime-info
-THUMBNAILER_USE= gnome=libgnomeui
+
+ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
+ALSA_CONFIGURE_ENABLE= alsa
+
+DEBUG_CONFIGURE_OFF= --with-debug=no
+DEBUG_CONFIGURE_ON= --with-debug=full --with-optimization=none
+
+FLUIDSYNTH_LIB_DEPENDS= libfluidsynth.so:audio/fluidsynth
+FLUIDSYNTH_CONFIGURE_ENABLE= fluidsynth
+
+GIMP_LIB_DEPENDS= libgimp-2.0.so:graphics/gimp-app
+GIMP_CONFIGURE_ENABLE= gimp-plugin
+
+STUDIO_CONFIGURE_ENABLE= exult-studio exult-studio-support
+STUDIO_USES= gnome
+STUDIO_USE= gnome=libglade2
+
+THUMBNAILER_USES= gnome shared-mime-info
+THUMBNAILER_USE= gnome=libgnomeui
THUMBNAILER_CONFIGURE_ENABLE= gnome-shp-thumbnailer
post-install-DOCS-on:
diff --git a/games/exult/distinfo b/games/exult/distinfo
index ee5a52407a5e..d190b1fbd8bb 100644
--- a/games/exult/distinfo
+++ b/games/exult/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1617640860
-SHA256 (exult-exult-1.7.0.20210405-6150ae4_GH0.tar.gz) = d124a8bc548d62dfbe034496d186b87aea4f29063febe28d92d7cf7be7148bd4
-SIZE (exult-exult-1.7.0.20210405-6150ae4_GH0.tar.gz) = 18460223
+TIMESTAMP = 1618045616
+SHA256 (exult-exult-v1.7.0.20210410-snapshot-v1.7.0.20210410_GH0.tar.gz) = ecbb5d40d374bec02d1c2d1b7c678519d8307d0ee9d0b000442ba6394fba84b2
+SIZE (exult-exult-v1.7.0.20210410-snapshot-v1.7.0.20210410_GH0.tar.gz) = 18460612
diff --git a/games/exult/pkg-descr b/games/exult/pkg-descr
index 13374afc307b..636aec50a461 100644
--- a/games/exult/pkg-descr
+++ b/games/exult/pkg-descr
@@ -1,6 +1,11 @@
-Exult is an engine built for running Ultima VII usecode. With Exult
-you can play both "The Black Gate" and "Serpent Isle" parts of the game.
-However, the original ORIGIN's Ultima VII data is required as Exult is
-just the engine. Refer to README file for details.
+Exult is an open source engine for playing Ultima VII on a variety of
+modern operating systems and environments. The Black Gate (including
+Forge of Virtue) and Serpent Isle (plus Silver Seed) are both playable
+to the end. Some differences to the original games exist; see sections
+5. of the FAQ.
+
+While it is possible to use the engine for other games, no such game has
+been written yet. Therefore, Exult is useless unless you own a copy of one
+of the Ultima VIIs.
WWW: http://exult.info
diff --git a/games/exult/pkg-plist b/games/exult/pkg-plist
index 5cecac851f81..ae81cbb15567 100644
--- a/games/exult/pkg-plist
+++ b/games/exult/pkg-plist
@@ -1,7 +1,8 @@
bin/cmanip
bin/expack
bin/exult
-bin/exult_studio
+%%STUDIO%%bin/exult_studio
+%%THUMBNAILER%%bin/gnome_shp_thumbnailer
bin/ipack
bin/mklink
bin/rip
@@ -19,6 +20,7 @@ man/man1/splitshp.1.gz
man/man1/textpack.1.gz
man/man1/ucc.1.gz
man/man6/exult.6.gz
+%%GIMP%%libexec/gimp/2.2/plug-ins/u7shp
share/applications/exult.desktop
%%PORTDOCS%%%%DOCSDIR%%/FAQ
%%PORTDOCS%%%%DOCSDIR%%/NEWS
@@ -46,22 +48,22 @@ share/applications/exult.desktop
%%PORTDOCS%%%%DOCSDIR%%/images/studio10.png
%%PORTDOCS%%%%DOCSDIR%%/images/studiobgiregs.png
%%PORTDOCS%%%%DOCSDIR%%/images/studiosiiregs.png
-%%DATADIR%%/estudio/new/avatar_data.txt
-%%DATADIR%%/estudio/new/blends.dat
-%%DATADIR%%/estudio/new/combos.flx
-%%DATADIR%%/estudio/new/faces.vga
-%%DATADIR%%/estudio/new/fonts.vga
-%%DATADIR%%/estudio/new/gumps.vga
-%%DATADIR%%/estudio/new/palettes.flx
-%%DATADIR%%/estudio/new/paperdol.vga
-%%DATADIR%%/estudio/new/pointers.shp
-%%DATADIR%%/estudio/new/shapes.vga
-%%DATADIR%%/estudio/new/sprites.vga
-%%DATADIR%%/estudio/new/text.flx
+%%STUDIO%%%%DATADIR%%/estudio/new/avatar_data.txt
+%%STUDIO%%%%DATADIR%%/estudio/new/blends.dat
+%%STUDIO%%%%DATADIR%%/estudio/new/combos.flx
+%%STUDIO%%%%DATADIR%%/estudio/new/faces.vga
+%%STUDIO%%%%DATADIR%%/estudio/new/fonts.vga
+%%STUDIO%%%%DATADIR%%/estudio/new/gumps.vga
+%%STUDIO%%%%DATADIR%%/estudio/new/palettes.flx
+%%STUDIO%%%%DATADIR%%/estudio/new/paperdol.vga
+%%STUDIO%%%%DATADIR%%/estudio/new/pointers.shp
+%%STUDIO%%%%DATADIR%%/estudio/new/shapes.vga
+%%STUDIO%%%%DATADIR%%/estudio/new/sprites.vga
+%%STUDIO%%%%DATADIR%%/estudio/new/text.flx
%%DATADIR%%/exult.flx
%%DATADIR%%/exult_bg.flx
%%DATADIR%%/exult_si.flx
-%%DATADIR%%/exult_studio.glade
+%%STUDIO%%%%DATADIR%%/exult_studio.glade
%%DATADIR%%/exultmsg.txt
%%DATADIR%%/midisfx.flx
%%DATADIR%%/u7bgintrinsics.data
@@ -69,4 +71,6 @@ share/applications/exult.desktop
%%DATADIR%%/u7opcodes.data
%%DATADIR%%/u7sibetaintrinsics.data
%%DATADIR%%/u7siintrinsics.data
+%%THUMBNAILER%%share/mime/packages/x-shapefile.xml
+%%THUMBNAILER%%share/thumbnailers/gnome_u7shapes.thumbnailer
share/pixmaps/exult.png