aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 00:44:22 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 00:48:20 +0000
commit95274bf4f99c71fc056013d966aec239161dfd74 (patch)
treebc1e95977678cb5b6b00b33e333b28161885e706 /games
parentdbe06d2da8c38d9d058f7939a7c6af36a2c0f1c7 (diff)
downloadports-95274bf4f99c71fc056013d966aec239161dfd74.tar.gz
ports-95274bf4f99c71fc056013d966aec239161dfd74.zip
Diffstat (limited to 'games')
-rw-r--r--games/alienarena/Makefile6
-rw-r--r--games/dxx-rebirth/Makefile11
-rw-r--r--games/falconseye/Makefile5
-rw-r--r--games/foobillard/Makefile2
-rw-r--r--games/gnuchess/Makefile20
-rw-r--r--games/gshisen/Makefile2
-rw-r--r--games/kevedit/Makefile2
-rw-r--r--games/libgnome-games-support/Makefile2
-rw-r--r--games/libretro-bluemsx/Makefile11
-rw-r--r--games/nethack34/Makefile2
-rw-r--r--games/prboom-plus/Makefile2
-rw-r--r--games/tuxpaint/Makefile2
-rw-r--r--games/tuxracer/Makefile2
-rw-r--r--games/xbubble/Makefile2
-rw-r--r--games/xlennart/Makefile2
-rw-r--r--games/xpipeman/Makefile2
-rw-r--r--games/xroach/Makefile2
-rw-r--r--games/xtrojka/Makefile2
18 files changed, 34 insertions, 45 deletions
diff --git a/games/alienarena/Makefile b/games/alienarena/Makefile
index 5446bb523df7..0d0b49d9e9ee 100644
--- a/games/alienarena/Makefile
+++ b/games/alienarena/Makefile
@@ -57,9 +57,9 @@ CLIENT_USE= GL=glu XORG=x11,xxf86dga,xxf86vm
LIBDIR= ${PREFIX}/lib/${PORTNAME}
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 160
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
@@ -91,4 +91,4 @@ do-install-DEDICATED-on:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}-ded \
${STAGEDIR}${PREFIX}/bin/${PORTNAME}-ded
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/dxx-rebirth/Makefile b/games/dxx-rebirth/Makefile
index 41689ce3133b..7e220e362b46 100644
--- a/games/dxx-rebirth/Makefile
+++ b/games/dxx-rebirth/Makefile
@@ -35,22 +35,21 @@ MAKE_ARGS= ignore_unknown_variables=1 sdl2=1
PLIST_FILES= bin/d1x-rebirth \
bin/d2x-rebirth
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
.if ${ARCH} != powerpc64 && ${ARCH} != riscv64
MAKE_ARGS+= lto=1
.endif
-.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 150
CPPFLAGS+= -Wno-error=unused-but-set-parameter -Wno-error=unused-but-set-variable
-.endif
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${COMPILER_VERSION} >= 160
CPPFLAGS+= -Wno-error=unused-result
.endif
+.endif
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/d1x-rebirth \
${STAGEDIR}${PREFIX}/bin/d2x-rebirth
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/falconseye/Makefile b/games/falconseye/Makefile
index f00121a090e3..31dcdc0b7e1b 100644
--- a/games/falconseye/Makefile
+++ b/games/falconseye/Makefile
@@ -34,11 +34,10 @@ NETHACKCONFIG= ${FILESDIR}/x-config
.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=int-conversion
-.endif
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 )
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
+.endif
post-patch:
@${REINPLACE_CMD} -i '' -e "s|<malloc.h>|<stdlib.h>|" \
diff --git a/games/foobillard/Makefile b/games/foobillard/Makefile
index da745cb82710..8a150a927014 100644
--- a/games/foobillard/Makefile
+++ b/games/foobillard/Makefile
@@ -44,7 +44,7 @@ FREETYPE_CONFIG?= pkg-config freetype2
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/games/gnuchess/Makefile b/games/gnuchess/Makefile
index b474e3209ef1..b057034b63a9 100644
--- a/games/gnuchess/Makefile
+++ b/games/gnuchess/Makefile
@@ -14,6 +14,7 @@ LICENSE= GPLv3+
USES= cpe shebangfix
CPE_VENDOR= gnu
CPE_PRODUCT= chess
+USE_CXXSTD= c++14
SHEBANG_FILES= doc/quotes.rb
@@ -30,27 +31,18 @@ OPENING_BOOK_DESC= Install opening book (25 MB download)
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
+OPENING_BOOK_DISTFILES= book_1.02.pgn.gz
+OPENING_BOOK_EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MOPENING_BOOK}
-DISTFILES+= book_1.02.pgn.gz
-EXTRACT_ONLY+= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
-.endif
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
-CPPFLAGS+= -Dregister=
-.endif
-
-post-build:
-.if ${PORT_OPTIONS:MOPENING_BOOK}
+post-build-OPENING_BOOK-on:
zcat ${DISTDIR}/book_1.02.pgn.gz > ${WRKSRC}/src/book.pgn
cd ${WRKSRC}/src && ( ${ECHO} book add book.pgn; sleep 1; ${ECHO} quit ) | ./gnuchess
@${REINPLACE_CMD} -e '/Book =/s/false/true/' ${WRKSRC}/src/gnuchess.ini
-.endif
post-install:
cd ${STAGEDIR}${PREFIX}/bin && ${LN} -f gnuchess gnuchessx
+
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/NEWS ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}
${RM} ${STAGEDIR}${DOCSDIR}/gnuchess.info
diff --git a/games/gshisen/Makefile b/games/gshisen/Makefile
index 61c0249d527f..a8960499570d 100644
--- a/games/gshisen/Makefile
+++ b/games/gshisen/Makefile
@@ -16,7 +16,7 @@ USE_GNUSTEP= back build
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/games/kevedit/Makefile b/games/kevedit/Makefile
index 385ffa048691..f82ffb85a27a 100644
--- a/games/kevedit/Makefile
+++ b/games/kevedit/Makefile
@@ -21,7 +21,7 @@ GNU_CONFIGURE= yes
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/games/libgnome-games-support/Makefile b/games/libgnome-games-support/Makefile
index a231aab75def..9194b1ddb11e 100644
--- a/games/libgnome-games-support/Makefile
+++ b/games/libgnome-games-support/Makefile
@@ -21,7 +21,7 @@ USE_GNOME= cairo gdkpixbuf2 gtk30
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/games/libretro-bluemsx/Makefile b/games/libretro-bluemsx/Makefile
index e1aea3ed4c80..8e3a77b27e0f 100644
--- a/games/libretro-bluemsx/Makefile
+++ b/games/libretro-bluemsx/Makefile
@@ -17,18 +17,17 @@ USE_LDCONFIG= yes
PLIST_FILES= lib/libretro/bluemsx_libretro.so
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 150
CFLAGS+= -Wno-error=int-conversion
-.endif
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${COMPILER_VERSION} >= 160
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
+.endif
do-install:
${MKDIR} ${STAGEDIR}/${PREFIX}/lib/libretro;
${INSTALL_LIB} ${WRKSRC}/bluemsx_libretro.so ${STAGEDIR}/${PREFIX}/lib/libretro;
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/nethack34/Makefile b/games/nethack34/Makefile
index a2cf4a77951a..a7fc45c6480a 100644
--- a/games/nethack34/Makefile
+++ b/games/nethack34/Makefile
@@ -81,7 +81,7 @@ PLIST_SUB+= HACKLINK=""
PLIST_SUB+= HACKLINK="@comment "
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/games/prboom-plus/Makefile b/games/prboom-plus/Makefile
index 0b0c62e51e15..6d2af709b358 100644
--- a/games/prboom-plus/Makefile
+++ b/games/prboom-plus/Makefile
@@ -35,7 +35,7 @@ OPENGL_CONFIGURE_ENABLE= gl
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/games/tuxpaint/Makefile b/games/tuxpaint/Makefile
index b1666b0a5045..861d1fb26efb 100644
--- a/games/tuxpaint/Makefile
+++ b/games/tuxpaint/Makefile
@@ -55,7 +55,7 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/games/tuxracer/Makefile b/games/tuxracer/Makefile
index fb116f808253..7e3f7b4bbe6b 100644
--- a/games/tuxracer/Makefile
+++ b/games/tuxracer/Makefile
@@ -31,7 +31,7 @@ CPPFLAGS+= -DGLX_GLXEXT_LEGACY
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/games/xbubble/Makefile b/games/xbubble/Makefile
index 00e3542d40ee..a47990e4fb76 100644
--- a/games/xbubble/Makefile
+++ b/games/xbubble/Makefile
@@ -27,7 +27,7 @@ NLS_LIBS= -lintl
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/games/xlennart/Makefile b/games/xlennart/Makefile
index 63f4392a2875..16bc7c44fe23 100644
--- a/games/xlennart/Makefile
+++ b/games/xlennart/Makefile
@@ -51,7 +51,7 @@ SCORES_DIR?= ${DATADIR}/scores
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/games/xpipeman/Makefile b/games/xpipeman/Makefile
index 31795e8d60e9..a4cc591c6eee 100644
--- a/games/xpipeman/Makefile
+++ b/games/xpipeman/Makefile
@@ -17,7 +17,7 @@ CFLAGS+= -Wno-error=return-type
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/games/xroach/Makefile b/games/xroach/Makefile
index d0787a3d0f69..075cfd830895 100644
--- a/games/xroach/Makefile
+++ b/games/xroach/Makefile
@@ -24,7 +24,7 @@ PLIST_FILES= bin/xroach man/man6/xroach.6.gz
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/games/xtrojka/Makefile b/games/xtrojka/Makefile
index 5ad5f0dfd1cc..282c055f3f3f 100644
--- a/games/xtrojka/Makefile
+++ b/games/xtrojka/Makefile
@@ -19,7 +19,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
.include <bsd.port.options.mk>
post-patch:
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
@${REINPLACE_CMD} -e 's|CFLAGS=|CFLAGS=-Wno-error=incompatible-function-pointer-types |g' \
${WRKSRC}/Makefile
.endif