aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-01-09 13:16:49 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-01-09 13:16:49 +0000
commit9d79e7b1469f6887d302e13ce7c67c54408a2453 (patch)
tree263754af5ddd95f1ad55b06c101378a0cf71009b /games
parenta0e384abe8236d5d12c69354d90c0de5342f7efb (diff)
downloadports-9d79e7b1469f6887d302e13ce7c67c54408a2453.tar.gz
ports-9d79e7b1469f6887d302e13ce7c67c54408a2453.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/bunnysay/Makefile11
-rw-r--r--games/darkplaces/Makefile4
-rw-r--r--games/pioneer/Makefile4
-rw-r--r--games/stonesoup/Makefile6
-rw-r--r--games/ufoai/Makefile4
5 files changed, 1 insertions, 28 deletions
diff --git a/games/bunnysay/Makefile b/games/bunnysay/Makefile
index 38f2ae733e20..b2d2bad71237 100644
--- a/games/bunnysay/Makefile
+++ b/games/bunnysay/Makefile
@@ -20,16 +20,7 @@ GH_ACCOUNT= co60ca
PLIST_FILES= bin/bunnysay
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
-LIB_DEPENDS+= libc++.so.1:devel/libc++
-CFLAGS+= -isystem${LOCALBASE}/include/c++/v1
-CXXFLAGS+= -isystem${LOCALBASE}/include/c++/v1
-LDFLAGS+= -L${LOCALBASE}/lib/c++
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/darkplaces/Makefile b/games/darkplaces/Makefile
index 4f600400e918..117b3ca569a4 100644
--- a/games/darkplaces/Makefile
+++ b/games/darkplaces/Makefile
@@ -41,10 +41,6 @@ SERVER_DESC= Build dedicated server
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
-USE_GCC= yes # internal compiler error on base gcc
-.endif
-
.if ${PORT_OPTIONS:MGLX} || ${PORT_OPTIONS:MSDL}
USE_GL= glu
PLIST_SUB+= CLIENT=""
diff --git a/games/pioneer/Makefile b/games/pioneer/Makefile
index fa0b31095977..0e8c953dd8c8 100644
--- a/games/pioneer/Makefile
+++ b/games/pioneer/Makefile
@@ -80,10 +80,6 @@ CXXFLAGS+= -D_GLIBCXX_USE_C99
post-patch: .SILENT
${REINPLACE_CMD} -e '/^OPTIMISE=/d' \
${WRKSRC}/configure.ac
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000054
- ${REINPLACE_CMD} -e 's/std::acosh/acosh/g ; s/std::copysign/copysign/g' \
- ${WRKSRC}/src/Orbit.cpp
-.endif
post-patch-MODELCOMPILER-off: .SILENT
${REINPLACE_CMD} -e 's/pioneer modelcompiler/pioneer/' \
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index 197ef1296b7b..104eef85ef30 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -74,12 +74,6 @@ LUA_MAKE_ARGS_OFF= NO_LUA_BINDINGS=yes
CFLAGS+= -D_GLIBCXX_USE_C99
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
-MAKE_ARGS+= NO_YACC=YesPlease
-CFLAGS+= -std=c++11
-LDFLAGS:= -Wl,-rpath=${_GCC_RUNTIME} ${LDFLAGS}
-.endif
-
post-patch-SOUND-on:
@${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE}," ${WRKSRC}/AppHdr.h
@${REINPLACE_CMD} -e "s,%%SOUND%%,," ${WRKSRC}/AppHdr.h
diff --git a/games/ufoai/Makefile b/games/ufoai/Makefile
index 4b8f82f66e74..4b0497ae2564 100644
--- a/games/ufoai/Makefile
+++ b/games/ufoai/Makefile
@@ -79,10 +79,6 @@ CONFIGURE_ARGS+=--disable-uforadiant
PLIST_SUB+= UFORADIANT="@comment "
.endif
-.if ${OSVERSION} < 1000024
-FAVORITE_COMPILER= gcc
-.endif
-
.include <bsd.port.pre.mk>
post-extract: