aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-12 23:56:46 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-12 23:56:46 +0000
commitb180849c7c6dd24f5d5602dbfab33a6763ef3603 (patch)
tree76cd98616d8a4cee1b947f413a7b7e558a82aac1 /games
parentf450fcbe6afe9d795ad4d23bdd104be1372d14e2 (diff)
downloadports-b180849c7c6dd24f5d5602dbfab33a6763ef3603.tar.gz
ports-b180849c7c6dd24f5d5602dbfab33a6763ef3603.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/griels-quest/Makefile24
-rw-r--r--games/griels-quest/distinfo2
-rw-r--r--games/griels-quest/pkg-descr9
-rw-r--r--games/griels-quest/pkg-plist53
5 files changed, 89 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index e4b39c47b7fd..bf816552cd76 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -372,6 +372,7 @@
SUBDIR += greed
SUBDIR += gretools
SUBDIR += grhino
+ SUBDIR += griels-quest
SUBDIR += gru
SUBDIR += grubik
SUBDIR += gshisen
diff --git a/games/griels-quest/Makefile b/games/griels-quest/Makefile
new file mode 100644
index 000000000000..ed0fb0f655b1
--- /dev/null
+++ b/games/griels-quest/Makefile
@@ -0,0 +1,24 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= griels-quest
+PORTVERSION= git20150512
+CATEGORIES= games
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Griel's Quest for the Sangraal
+
+LICENSE= GPLv3
+
+USE_GITHUB= yes
+GH_ACCOUNT= nevat
+GH_TAGNAME= 0282e6a2e3
+
+USE_SDL= sdl mixer image ttf gfx
+
+DATADIR= ${PREFIX}/share/griels
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/griels
+
+.include <bsd.port.mk>
diff --git a/games/griels-quest/distinfo b/games/griels-quest/distinfo
new file mode 100644
index 000000000000..d99def55409a
--- /dev/null
+++ b/games/griels-quest/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nevat-griels-quest-git20150512-0282e6a2e3_GH0.tar.gz) = e512c7da6d6d5055bb60229d70e8ae93d1124f7f237c3699641cf7a8b3628be1
+SIZE (nevat-griels-quest-git20150512-0282e6a2e3_GH0.tar.gz) = 6411052
diff --git a/games/griels-quest/pkg-descr b/games/griels-quest/pkg-descr
new file mode 100644
index 000000000000..3fcd4e9db961
--- /dev/null
+++ b/games/griels-quest/pkg-descr
@@ -0,0 +1,9 @@
+"Griel's Quest for the Sangraal" is a game released for MSX2 systems
+in the year 1990 (only on Japan). In 2005 was ported to MSX1 systems
+by Karoshi Corp.
+
+This version is a port of MSX1 version of the game to the GNU/Linux
+systems. Featuring all the levels, objects and enemies. The program
+is written in C language with the help of SDL 1.2 libraries.
+
+WWW: https://github.com/nevat/griels-quest
diff --git a/games/griels-quest/pkg-plist b/games/griels-quest/pkg-plist
new file mode 100644
index 000000000000..f9af05bb4249
--- /dev/null
+++ b/games/griels-quest/pkg-plist
@@ -0,0 +1,53 @@
+bin/griels
+share/applications/griels.desktop
+%%DATADIR%%/data/rounds.txt
+%%DATADIR%%/fx/fx_ding.ogg
+%%DATADIR%%/fx/fx_error.ogg
+%%DATADIR%%/fx/fx_giveup.ogg
+%%DATADIR%%/fx/fx_hahaha.ogg
+%%DATADIR%%/fx/fx_key.ogg
+%%DATADIR%%/fx/fx_kill.ogg
+%%DATADIR%%/fx/fx_ok.ogg
+%%DATADIR%%/fx/fx_poff.ogg
+%%DATADIR%%/fx/fx_start.ogg
+%%DATADIR%%/fx/fx_uaaah.ogg
+%%DATADIR%%/music/ending.ogg
+%%DATADIR%%/music/gameover.ogg
+%%DATADIR%%/music/history.ogg
+%%DATADIR%%/music/stage1.ogg
+%%DATADIR%%/music/stage2.ogg
+%%DATADIR%%/music/stage3.ogg
+%%DATADIR%%/music/stage4.ogg
+%%DATADIR%%/music/stage5.ogg
+%%DATADIR%%/music/stageclear.ogg
+%%DATADIR%%/png/blackbox.png
+%%DATADIR%%/png/blackbox2.png
+%%DATADIR%%/png/blocks.png
+%%DATADIR%%/png/ending1.png
+%%DATADIR%%/png/ending2.png
+%%DATADIR%%/png/ending3.png
+%%DATADIR%%/png/fonts.png
+%%DATADIR%%/png/gamehead.png
+%%DATADIR%%/png/gameover.png
+%%DATADIR%%/png/howtoplay.png
+%%DATADIR%%/png/icon.png
+%%DATADIR%%/png/karoshi.png
+%%DATADIR%%/png/menu.png
+%%DATADIR%%/png/passw1.png
+%%DATADIR%%/png/passw10.png
+%%DATADIR%%/png/passw2.png
+%%DATADIR%%/png/passw3.png
+%%DATADIR%%/png/passw4.png
+%%DATADIR%%/png/passw5.png
+%%DATADIR%%/png/passw6.png
+%%DATADIR%%/png/passw7.png
+%%DATADIR%%/png/passw8.png
+%%DATADIR%%/png/passw9.png
+%%DATADIR%%/png/password.png
+%%DATADIR%%/png/round.png
+%%DATADIR%%/png/soon.png
+%%DATADIR%%/png/startinfo.png
+%%DATADIR%%/png/startscreen.png
+%%DATADIR%%/png/texts.png
+%%DATADIR%%/png/theend.png
+share/pixmaps/griels.png